首页 > 选股公式 > 操盘手选股公式

操盘手选股公式

日期:2021-12-17 18:51:02

选股公式源码

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
M1:=BAIJIN1 AND BAIJIN2 AND BAIJIN3;
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
M2:=HUANGJIN1 AND HUANGJIN2;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4;
M3:=COUNT(XG,3)=1 AND XG AND C>MA(C,20);
A:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A1:=A AND B;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A2:=AA AND BA ;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=AAA AND BAA ;
B1:=REF(A1,1);
B2:=REF(A2,1);
B3:=REF(A3,1);
D1:=GJTJ1=100 AND GJTJ2=100 AND A1;
D2:=GJTJ1=100 AND GJTJ2=100 AND A2;
D3:=GJTJ1=100 AND GJTJ2=100 AND A3;
AQ:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
BQ:=BARSLAST(CROSS(GJTJ4,GJTJ2));
DQ:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
EQ:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
FQ:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
AW:=BARSLAST(CROSS(95,GJTJ1))<=2;
BW:=BARSLAST(CROSS(95,GJTJ2))<=2;
EW:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
FW:=GJTJ2>50 AND GJTJ3>50;
G:=GJTJ1=100 AND GJTJ2=100;
TX:=COUNT(G,2)=1;
AE:=GJTJ3=100;
BE:=GJTJ4<90;
操盘手: M1 OR M2 OR M3 OR D1 OR D2 OR D3 OR (AQ AND BQ AND DQ AND EQ AND FQ) OR (AW AND BW AND EW
AND FW AND TX) OR (COUNT(AE,2) = 2 AND BE);

选股公式翻译

GJTJ1赋值:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值)
GJTJ2赋值:100*(收盘价-10日内最低价的最低值)/(10日内收盘价的最高值-10日内最低价的最低值)
GJTJ3赋值:100*(收盘价-20日内最低价的最低值)/(20日内收盘价的最高值-20日内最低价的最低值)
GJTJ4赋值:100*(收盘价-30日内最低价的最低值)/(30日内收盘价的最高值-30日内最低价的最低值)
BAIJIN1赋值:上次30上穿GJTJ1距今天数<2 AND 上次GJTJ1上穿50距今天数<2
BAIJIN2赋值:上次GJTJ4上穿GJTJ1距今天数<2 AND GJTJ1>GJTJ4
BAIJIN3赋值:GJTJ1>60 AND GJTJ4>70
M1赋值:BAIJIN1 AND BAIJIN2 AND BAIJIN3
HUANGJIN1赋值:上次50上穿GJTJ1距今天数<3 AND 上次GJTJ1上穿50距今天数<3
HUANGJIN2赋值:上次GJTJ4上穿GJTJ1距今天数<2 AND GJTJ1>GJTJ4
M2赋值:HUANGJIN1 AND HUANGJIN2
XG赋值:上次GJTJ4上穿GJTJ1距今天数<5 AND GJTJ1>GJTJ4
M3赋值:统计3日中满足XG的天数=1 AND XG AND 收盘价>收盘价的20日简单移动平均
A赋值:上次97上穿GJTJ1距今天数<=1 AND 上次GJTJ1上穿85距今天数<=1
B赋值:上次97上穿GJTJ2距今天数<=1 AND 上次GJTJ2上穿85距今天数<=1
A1赋值:A AND B
AA赋值:上次97上穿GJTJ1距今天数<=2 AND 上次GJTJ1上穿85距今天数<=1
BA赋值:上次97上穿GJTJ2距今天数<=2 AND 上次GJTJ2上穿85距今天数<=1
A2赋值:AA AND BA
AAA赋值:上次97上穿GJTJ1距今天数<=3 AND 上次GJTJ1上穿85距今天数<=1
BAA赋值:上次97上穿GJTJ2距今天数<=3 AND 上次GJTJ2上穿85距今天数<=1
A3赋值:AAA AND BAA
B1赋值:1日前的A1
B2赋值:1日前的A2
B3赋值:1日前的A3
D1赋值:GJTJ1=100 AND GJTJ2=100 AND A1
D2赋值:GJTJ1=100 AND GJTJ2=100 AND A2
D3赋值:GJTJ1=100 AND GJTJ2=100 AND A3
AQ赋值:上次GJTJ4上穿GJTJ1距今天数>3 AND 上次GJTJ1上穿GJTJ4距今天数<3
BQ赋值:上次GJTJ4上穿GJTJ2距今天数
DQ赋值:GJTJ33 AND 上次GJTJ1上穿GJTJ4距今天数<3
FQ赋值:GJTJ250 AND GJTJ3>50
G赋值:GJTJ1=100 AND GJTJ2=100
TX赋值:统计2日中满足G的天数=1
AE赋值:GJTJ3=100
BE赋值:GJTJ4<90
输出操盘手: M1 OR M2 OR M3 OR D1 OR D2 OR D3 OR (AQ AND BQ AND DQ AND EQ AND FQ) OR (AW AND BW AND EWAND FW AND TX) OR (统计2日中满足AE的天数 = 2 AND BE)

演示图片