首页 > 选股公式 > 虎口夺食选股公式

虎口夺食选股公式

日期:2021-12-17 18:51:02

选股公式源码

RSV:=(((C-LLV(L,9))/(HHV(H,9)-LLV(L,9)))*100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3*K)-(2*D));
DIFF:=(EMA(C,12)-EMA(C,26));
DEA:=EMA(DIFF,9);
MACD2:=(2*(DIFF-DEA));
DIF:=DIFF;
macd:=DEA;
DEF:=MACD2;
CA1:=REF(C,1)>REF(O,1);
CA2:=O>=(REF(C,1)+REF(O,1))/2 AND REF(C,1)>=O;
CA3:=C>(REF(C,1)+REF(O,1))/2;
CA:=CA1 AND CA2 AND CA3;
CB1:=REF(C,1)<REF(O,1);
CB2:=C>O;CB:=CA2 AND CB1 AND CB2;
CC1:=(REF(C,1)+REF(O,1))/2>=O AND O>=REF(C,1);
CC2:=(REF(C,1)+REF(O,1))/2>=C;
CC:=CB1 AND CC1 AND CC2;
CD1:=(REF(C,1)+REF(O,1))/2>=O;
CD2:=O>=C;
CD:=CA1 AND CD1 AND CD2;
CE:=ABS((C-REF(C,1))/REF(C,1)*100)<3;
EB1:=(CA OR CB OR CC OR CD) AND CE;
CF:=BARSLAST(EB1);
EB2:=IF(REF(C,CF)>REF(O,CF),REF(O,CF),REF(C,CF));
EA1:=C>O; EA2:=C-MIN(MIN(REF(C,1),REF(O,1)),O);
EA3:=EA2/ABS(EB2-REF(C,1))*100>50;EA4:=J>REF(J,1);
EA5:=MAX(REF(C,2),REF(O,2))>MIN(O,MIN(REF(C,1),REF(O,1)));
EA6:=(DEF>REF(DEF,1) OR DEF>0) AND (MACD>REF(MACD,1) OR DIF>REF(DIF,1));
艺高胆大者指标:EA1 AND EA3 AND EA4 AND EA5 AND EA6;

选股公式翻译

RSV赋值:(((收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值))*100)
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:((3*K)-(2*D))
DIFF赋值:(收盘价的12日指数移动平均-收盘价的26日指数移动平均)
DEA赋值:DIFF的9日指数移动平均
MACD2赋值:(2*(DIFF-DEA))
DIF赋值:DIFF
MACD赋值:DEA
DEF赋值:MACD2
CA1赋值:1日前的收盘价>1日前的开盘价
CA2赋值:开盘价>=(1日前的收盘价+1日前的开盘价)/2 AND 1日前的收盘价>=开盘价
CA3赋值:收盘价>(1日前的收盘价+1日前的开盘价)/2
CA赋值:CA1 AND CA2 AND CA3
CB1赋值:1日前的收盘价<1日前的开盘价
CB2赋值:收阳线
CB赋值:CA2 AND CB1 AND CB2
CC1赋值:(1日前的收盘价+1日前的开盘价)/2>=开盘价 AND 开盘价>=1日前的收盘价
CC2赋值:(1日前的收盘价+1日前的开盘价)/2>=收盘价
CC赋值:CB1 AND CC1 AND CC2
CD1赋值:(1日前的收盘价+1日前的开盘价)/2>=开盘价
CD2赋值:开盘价>=收盘价
CD赋值:CA1 AND CD1 AND CD2
CE赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100的绝对值<3
EB1赋值:(CA OR CB OR CC OR CD) AND CE
CF赋值:上次EB1距今天数
EB2赋值:如果CF日前的收盘价>CF日前的开盘价,返回CF日前的开盘价,否则返回CF日前的收盘价
EA1赋值:收阳线
EA2赋值:收盘价-1日前的收盘价和1日前的开盘价的较小值和开盘价的较小值
EA3赋值:EA2/EB2-1日前的收盘价的绝对值*100>50
EA4赋值:J>1日前的J
EA5赋值:2日前的收盘价和2日前的开盘价的较大值>开盘价和1日前的收盘价和1日前的开盘价的较小值的较小值
EA6赋值:(DEF>1日前的DEF OR DEF>0) AND (MACD>1日前的MACD OR DIF>1日前的DIF)
输出艺高胆大者指标:EA1 AND EA3 AND EA4 AND EA5 AND EA6

演示图片