首页 > 选股公式 > 主力轨迹选股公式

主力轨迹选股公式

日期:2021-12-17 18:51:02

选股公式源码

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MTGJ:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);
MAZL:=MA(ZLGJ,5);
主力轨迹:ABV>M2 AND MMS>MML AND CROSS(ZLGJ,MAZL) AND ZLGJ>REF(ZLGJ,1) AND MAZL>REF(MAZL,1);

选股公式翻译

ABV赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回如果收盘价<1日前的收盘价,返回-成交量(手),否则返回0的历史累和/25000的2日简单移动平均
M1赋值:ABV的12日指数移动平均
M2赋值:ABV的26日指数移动平均
MTM赋值:收盘价-1日前的收盘价
MMS赋值:((100)*(MTM的6日指数移动平均的6日指数移动平均))/(MTM的绝对值的6日指数移动平均的6日指数移动平均)
MMM赋值:((100)*(MTM的12日指数移动平均的12日指数移动平均))/(MTM的绝对值的12日指数移动平均的12日指数移动平均)
MML赋值:((100)*(MTM的26日指数移动平均的26日指数移动平均))/(MTM的绝对值的26日指数移动平均的26日指数移动平均)
MTGJ赋值:收盘价-1日前的收盘价
ZLGJ赋值:100*MTGJ的9日指数移动平均的9日指数移动平均/MTGJ的绝对值的9日指数移动平均的9日指数移动平均
MAZL赋值:ZLGJ的5日简单移动平均
输出主力轨迹:ABV>M2 AND MMS>MML AND ZLGJ上穿MAZL AND ZLGJ>1日前的ZLGJ AND MAZL>1日前的MAZL

演示图片