首页 > 选股公式 > 买入大涨选股公式

买入大涨选股公式

日期:2021-12-17 18:51:02

选股公式源码

Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
A1:=SMA(HIGH,21,2)*1.05;
A2:=SMA(LOW,21,2)*0.95;
A3:=SMA(LOW,5,1);
A4:=SMA(CLOSE,2,1);
买入:=IF(CROSS(A4,A3),A1*1.05,A3);
大涨:=IF(CROSS(A4,A1),A1*1.10,A2);
XG:IF(大涨>A2 OR 买入>A3 AND CROSS(C,ZX) AND VOL>0,10,0);

选股公式翻译

Z1赋值:收盘价的13日简单移动平均
ZX赋值:13/2+1日前的Z1
A1赋值:最高价的21日[2日权重]移动平均*1.05
A2赋值:最低价的21日[2日权重]移动平均*0.95
A3赋值:最低价的5日[1日权重]移动平均
A4赋值:收盘价的2日[1日权重]移动平均
买入赋值:如果A4上穿A3,返回A1*1.05,否则返回A3
大涨赋值:如果A4上穿A1,返回A1*1.10,否则返回A2
输出XG:如果大涨>A2OR买入>A3ANDCROSS(收盘价,ZX)ANDVOL>0,返回10,否则返回0

演示图片