首页 > 选股公式 > 启动关注选股公式

启动关注选股公式

日期:2021-12-17 18:51:02

选股公式源码

RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
WEN:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
J1:=SMA(RSV1,3,1);J2:=SMA(J1,3,1);
W1:=SMA(RSV2,3,1);W2:=SMA(W1,3,1);
出点准备:=IF(CROSS(J2,J1) AND J2>85,70,100);
趋势线:= WEN,LINETHICK2;
买点准备:=IF(趋势线<=10,30,0);
G1:=W1,LINETHICK2,COLORWHITE;
G2:=W2,LINETHICK2,COLORCYAN;
TJ6:= MA(C,30)>=REF(MA(C,30),1) AND MA(C,5)>REF(MA(C,5),1);
A4:="MACD.DIF">REF("macd.DIF",2);
信号:CROSS(趋势线,G1) AND CROSS(趋势线,G1) AND TJ6 AND A4 AND G1>=REF(G1,1);

选股公式翻译

RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
RSV2赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
WEN赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
J1赋值:RSV1的3日[1日权重]移动平均
J2赋值:J1的3日[1日权重]移动平均
W1赋值:RSV2的3日[1日权重]移动平均
W2赋值:W1的3日[1日权重]移动平均
出点准备赋值:如果J2上穿J1ANDJ2>85,返回70,否则返回100
趋势线赋值: WEN,线宽为2
买点准备赋值:如果趋势线<=10,返回30,否则返回0
G1赋值:W1,线宽为2,画白色
G2赋值:W2,线宽为2,画青色
TJ6赋值: 收盘价的30日简单移动平均>=1日前的收盘价的30日简单移动平均 AND 收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均
A4赋值:"平滑异同平均的DIF">2日前的"平滑异同平均的DIF"
输出信号:趋势线上穿G1 AND 趋势线上穿G1 AND TJ6 AND A4 AND G1>=1日前的G1

演示图片