首页 > 选股公式 > OBV黄线30度选股公式

OBV黄线30度选股公式

日期:2021-12-17 19:03:02

选股公式源码

M:=30;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV,M);
A1:=OBV>MaoBV;
A2:=ATAN((MAOBV/REF(MAOBV,1)-1)*100)*180/3.1416;
A3:=A2>30;
A4:=LAst(A3,20,0);
A5:=(HHV(H,20)-LLV(L,20))/LLV(L,20)*100<30;
XG:A4 AND A5 ;

选股公式翻译

M赋值:30
VA赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回-成交量(手)
OBV赋值:如果收盘价=1日前的收盘价,返回0,否则返回VA的历史累和
MAOBV赋值:OBV的M日简单移动平均
A1赋值:OBV>MAOBV
A2赋值:(MAOBV/1日前的MAOBV-1)*100的反正切*180/3.1416
A3赋值:A2>30
A4赋值:从前20日到前0日持续A3
A5赋值:(20日内最高价的最高值-20日内最低价的最低值)/20日内最低价的最低值*100<30
输出XG:A4 AND A5 

演示图片

OBV黄线30度选股公式