首页 > 选股公式 > 共振乾坤选股公式

共振乾坤选股公式

日期:2021-12-17 19:03:02

选股公式源码

X_1:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
X_2:=5;
X_3:=3;
X_4:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
X_5:=IF(YEAR>=2025,0,1);
X_6:=EMA(EMA(LOW,21)+6.8*STD(LOW,2),55);
X_7:=EMA(CLOSE/X_6*(1.88*CLOSE+LOW+OPEN)/2.75,3);
X_8:=(X_7-X_6)/X_6/2;
X_9:=EMA(X_7-X_8*X_7,5)*X_5;
X_10:=EMA(CLOSE,34)-3*STD(CLOSE,34);
X_11:=IF(X_4>X_9,X_4,X_9)*X_5;
X_12:=IF(X_9<X_4 AND X_9<CLOSE*0.15,EMA(CLOSE,34)-3*STD(CLOSE,34),X_9);
X_13:=BARSLASTCOUNT(X_11>X_12)=1;
X_14:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
X_15:=(X_14-LLV(X_14,27))/(HHV(X_14,27)-LLV(X_14,27))*4*25;{股旁网 WWW.GUPANG.COM}
X_16:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
X_17:=SMA(X_16,10,1);
X_18:=SMA(X_17,5,1);
X_19:=INTPART(X_17);
X_20:=INTPART(X_18);
X_21:=X_19+X_20;
X_22:=MOD(X_21,10);
X_23:=(X_21-REF(X_21,1))*10;
X_24:=X_21+X_23;
X_25:=EMA(WINNER(CLOSE)*70,3);
X_26:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
X_27:=X_25/(X_25+X_26)*100;
X_28:=EMA(WINNER(CLOSE)*40,3);
X_29:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
X_30:=X_29/(X_28+X_29)*100;
X_31:=X_28/(X_28+X_29)*100;
X_32:=EMA(X_30,55);
X_33:=EMA(X_31,55);
X_34:=HHV((HIGH+LOW)/2,120);
X_35:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
X_36:=MA(CLOSE,27);
X_37:=VOL/FINANCE(7)*100;
X_38:=TMA(X_37,1-X_37,1);
X_39:=DMA((CLOSE+OPEN)/2,X_37/TMA(X_37,1-X_37,1));
X_40:=BARSLAST(CLOSE>X_39*POW(1.1,0.9));
X_41:=BARSLAST(CLOSE<X_39*POW(1.1,(-0.9)));
X_42:=CROSS(X_40,X_41) OR CROSS(X_41,X_40) OR BARSSINCE(X_40+1)=0 OR BARSSINCE(X_41+1)=0 OR BARSCOUNT(CLOSE)=0;
X_43:=REF(X_39,BARSLAST(X_42));
X_44:=LN(CLOSE/X_43)/LN(1.1)*10;
X_45:=VOL/CAPITAL*100;
X_46:=WINNER(CLOSE/1.1)*100;
X_47:=WINNER(CLOSE/1.2)*100;
X_48:=WINNER(CLOSE/1.25)*100;
X_49:=EMA(EMA(CLOSE,1),5);
X_50:=EMA(HHV(X_49,5),1);
X_51:=EMA(HHV(X_50,21),1);
X_52:=EMA(HHV(X_51,21),2);
X_53:=EMA(HHV(X_52,21),3);
X_54:=EMA(HHV(X_53,21),4);
X_55:=EMA(HHV(X_54,21),5);
X_56:=CLOSE;
X_57:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
X_58:=IF(CLOSE>200,CLOSE,DMA(X_57,VOL/CAPITAL))*1.1;
X_59:=EMA(HHV(X_55,21),6);
X_60:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
X_61:=SUM(IF(CLOSE=REF(CLOSE,1),0,X_60),0);
X_62:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
X_63:=SMA(X_62,3,1);
X_64:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_65:=SMA(X_64,5,1)-8;
X_66:=X_65-X_63;
X_67:=(HIGH+OPEN+LOW+3*CLOSE)/6;
X_68:=EMA(100-100/(1+SUM(IF(X_67>REF(X_67,1),X_67*VOL,0),14)/SUM(IF(X_67<REF(X_67,1),X_67*VOL,0),14)),5);
X_69:=CROSS(X_56,X_59);
X_70:=2*CLOSE+OPEN+HIGH+LOW;
X_71:=(X_70/EMA(X_70,4)-1)*100;
X_72:=X_71*5;
X_73:=X_23;
X_74:=ATAN((X_68/REF(X_68,1)-1)*100)*180/3.1416;
X_75:=ATAN((X_72/REF(X_72,1)-1)*100)*180/3.1416;
X_76:=(X_72-REF(X_72,1))*100/REF(X_72,1);
X_77:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1);
X_78:=SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,15);
X_79:=DYNAINFO(4)=0;
X_80:=IF(X_35>X_36 AND X_29<X_28 AND (X_15>50 OR X_15>REF(X_15,1)),(-40),0);
X_81:=IF(COUNT(X_69,20) AND X_28>X_29 AND X_31>X_33 AND X_48>30 AND X_15>X_31 AND X_15>60 AND X_77>=0.5 AND MAX(CLOSE,X_35) AND COUNT(CLOSE>X_35,10),18,0);
X_82:=IF(X_81>10 AND X_77>=0.5 AND X_80=(-40),88,0);
X_83:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
X_84:=EMA((CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100,4)*2;
X_85:=MA(CLOSE,1);
X_86:=SMA(SMA(SMA(X_85,2,1),2,1),2,1);
X_87:=HHV(MA(X_86,1),13);
X_88:=IF(X_44>0 AND X_44<150 AND X_15>50 AND CLOSE>X_58 AND X_56>X_59 AND X_45<20 AND X_76>10 AND X_74>2 AND X_28>X_29,208,0);
X_89:=3*SMA((CLOSE-LLV(LOW,480))/(HHV(HIGH,480)-LLV(LOW,480))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,480))/(HHV(HIGH,480)-LLV(LOW,480))*100,180,1),15,1);
X_90:=EMA(X_89,5);
X_91:=X_90-100;
X_92:=EMA(CLOSE,5);
X_93:=(EMA(CLOSE,1)+EMA(CLOSE,5)+EMA(CLOSE,10)+EMA(CLOSE,15)+EMA(CLOSE,20)+EMA(CLOSE,25)+EMA(CLOSE,30)+EMA(CLOSE,35)+EMA(CLOSE,40)+EMA(CLOSE,45)+EMA(CLOSE,50)+EMA(CLOSE,55)+EMA(CLOSE,60)+EMA(CLOSE,65)+EMA(CLOSE,70)+EMA(CLOSE,75)+EMA(CLOSE,80)+EMA(CLOSE,85)+EMA(CLOSE,90)+EMA(CLOSE,95)+EMA(CLOSE,100)+EMA(CLOSE,105)+EMA(CLOSE,110)+EMA(CLOSE,115)+EMA(CLOSE,120)+EMA(CLOSE,125)+EMA(CLOSE,130)+EMA(CLOSE,135)+EMA(CLOSE,140)+EMA(CLOSE,150))/30;
X_94:=X_92/X_93*100;
X_95:=X_94-110;
X_96:=(HIGH+LOW+2*CLOSE)/4;
X_97:=(X_96-REF(X_96,3))/3+X_96;
X_98:=EMA(X_97,7);
X_99:=EMA(HHV(X_97,20),60);
X_100:=EMA(COST(80),30);
X_101:=EMA(1.4*EMA(FORCAST(X_97,20),40),20);
X_102:=(X_99+X_100+X_101)/3;
X_103:=EMA(EMA(CLOSE*1.38,50),50);
X_104:=SMA(HIGH,21,2)*1.05;
X_105:=SMA(LOW,21,2)*0.95;
X_106:=(X_104+X_105)/2;
X_107:=X_106+2*STD(X_106,20);
X_108:=REF(X_107,0);
X_109:=ABS((2*CLOSE+HIGH+LOW)/4-MA(X_97,20))/MA(X_97,20);
X_110:=DMA(CLOSE,X_109);
X_111:=(1+9/100)*X_110;
X_112:=(1-7/100)*X_110;
X_113:=(REF((X_102+X_103+EMA(X_107*1.04,40)+X_111)/4,10)+MA(CLOSE,20)*1.04)/2;
X_114:=HIGH*VOL;
X_115:=EMA((EXPMA(X_114,180)/EXPMA(VOL,180)+EXPMA(X_114,360)/EXPMA(VOL,360)+EXPMA(X_114,720)/EXPMA(VOL,720)+EXPMA(X_114,1440)/EXPMA(VOL,1440))/4,34);
X_116:=1.06*X_115;
X_117:=X_115*0.94;
X_118:=EMA((EXPMA(X_114,27)/EXPMA(VOL,27)+EXPMA(X_114,54)/EXPMA(VOL,54)+EXPMA(X_114,108)/EXPMA(VOL,108)+EXPMA(X_114,316)/EXPMA(VOL,316))/4,34);
X_119:=1.06*X_118;
X_120:=X_118*0.94;
X_121:=EMA((EXPMA(X_114,5)/EXPMA(VOL,5)+EXPMA(X_114,10)/EXPMA(VOL,10)+EXPMA(X_114,20)/EXPMA(VOL,20)+EXPMA(X_114,40)/EXPMA(VOL,40))/4,34);
X_122:=1.06*X_121;
X_123:=X_121*0.94;
X_124:=(X_116+X_122+X_119)/3*1.05;
X_125:=(X_98*2/(X_113+X_124)-1)*100;
X_126:=MA(COST(80),20);
X_127:=(X_98/X_126-1)*100;
X_128:=(HHV(HIGH,42)-LLV(LOW,42))/2+LLV(LOW,42);
X_129:=ABS(HHV(HIGH,40)-LLV(LOW,40)-LLV(LOW,40))+X_128*0.5;
X_130:=(X_128/X_129-1)*100;
X_131:=EMA(EMA(CLOSE*1.14,55),20);
X_132:=(X_98/X_131-1)*100;
X_133:=(EMA(HHV(HIGH,60),60)+EMA(X_128,453)*1.62)/2;
X_134:=(X_98/X_133-1)*100;
X_135:=(X_91+X_95+X_125+X_127+X_130+X_132+X_134)/2;
X_136:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_137:=VOL*100/CAPITAL;
X_138:=MA(X_137,4);
X_139:=MA(X_137,9);
X_140:=MA(X_137,17);
X_141:=MA(X_137,34);
X_142:=(X_138+X_139+X_140+X_141)/4;
X_143:=VOL;
X_144:=X_138-X_142;
X_145:=X_139-X_142;
X_146:=IF(X_80<0 AND REF(X_144,1)>0 AND (CLOSE/REF(CLOSE,4)-1)*100<15 AND X_56>X_59 AND X_56>X_34 AND X_77>0 AND X_144>REF(X_144,1)*1.5 AND X_145>REF(X_145,1) AND X_144>0 AND X_15>X_31,80,0);
X_147:=MA(CLOSE,7);
X_148:=MA(CLOSE,14);
X_149:=MA(CLOSE,21);
X_150:=MA(CLOSE,34);
X_151:=MA(CLOSE,55);
X_152:=CROSS(X_147,X_150);
X_153:=X_147>X_148>X_149>X_150;
X_154:=MA(VOL,5);
X_155:=MA(VOL,10);
X_156:=CROSS(X_154,X_155);
X_157:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_158:=EMA(X_157,9);
X_159:=(X_157-X_158)*2;
X_160:=CROSS(X_157,X_158);
X_161:=X_152 AND X_156 AND X_160;
X_162:=3*SMA((CLOSE-LLV(LOW,180))/(HHV(HIGH,180)-LLV(LOW,180))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,180))/(HHV(HIGH,180)-LLV(LOW,180))*100,180,1),15,1);
X_163:=BARSLASTCOUNT(100*(HHV(HIGH,20)-LLV(LOW,20))/LLV(LOW,20)<30 AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1))>=5 AND BARSLASTCOUNT(100*(HHV(HIGH,14)-LLV(LOW,20))/LLV(LOW,20)<15 AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1))<=30;
X_164:=COUNT(REF(X_163,1)<=0.25 AND CLOSE>OPEN AND CLOSE>=REF(HHV(CLOSE,15),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04,15)=1;
X_165:=IF(X_164 AND X_48>30 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 AND CLOSE>=X_59 AND (CLOSE-REF(CLOSE,20))/REF(CLOSE,20)>0 AND (CLOSE-REF(CLOSE,20))/REF(CLOSE,20)<0.25,218,0);
X_166:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1);
X_167:=(REF(CLOSE,1)-REF(CLOSE,5))*100/REF(CLOSE,5);
X_168:=(REF(CLOSE,1)-REF(CLOSE,10))*100/REF(CLOSE,10);
X_169:=(-EMA(X_162,5))/4;
X_170:=(CLOSE-REF(CLOSE,20))*100/REF(CLOSE,20);
X_171:=IF(X_82>18 AND X_88>10 AND X_168<10,218,0);
X_172:=IF(COUNT(X_135>X_169,5)>=1 AND X_167>1 AND X_80<0 AND X_86=X_87 AND X_56>X_59*0.95 AND X_166>=3 AND X_168<20 OR (X_165>18 AND COUNT(CROSS(X_135,X_169),5)=1) OR (X_146>18 AND X_168<20) OR X_171>8,18,0);
X_173:=COUNT(CROSS(X_135,X_169),5)=1 AND X_170>4 AND X_86=X_87 AND X_168<20 AND X_56>X_59*1.05;
X_174:=FILTER(X_173,30);
X_175:=HIGH=HHV(X_135,10);
X_176:=(HIGH-LOW)/REF(CLOSE,1)*100;
X_177:=HHV(X_176,15);
X_178:=(REF(CLOSE,1)-REF(CLOSE,2))/REF(CLOSE,2)*100;
X_179:=(REF(CLOSE,2)-REF(CLOSE,3))/REF(CLOSE,3)*100;
X_180:=(CLOSE-REF(CLOSE,50))/REF(CLOSE,50)*100;
X_181:=(CLOSE-OPEN)/OPEN*100;
X_182:=(REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*100;
X_183:=OPEN>REF(HIGH,1) AND LOW>REF(HIGH,1) AND CLOSE>OPEN AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100>1.5;
X_184:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100>2;
X_185:=COUNT(OPEN>REF(CLOSE,1),2)>=2;
X_186:=COUNT(OPEN>REF(HIGH,1) AND LOW>REF(HIGH,1),10);
X_187:=COUNT(OPEN>REF(CLOSE,1) AND LOW>REF(CLOSE,1),10) AND LOW<OPEN;
X_188:=COUNT(OPEN>REF(CLOSE,1) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100>0.1 AND CLOSE>REF(HIGH,1),10);
X_189:=SMA(ABS(HIGH-X_62),13,1)/SMA(MIN(HIGH-X_62,0),10,1);
X_190:=EMA(X_189,10);
X_191:=HHV(HIGH,33);
X_192:=EMA(IF(HIGH>=X_191,X_190,0),3);
X_193:=(CLOSE/REF(CLOSE,1)-1)*100;
X_194:=RANGE(X_193,1.07,1.1) OR CLOSE=HIGH;
X_195:=REF(X_194,2);
X_196:=REF(CLOSE,1)<REF(OPEN,1);
X_197:=CLOSE>(REF(CLOSE,1)+REF(CLOSE,1))/1.9;
X_198:=CLOSE*FINANCE(7)/100000000<60;
X_199:=IF(X_195 AND X_196 AND X_197 AND X_198,18,0);
X_200:=IF(X_192<REF(X_192,1) AND X_182<3,18,0);
X_201:=(REF(CLOSE,1)-OPEN)/REF(CLOSE,1)*100>2.5 AND (CLOSE-OPEN)/OPEN*100>2 AND X_167<30 AND X_168<40 AND X_135>=REF(X_135,1);
X_202:=FILTER(X_166>5 AND X_178>5 AND (X_135>=REF(X_135,1) AND CLOSE>X_59 AND X_168<40 AND X_135>=REF(X_135,10)),3);
X_203:=REF(X_166>5,1) AND REF(X_178,1) AND X_181<2 AND X_166<2 AND X_18<2 AND X_168<28 AND X_87=X_86;
X_204:=COUNT(X_184,10)=1 AND X_185 OR X_199 OR (X_177<20 AND X_188 AND COUNT(MA(CLOSE,34)>=LLV(MA(CLOSE,34),30),15)>1) AND X_166>5 AND X_178<5 AND X_170<20 AND X_180<40 AND X_87=X_86 AND X_151>=REF(X_151,1) AND BARSCOUNT(CLOSE)>20 AND X_135>=REF(X_135,1);
X_205:=IF(X_73>0 AND X_86>=X_87,28,0);
X_206:=IF(EXIST(X_73>0,3) AND X_27>=50,28,0);
X_207:=X_13 AND (REF(X_166,1)>5 OR X_166>1 OR X_199);
X_208:=IF(X_1 AND X_166>7 AND CROSS(X_56,X_11),18,0);
小试牛刀:FILTER(X_27>REF(X_27,5) AND X_170<30 AND X_27>=HHV(X_27,50) AND (X_205>5 OR X_206>5 AND X_170<30) AND (COUNT(CROSS(X_86,X_59),10)=1 AND X_170<30 AND (X_27>REF(X_27,10) AND X_27>=HHV(X_27,50))) OR (X_86<X_59 AND X_170<30 AND X_166>1.5 AND X_27>REF(X_27,10) AND X_170<30 AND X_56>X_59) AND X_48>20 OR (X_202 AND X_170<30) OR (X_204 AND X_170<50) OR X_207 AND X_200>0 AND X_151>=REF(X_151,1),6),COLORMAGENTA,LINETHICK2;
小牛启程:FILTER(X_172>5 AND X_15>X_31 OR X_174 AND X_144>0 AND X_48>20 OR X_170<30 AND X_204 OR X_202 OR X_207 OR X_199 OR (COUNT(CROSS(X_208,0.8),5)=1 AND X_166>1.5) AND X_200>0 AND X_151>=REF(X_151,1),6),COLORFF0080,LINETHICK2;
X_209:=IF(COUNT(X_13,5)=1 AND X_166>0.5 AND X_48>30 AND X_87=X_86 AND X_168<50 AND X_73>=REF(X_73,1),18,0);
X_210:=IF(COUNT(CROSS(小牛启程,0.8),6)=1 AND 小试牛刀>0 OR (COUNT(CROSS(小试牛刀,0.8),6)=1 AND 小牛启程>0) OR (COUNT(CROSS(X_209,0.8),6)=1 AND 小牛启程>0) OR (COUNT(CROSS(小牛启程,0.8),6)=1 AND X_209>0) OR (COUNT(CROSS(小试牛刀,0.8),6)=1 AND X_209>0) OR (COUNT(CROSS(X_209,0.8),6)=1 AND 小试牛刀>0) AND X_200>0 AND BARSCOUNT(CLOSE)>20 AND X_151>=REF(X_151,1),18,0);
共振乾坤:FILTER(X_210>5 OR X_199>5 OR X_209>5,6);

选股公式翻译

X_1赋值:1日前的收盘价*1.1-收盘价<0.01 AND 最高价=收盘价
X_2赋值:5
X_3赋值:3
X_4赋值:(收盘价的5日指数移动平均*7+收盘价的10日指数移动平均*3)/10
X_5赋值:如果年份>=2025,返回0,否则返回1
X_6赋值:最低价的21日指数移动平均+6.8*最低价的2日估算标准差的55日指数移动平均
X_7赋值:收盘价/X_6*(1.88*收盘价+最低价+开盘价)/2.75的3日指数移动平均
X_8赋值:(X_7-X_6)/X_6/2
X_9赋值:X_7-X_8*X_7的5日指数移动平均*X_5
X_10赋值:收盘价的34日指数移动平均-3*收盘价的34日估算标准差
X_11赋值:如果X_4>X_9,返回X_4,否则返回X_9*X_5
X_12赋值:如果X_9X_39*1.1的0.9乘幂距今天数
X_41赋值:上次收盘价200,返回收盘价,否则返回以成交量(手)/当前流通股本(手)为权重X_57的动态移动平均*1.1
X_59赋值:21日内X_55的最高值的6日指数移动平均
X_60赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回-成交量(手)
X_61赋值:如果收盘价=1日前的收盘价,返回0,否则返回X_60的历史累和
X_62赋值:(36日内最高价的最高值-收盘价)/(36日内最高价的最高值-36日内最低价的最低值)*100
X_63赋值:X_62的3日[1日权重]移动平均
X_64赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
X_65赋值:X_64的5日[1日权重]移动平均-8
X_66赋值:X_65-X_63
X_67赋值:(最高价+开盘价+最低价+3*收盘价)/6
X_68赋值:100-100/(1+如果X_67>1日前的X_67,返回X_67*成交量(手),否则返回0的14日累和/如果X_67<1日前的X_67,返回X_67*成交量(手),否则返回0的14日累和)的5日指数移动平均
X_69赋值:X_56上穿X_59
X_70赋值:2*收盘价+开盘价+最高价+最低价
X_71赋值:(X_70/X_70的4日指数移动平均-1)*100
X_72赋值:X_71*5
X_73赋值:X_23
X_74赋值:(X_68/1日前的X_68-1)*100的反正切*180/3.1416
X_75赋值:(X_72/1日前的X_72-1)*100的反正切*180/3.1416
X_76赋值:(X_72-1日前的X_72)*100/1日前的X_72
X_77赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价
X_78赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100的15日累和
X_79赋值:开盘价=0
X_80赋值:如果X_35>X_36ANDX_2950ORX_15>1日前的X_15),返回(-40),否则返回0
X_81赋值:如果统计20日中满足X_69的天数ANDX_28>X_29ANDX_31>X_33ANDX_48>30ANDX_15>X_31ANDX_15>60ANDX_77>=0.5ANDMAX(收盘价,X_35)ANDCOUNT(收盘价>X_35,10),返回18,否则返回0
X_82赋值:如果X_81>10ANDX_77>=0.5ANDX_80=(-40),返回88,否则返回0
X_83赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
X_84赋值:(收盘价-21日前的收盘价)/21日前的收盘价*100的4日指数移动平均*2
X_85赋值:收盘价的1日简单移动平均
X_86赋值:X_85的2日[1日权重]移动平均的2日[1日权重]移动平均的2日[1日权重]移动平均
X_87赋值:13日内X_86的1日简单移动平均的最高值
X_88赋值:如果X_44>0ANDX_44<150ANDX_15>50ANDCLOSE>X_58ANDX_56>X_59ANDX_45<20ANDX_76>10ANDX_74>2ANDX_28>X_29,返回208,否则返回0
X_89赋值:3*(收盘价-480日内最低价的最低值)/(480日内最高价的最高值-480日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-480日内最低价的最低值)/(480日内最高价的最高值-480日内最低价的最低值)*100的180日[1日权重]移动平均的15日[1日权重]移动平均
X_90赋值:X_89的5日指数移动平均
X_91赋值:X_90-100
X_92赋值:收盘价的5日指数移动平均
X_93赋值:(收盘价的1日指数移动平均+收盘价的5日指数移动平均+收盘价的10日指数移动平均+收盘价的15日指数移动平均+收盘价的20日指数移动平均+收盘价的25日指数移动平均+收盘价的30日指数移动平均+收盘价的35日指数移动平均+收盘价的40日指数移动平均+收盘价的45日指数移动平均+收盘价的50日指数移动平均+收盘价的55日指数移动平均+收盘价的60日指数移动平均+收盘价的65日指数移动平均+收盘价的70日指数移动平均+收盘价的75日指数移动平均+收盘价的80日指数移动平均+收盘价的85日指数移动平均+收盘价的90日指数移动平均+收盘价的95日指数移动平均+收盘价的100日指数移动平均+收盘价的105日指数移动平均+收盘价的110日指数移动平均+收盘价的115日指数移动平均+收盘价的120日指数移动平均+收盘价的125日指数移动平均+收盘价的130日指数移动平均+收盘价的135日指数移动平均+收盘价的140日指数移动平均+收盘价的150日指数移动平均)/30
X_94赋值:X_92/X_93*100
X_95赋值:X_94-110
X_96赋值:(最高价+最低价+2*收盘价)/4
X_97赋值:(X_96-3日前的X_96)/3+X_96
X_98赋值:X_97的7日指数移动平均
X_99赋值:20日内X_97的最高值的60日指数移动平均
X_100赋值:获利盘为80%的成本分布的30日指数移动平均
X_101赋值:1.4*X_97的20日线性回归预测值的40日指数移动平均的20日指数移动平均
X_102赋值:(X_99+X_100+X_101)/3
X_103赋值:收盘价*1.38的50日指数移动平均的50日指数移动平均
X_104赋值:最高价的21日[2日权重]移动平均*1.05
X_105赋值:最低价的21日[2日权重]移动平均*0.95
X_106赋值:(X_104+X_105)/2
X_107赋值:X_106+2*X_106的20日估算标准差
X_108赋值:0日前的X_107
X_109赋值:(2*收盘价+最高价+最低价)/4-X_97的20日简单移动平均的绝对值/X_97的20日简单移动平均
X_110赋值:以X_109为权重收盘价的动态移动平均
X_111赋值:(1+9/100)*X_110
X_112赋值:(1-7/100)*X_110
X_113赋值:(10日前的(X_102+X_103+X_107*1.04的40日指数移动平均+X_111)/4+收盘价的20日简单移动平均*1.04)/2
X_114赋值:最高价*成交量(手)
X_115赋值:(X_114的180日指数移动平均/成交量(手)的180日指数移动平均+X_114的360日指数移动平均/成交量(手)的360日指数移动平均+X_114的720日指数移动平均/成交量(手)的720日指数移动平均+X_114的1440日指数移动平均/成交量(手)的1440日指数移动平均)/4的34日指数移动平均
X_116赋值:1.06*X_115
X_117赋值:X_115*0.94
X_118赋值:(X_114的27日指数移动平均/成交量(手)的27日指数移动平均+X_114的54日指数移动平均/成交量(手)的54日指数移动平均+X_114的108日指数移动平均/成交量(手)的108日指数移动平均+X_114的316日指数移动平均/成交量(手)的316日指数移动平均)/4的34日指数移动平均
X_119赋值:1.06*X_118
X_120赋值:X_118*0.94
X_121赋值:(X_114的5日指数移动平均/成交量(手)的5日指数移动平均+X_114的10日指数移动平均/成交量(手)的10日指数移动平均+X_114的20日指数移动平均/成交量(手)的20日指数移动平均+X_114的40日指数移动平均/成交量(手)的40日指数移动平均)/4的34日指数移动平均
X_122赋值:1.06*X_121
X_123赋值:X_121*0.94
X_124赋值:(X_116+X_122+X_119)/3*1.05
X_125赋值:(X_98*2/(X_113+X_124)-1)*100
X_126赋值:获利盘为80%的成本分布的20日简单移动平均
X_127赋值:(X_98/X_126-1)*100
X_128赋值:(42日内最高价的最高值-42日内最低价的最低值)/2+42日内最低价的最低值
X_129赋值:40日内最高价的最高值-40日内最低价的最低值-40日内最低价的最低值的绝对值+X_128*0.5
X_130赋值:(X_128/X_129-1)*100
X_131赋值:收盘价*1.14的55日指数移动平均的20日指数移动平均
X_132赋值:(X_98/X_131-1)*100
X_133赋值:(60日内最高价的最高值的60日指数移动平均+X_128的453日指数移动平均*1.62)/2
X_134赋值:(X_98/X_133-1)*100
X_135赋值:(X_91+X_95+X_125+X_127+X_130+X_132+X_134)/2
X_136赋值:以0.9为权重(最高价+最低价+收盘价*2)/4的动态移动平均
X_137赋值:成交量(手)*100/当前流通股本(手)
X_138赋值:X_137的4日简单移动平均
X_139赋值:X_137的9日简单移动平均
X_140赋值:X_137的17日简单移动平均
X_141赋值:X_137的34日简单移动平均
X_142赋值:(X_138+X_139+X_140+X_141)/4
X_143赋值:成交量(手)
X_144赋值:X_138-X_142
X_145赋值:X_139-X_142
X_146赋值:如果X_80<0ANDREF(X_144,1)>0AND(收盘价/4日前的收盘价-1)*100<15ANDX_56>X_59ANDX_56>X_34ANDX_77>0ANDX_144>1日前的X_144*1.5ANDX_145>1日前的X_145ANDX_144>0ANDX_15>X_31,返回80,否则返回0
X_147赋值:收盘价的7日简单移动平均
X_148赋值:收盘价的14日简单移动平均
X_149赋值:收盘价的21日简单移动平均
X_150赋值:收盘价的34日简单移动平均
X_151赋值:收盘价的55日简单移动平均
X_152赋值:X_147上穿X_150
X_153赋值:X_147>X_148>X_149>X_150
X_154赋值:成交量(手)的5日简单移动平均
X_155赋值:成交量(手)的10日简单移动平均
X_156赋值:X_154上穿X_155
X_157赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
X_158赋值:X_157的9日指数移动平均
X_159赋值:(X_157-X_158)*2
X_160赋值:X_157上穿X_158
X_161赋值:X_152 AND X_156 AND X_160
X_162赋值:3*(收盘价-180日内最低价的最低值)/(180日内最高价的最高值-180日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-180日内最低价的最低值)/(180日内最高价的最高值-180日内最低价的最低值)*100的180日[1日权重]移动平均的15日[1日权重]移动平均
X_163赋值:条件连续成立次数>=5 AND 条件连续成立次数<=30
X_164赋值:统计15日中满足1日前的X_163<=0.25ANDCLOSE>OPENANDCLOSE>=1日前的15日内收盘价的最高值AND(收盘价-1日前的收盘价)/1日前的收盘价>=0.04的天数=1
X_165赋值:如果X_164ANDX_48>30AND(收盘价-1日前的收盘价)/1日前的收盘价>=0.04ANDCLOSE>=X_59AND(收盘价-20日前的收盘价)/20日前的收盘价>0AND(收盘价-20日前的收盘价)/20日前的收盘价<0.25,返回218,否则返回0
X_166赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价
X_167赋值:(1日前的收盘价-5日前的收盘价)*100/5日前的收盘价
X_168赋值:(1日前的收盘价-10日前的收盘价)*100/10日前的收盘价
X_169赋值:(-X_162的5日指数移动平均)/4
X_170赋值:(收盘价-20日前的收盘价)*100/20日前的收盘价
X_171赋值:如果X_82>18ANDX_88>10ANDX_168<10,返回218,否则返回0
X_172赋值:如果统计5日中满足X_135>X_169的天数>=1ANDX_167>1ANDX_80<0ANDX_86=X_87ANDX_56>X_59*0.95ANDX_166>=3ANDX_168<20OR(X_165>18ANDCOUNT(X_135上穿X_169,5)=1)OR(X_146>18ANDX_168<20,返回ORX_171>8,否则返回18
X_173赋值:统计5日中满足X_135上穿X_169的天数=1 AND X_170>4 AND X_86=X_87 AND X_168<20 AND X_56>X_59*1.05
X_174赋值:X_173的30日过滤
X_175赋值:最高价=10日内X_135的最高值
X_176赋值:(最高价-最低价)/1日前的收盘价*100
X_177赋值:15日内X_176的最高值
X_178赋值:(1日前的收盘价-2日前的收盘价)/2日前的收盘价*100
X_179赋值:(2日前的收盘价-3日前的收盘价)/3日前的收盘价*100
X_180赋值:(收盘价-50日前的收盘价)/50日前的收盘价*100
X_181赋值:(收盘价-开盘价)/开盘价*100
X_182赋值:(1日前的收盘价-收盘价)/1日前的收盘价*100
X_183赋值:开盘价>1日前的最高价 AND 最低价>1日前的最高价 AND 收阳线ANDSE (开盘价-1日前的收盘价)/1日前的收盘价*100>1.5
X_184赋值:(开盘价-1日前的收盘价)/1日前的收盘价*100>2
X_185赋值:统计2日中满足开盘价>1日前的收盘价的天数>=2
X_186赋值:统计10日中满足开盘价>1日前的最高价ANDLOW>1日前的最高价的天数
X_187赋值:统计10日中满足开盘价>1日前的收盘价ANDLOW>1日前的收盘价的天数 AND 最低价<开盘价
X_188赋值:统计10日中满足开盘价>1日前的收盘价AND(开盘价-1日前的收盘价)/1日前的收盘价*100>0.1ANDCLOSE>1日前的最高价的天数
X_189赋值:最高价-X_62的绝对值的13日[1日权重]移动平均/最高价-X_62和0的较小值的10日[1日权重]移动平均
X_190赋值:X_189的10日指数移动平均
X_191赋值:33日内最高价的最高值
X_192赋值:如果最高价>=X_191,返回X_190,否则返回0的3日指数移动平均
X_193赋值:(收盘价/1日前的收盘价-1)*100
X_194赋值:X_193位于1.07和1.1之间 OR 收盘价=最高价
X_195赋值:2日前的X_194
X_196赋值:1日前的收盘价<1日前的开盘价
X_197赋值:收盘价>(1日前的收盘价+1日前的收盘价)/1.9
X_198赋值:收盘价*流通股本(股)/100000000<60
X_199赋值:如果X_195ANDX_196ANDX_197ANDX_198,返回18,否则返回0
X_200赋值:如果X_192<1日前的X_192ANDX_182<3,返回18,否则返回0
X_201赋值:(1日前的收盘价-开盘价)/1日前的收盘价*100>2.5 AND (收盘价-开盘价)/开盘价*100>2 AND X_167<30 AND X_168<40 AND X_135>=1日前的X_135
X_202赋值:X_166>5ANDX_178>5AND(X_135>=1日前的X_135ANDCLOSE>X_59ANDX_168<40ANDX_135>=10日前的X_135)的3日过滤
X_203赋值:1日前的X_166>5 AND 1日前的X_178 AND X_181<2 AND X_166<2 AND X_18<2 AND X_168<28 AND X_87=X_86
X_204赋值:统计10日中满足X_184的天数=1 AND X_185 OR X_199 OR (X_177<20 AND X_188 AND 统计15日中满足收盘价的34日简单移动平均>=30日内收盘价的34日简单移动平均的最低值的天数>1) AND X_166>5 AND X_178<5 AND X_170<20 AND X_180<40 AND X_87=X_86 AND X_151>=1日前的X_151 AND 收盘价的有效数据周期数>20 AND X_135>=1日前的X_135
X_205赋值:如果X_73>0ANDX_86>=X_87,返回28,否则返回0
X_206赋值:如果最近3日存在X_73>0ANDX_27>=50,返回28,否则返回0
X_207赋值:X_13 AND (1日前的X_166>5 OR X_166>1 OR X_199)
X_208赋值:如果X_1ANDX_166>7ANDCROSS(X_56,X_11),返回18,否则返回0
小试牛刀赋值:X_27>5日前的X_27ANDX_170<30ANDX_27>=50日内X_27的最高值AND(X_205>5ORX_206>5ANDX_170<30)AND(统计10日中满足X_86上穿X_59的天数=1ANDX_170<30AND(X_27>10日前的X_27ANDX_27>=?日内X_的最高值的7,50)))OR(X_861.5ANDX_27>10日前的X_27ANDX_170<30ANDX_56>X_59)ANDX_48>20OR(X_202ANDX_170<30)OR(X_204ANDX_170<50)ORX_207ANDX_200>0ANDX_1日过滤,画洋红色,线宽为2
小牛启程赋值:X_172>5ANDX_15>X_31ORX_174ANDX_144>0ANDX_48>20ORX_170<30ANDX_204ORX_202ORX_207ORX_199OR(统计5日中满足X_208上穿0.8的天数=1ANDX_166>1.5)ANDX_200>0ANDX_151>=1日前的X_151的?日过滤,COLORFF0080,线宽为2
X_209赋值:如果统计5日中满足X_13的天数=1ANDX_166>0.5ANDX_48>30ANDX_87=X_86ANDX_168<50ANDX_73>=1日前的X_73,返回18,否则返回0
X_210赋值:如果统计6日中满足小牛启程上穿0.8的天数=1AND小试牛刀>0OR(统计6日中满足小试牛刀上穿0.8的天数=1AND小牛启程>0)OR(统计6日中满足X_209上穿0.8的天数=1AND小牛启程>0)OR(统计?日中满足小牛启程上穿0的天数,返回8),6)=1ANDX_209>0)OR(统计6日中满足小试牛刀上穿0.8的天数=1ANDX_209>0)OR(统计6日中满足X_209上穿0.8的天数=1AND小试牛刀>0)ANDX_200>0ANDBARSCOUNT(收盘价)>20ANDX_151>=1日前的X_151,否则返回?
输出共振乾坤:X_210>5ORX_199>5ORX_209>5的6日过滤

演示图片

共振乾坤选股公式