首页 > 选股公式 > 震仓买入选股公式

震仓买入选股公式

日期:2021-12-17 18:51:02

选股公式源码

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
B:=BARSLAST(CROSS(GJTJ4,GJTJ2));
D:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
E:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
F:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
B1:=A>0 AND REF(A,1)=0 AND REF(A,2)>0;
ENTERLONG:A AND B AND D AND E AND F;

选股公式翻译

GJTJ1赋值:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值)
GJTJ2赋值:100*(收盘价-10日内最低价的最低值)/(10日内收盘价的最高值-10日内最低价的最低值)
GJTJ3赋值:100*(收盘价-20日内最低价的最低值)/(20日内收盘价的最高值-20日内最低价的最低值)
GJTJ4赋值:100*(收盘价-30日内最低价的最低值)/(30日内收盘价的最高值-30日内最低价的最低值)
A赋值:上次GJTJ4上穿GJTJ1距今天数>3 AND 上次GJTJ1上穿GJTJ4距今天数<3
B赋值:上次GJTJ4上穿GJTJ2距今天数
D赋值:GJTJ33 AND 上次GJTJ1上穿GJTJ4距今天数<3
F赋值:GJTJ20 AND 1日前的A=0 AND 2日前的A>0
多头买入:A AND B AND D AND E AND F

演示图片