首页 > 选股公式 > 主进主买选股公式

主进主买选股公式

日期:2021-12-17 18:51:02

选股公式源码

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
主进主买:ABV>M2 AND MMB>MMC AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);

选股公式翻译

ABV赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回如果收盘价<1日前的收盘价,返回-成交量(手),否则返回0的历史累和/25000的2日简单移动平均
M1赋值:ABV的12日指数移动平均
M2赋值:ABV的26日指数移动平均
MTM赋值:收盘价-1日前的收盘价
MMS赋值:((100)*(MTM的6日指数移动平均的6日指数移动平均))/(MTM的绝对值的6日指数移动平均的6日指数移动平均)
MMM赋值:((100)*(MTM的12日指数移动平均的12日指数移动平均))/(MTM的绝对值的12日指数移动平均的12日指数移动平均)
MML赋值:((100)*(MTM的26日指数移动平均的26日指数移动平均))/(MTM的绝对值的26日指数移动平均的26日指数移动平均)
MMA赋值:收盘价-1日前的收盘价
MMB赋值:100*MMA的9日指数移动平均的9日指数移动平均/MMA的绝对值的9日指数移动平均的9日指数移动平均
MMC赋值:MMB的5日简单移动平均
输出主进主买:ABV>M2 AND MMB>MMC AND MMS上穿MML AND MMS>1日前的MMS AND MMM>1日前的MMM AND MML>1日前的MML

演示图片