首页 > 选股公式 > 射日箭选股公式

射日箭选股公式

日期:2021-12-17 18:51:02

选股公式源码

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA90:=MA(C,90);
MA120:=MA(C,120);
MA250:=MA(C,250);
VAR1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);
ABV:=MA(SUM(IF(C>REF(C,1),V,IF(C<REF(C,1),-V,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=C-REF(C,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(H+O+L+(2)*(C))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主力进出:=(MMS>REF(MMS,1) AND MMB>REF(MMB,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1));
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);
TJ:=REF(C,1)>REF(O,1) AND V>REF(V,1);
精准买卖:=V8>=1 AND V9>=1 AND C>O AND TJ AND MMS>MML AND CROSS(ABV,M2);
短线买点:=V8>=1 AND V9>=1 AND C>O AND TJ AND CROSS(MMS,MML) AND ABV>REF(ABV,1);
中线买 点:=V8>=1 AND V9>=1 AND C>O AND TJ AND ABV>REF(ABV,1) AND MMS>MML AND CROSS(MMM,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主进主买:=ABV>M2 AND MMB>MMC AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主力买卖:=精准买卖 OR 短线买点 OR 中线买点 OR 主进主买;
射日:=S<X AND Y<X AND MMS>MML AND ABV>M1 AND CROSS(S,Y);
主力轨迹:=ABV>M2 AND MMS>MML AND CROSS(MMB,MMC) AND MMB>REF(MMB,1) AND MMC>REF(MMC,1);
SR:=射日>0;
SR11:=EXIST(主力买卖,10);
SR12:=EXIST(主力进出,10);
SR13:=EXIST(主力轨迹,10);
YGQFSRJ:=SR11 OR SR12 OR SR13 ;
YGQFXS:=MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND C>MA10 AND C>MA20 AND C>MA120;
DT1:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
射日箭:SR AND YGQFSRJ AND YGQFXS AND DT1;

选股公式翻译

MA5赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA30赋值:收盘价的30日简单移动平均
MA60赋值:收盘价的60日简单移动平均
MA90赋值:收盘价的90日简单移动平均
MA120赋值:收盘价的120日简单移动平均
MA250赋值:收盘价的250日简单移动平均
VAR1赋值:(收盘价-19日内最低价的最低值)/(19日内最高价的最高值-19日内最低价的最低值)*100的8日[1日权重]移动平均的3日指数移动平均
ABV赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回如果收盘价<1日前的收盘价,返回-成交量(手),否则返回0的历史累和/25000的2日简单移动平均
M1赋值:ABV的12日指数移动平均
M2赋值:ABV的26日指数移动平均
MTM赋值:收盘价-1日前的收盘价
MMS赋值:((100)*(MTM的6日指数移动平均的6日指数移动平均))/(MTM的绝对值的6日指数移动平均的6日指数移动平均)
MMM赋值:((100)*(MTM的12日指数移动平均的12日指数移动平均))/(MTM的绝对值的12日指数移动平均的12日指数移动平均)
MML赋值:((100)*(MTM的26日指数移动平均的26日指数移动平均))/(MTM的绝对值的26日指数移动平均的26日指数移动平均)
MMA赋值:收盘价-1日前的收盘价
MMB赋值:100*MMA的9日指数移动平均的9日指数移动平均/MMA的绝对值的9日指数移动平均的9日指数移动平均
MMC赋值:MMB的5日简单移动平均
A赋值:((成交量(手))/(当前流通股本(手)))*(100)
S赋值:((A的30日简单移动平均)/(大盘的成交额的10日简单移动平均))*(大盘的成交额的60日简单移动平均)
Y赋值:((A的120日简单移动平均)/(大盘的成交额的10日简单移动平均))*(大盘的成交额的60日简单移动平均)
X赋值:1
V1赋值:(最高价+开盘价+最低价+(2)*(收盘价))/(5)
V2赋值:1日前的V1
V3赋值:V1-V2和0的较大值
V4赋值:V1-V2的绝对值
V5赋值:V3的10日[1日权重]移动平均
V6赋值:V4的10日[1日权重]移动平均
V8赋值:统计5日中满足((V5)/(V6)<0.2)的天数
V9赋值:统计10日中满足(10日内V1的最低值=V1)的天数
主力进出赋值:(MMS>1日前的MMS AND MMB>1日前的MMB AND ABV上穿M2 AND ABV>1日前的ABV AND M1>1日前的M1 AND M2>1日前的M2)
主进主轨赋值:ABV>M2 AND ABV上穿M1 AND MMB上穿MMC
TJ赋值:1日前的收盘价>1日前的开盘价 AND 成交量(手)>1日前的成交量(手)
精准买卖赋值:V8>=1 AND V9>=1 AND 收阳线AND TJ AND MMS>MML AND ABV上穿M2
短线买点赋值:V8>=1 AND V9>=1 AND 收阳线AND TJ AND MMS上穿MML AND ABV>1日前的ABV
中线买点赋值:V8>=1 AND V9>=1 AND 收阳线AND TJ AND ABV>1日前的ABV AND MMS>MML AND MMM上穿MML AND MMS>1日前的MMS AND MMM>1日前的MMM AND MML>1日前的MML
主进主买赋值:ABV>M2 AND MMB>MMC AND MMS上穿MML AND MMS>1日前的MMS AND MMM>1日前的MMM AND MML>1日前的MML
主力买卖赋值:精准买卖 OR 短线买点 OR 中线买点 OR 主进主买
射日赋值:SMML AND ABV>M1 AND S上穿Y
主力轨迹赋值:ABV>M2 AND MMS>MML AND MMB上穿MMC AND MMB>1日前的MMB AND MMC>1日前的MMC
SR赋值:射日>0
SR11赋值:最近10日存在主力买卖
SR12赋值:最近10日存在主力进出
SR13赋值:最近10日存在主力轨迹
YGQFSRJ赋值:SR11 OR SR12 OR SR13
YGQFXS赋值:MA5>1日前的MA5 AND MA10>1日前的MA10 AND MA20>1日前的MA20 AND MA30>1日前的MA30 AND 收盘价>MA10 AND 收盘价>MA20 AND 收盘价>MA120
DT1赋值:MA5>MA10 AND MA10>MA20 AND MA20>MA30
输出射日箭:SR AND YGQFSRJ AND YGQFXS AND DT1

演示图片