首页 > 选股公式 > 准备赚钱选股公式

准备赚钱选股公式

日期:2021-12-17 18:51:02

选股公式源码

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
准备赚钱:=(AV + NEWVOL);
选股:CROSS(准备赚钱,0);

选股公式翻译

LC赋值:1日前的收盘价
RSI5赋值:(((收盘价-LC)和0的较大值的5日[1日权重]移动平均 / (收盘价-LC)的绝对值的5日[1日权重]移动平均) * 100)
TR1赋值:(最高价-最低价)和(最高价-1日前的收盘价)的绝对值的较大值和(最低价-1日前的收盘价)的绝对值的较大值的10日累和
HD赋值:(最高价 - 1日前的最高价)
LD赋值:(1日前的最低价 - 最低价)
DMP赋值:如果((HD>0)AND(HD>LD)),返回HD,否则返回0的10日累和
DMM赋值:如果((LD>0)AND(LD>HD)),返回LD,否则返回0的10日累和
PDI赋值:((DMP * 100) / TR1)
MDI赋值:((DMM * 100) / TR1)
ADX赋值:(((MDI-PDI)的绝对值/(MDI+PDI))*100)的5日简单移动平均
AV赋值:(RSI5 + ADX)
DXR赋值:(((ADX + 5日前的ADX) / 2) + RSI5)
WR10赋值:((100 * (10日内最高价的最高值 - 收盘价)) / (10日内最高价的最高值 - 10日内最低价的最低值))
NEWVOL赋值:(RSI5 - WR10)
准备赚钱赋值:(AV + NEWVOL)
输出选股:准备赚钱上穿0

演示图片