首页 > 选股公式 > 卧底选股公式

卧底选股公式

日期:2021-12-17 18:51:02

选股公式源码

TDJ1:=(H-L)/REF(C,1)>0.05;
YUL1:=COUNT(TDJ1,5)>1;
TU1:=CLOSE/MA(C,40)<0.74;
启动1:=TDJ1 AND YUL1 AND TU1;
ZC:=REF(CLOSE,1);
VAR1:=SMA(MAX(CLOSE-ZC,0),7,1)/SMA(ABS(CLOSE-ZC),7,1)*100;
VAR2:=((MA(C,30)-LOW)/MA(C,60))*200;
GL1:=FILTER(REF(VAR1,1)<20 AND VAR1>REF(VAR1,1),5);
波段1:=FILTER(GL1 AND REF(启动1,1) AND VAR2>20 AND C>REF(C,1),10);
MA5:=EMA(C,5);
EM5:=EMA(MA5,5);
VAR3:=ABS(MA5-EM5);
VAR4:=MA5-REF(MA5,1);
VAR5:=VAR4-REF(VAR4,1);
VAR6:=(VAR4+VAR5)/2;
TDF1:=POW(VAR3,1)*POW(VAR6,3);
NTDF1:=TDF1/HHV(ABS(TDF1),15);
确定1:=波段1 AND CROSS(NTDF1,-0.05);
选股1:=FILTER(REF(启动1,1) AND (确定1 OR C>REF(C,1)) AND "MACD.macd"(12,26,9)>-1.5,10);
卧底1:(COUNT(选股1,13)>=1 AND (波段1 OR 确定1))*0.4;

选股公式翻译

TDJ1赋值:(最高价-最低价)/1日前的收盘价>0.05
YUL1赋值:统计5日中满足TDJ1的天数>1
TU1赋值:收盘价/收盘价的40日简单移动平均<0.74
启动1赋值:TDJ1 AND YUL1 AND TU1
ZC赋值:1日前的收盘价
VAR1赋值:收盘价-ZC和0的较大值的7日[1日权重]移动平均/收盘价-ZC的绝对值的7日[1日权重]移动平均*100
VAR2赋值:((收盘价的30日简单移动平均-最低价)/收盘价的60日简单移动平均)*200
GL1赋值:1日前的VAR1<20ANDVAR1>1日前的VAR1的5日过滤
波段1赋值:GL1ANDREF(启动1,1)ANDVAR2>20ANDC>1日前的收盘价的10日过滤
MA5赋值:收盘价的5日指数移动平均
EM5赋值:MA5的5日指数移动平均
VAR3赋值:MA5-EM5的绝对值
VAR4赋值:MA5-1日前的MA5
VAR5赋值:VAR4-1日前的VAR4
VAR6赋值:(VAR4+VAR5)/2
TDF1赋值:VAR3的1乘幂*VAR6的3乘幂
NTDF1赋值:TDF1/15日内TDF1的绝对值的最高值
确定1赋值:波段1 AND NTDF1上穿-0.05
选股1赋值:1日前的启动1AND(确定1ORC>1日前的收盘价)AND"平滑异同平均的MACD"(12,26,9)>-1.5的10日过滤
输出卧底1:(统计13日中满足选股1的天数>=1 AND (波段1 OR 确定1))*0.4

演示图片