首页 > 选股公式 > 宝塔镇妖选股公式

宝塔镇妖选股公式

日期:2021-12-17 18:51:02

选股公式源码

X_1:=IF(NAMELIKE(7),0,1);
X_2:=DYNAINFO(8)>0;
X_3:=IF(NAMELIKE(8),0,1);
X_4:=X_1 AND X_2 AND X_3;
X_5:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
X_6:=SMA(X_5,9,1);
X_7:=SMA(X_6,9,1);
X_8:=CROSS(X_6,X_7);
X_9:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
X_10:=COUNT(X_8,21)>=2;
X_11:=X_6<20;
X_12:=MA(CLOSE,10)>REF(MA(CLOSE,10),1);
X_13:=COUNT(X_9<(-8),20)>=1 AND X_9<=0 AND COUNT(X_9<=0,4)>=2;
X_14:=X_10 AND X_11 AND X_12 AND X_13;
X_15:=X_14 AND COUNT(X_14,10)=1;
X_16:=REF(CLOSE,1);
X_17:=SMA(MAX(CLOSE-X_16,0),7,1)/SMA(ABS(CLOSE-X_16),7,1)*100;
X_18:=SMA(MAX(CLOSE-X_16,0),13,1)/SMA(ABS(CLOSE-X_16),13,1)*100;
X_19:=BARSLAST(X_18<20)<=3 AND CROSS(X_17,X_18);
X_20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100<(-12.5);
X_21:=LLV(LOW,5);
X_22:=HHV(HIGH,5);
X_23:=EMA((CLOSE-X_21)/(X_22-X_21)*100,4);
X_24:=EMA(0.667*REF(X_23,1)+0.333*X_23,2);
X_25:=X_19 AND X_20 AND CROSS(X_23,X_24) AND X_23<=25;
X_26:=DMA(EMA(CLOSE,14),SUM(VOL,5)/3/CAPITAL);
X_27:=(CLOSE-X_26)/X_26*100;
X_28:=X_27<(-38);
X_29:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
X_30:=(CLOSE-X_29)/X_29*100;
X_31:=REF(X_30,1)<(-37) AND X_30>REF(X_30,1) AND REF(X_30,1)<REF(X_30,2) AND REF(X_30,2)-REF(X_30,1)>1;
X_32:=X_28 OR X_31 AND VOL/CAPITAL*100<6;
X_33:=X_32 AND COUNT(X_32,10)=1;
X_34:=(HIGH-LOW)/HIGH*100+(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_35:=EMA(MA(X_34,50),5);
X_36:=X_35>LLV(X_35,5)*1.01 AND REF(X_35,1)<REF(LLV(X_35,5),1)*1.01 AND LLV(X_35,50)=LLV(X_35,5);
X_37:=LLV(LOW,5)=LLV(LOW,50) AND LLV(LOW,5)<HHV(LOW,70)*0.5;
X_38:=X_36 AND X_37;
X_39:=X_15 OR X_25 OR X_33 OR X_38 AND X_4;
X_40:=CLOSE/REF(CLOSE,1)>1.05 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_41:=FILTER(X_40,28)*100;
X_42:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1),91,0);
X_43:=FILTER(X_42>90,45) AND FILTER(X_42>90,35) AND X_41>0;
X_44:X_43 AND COUNT(X_43,60)=1;

选股公式翻译

X_1赋值:如果模糊匹配品种名称,返回0,否则返回1
X_2赋值:总量>0
X_3赋值:如果模糊匹配品种名称,返回0,否则返回1
X_4赋值:X_1 AND X_2 AND X_3
X_5赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
X_6赋值:X_5的9日[1日权重]移动平均
X_7赋值:X_6的9日[1日权重]移动平均
X_8赋值:X_6上穿X_7
X_9赋值:(收盘价-收盘价的5日简单移动平均)/收盘价的5日简单移动平均*100
X_10赋值:统计21日中满足X_8的天数>=2
X_11赋值:X_6<20
X_12赋值:收盘价的10日简单移动平均>1日前的收盘价的10日简单移动平均
X_13赋值:统计20日中满足X_9<(-8)的天数>=1 AND X_9<=0 AND 统计4日中满足X_9<=0的天数>=2
X_14赋值:X_10 AND X_11 AND X_12 AND X_13
X_15赋值:X_14 AND 统计10日中满足X_14的天数=1
X_16赋值:1日前的收盘价
X_17赋值:收盘价-X_16和0的较大值的7日[1日权重]移动平均/收盘价-X_16的绝对值的7日[1日权重]移动平均*100
X_18赋值:收盘价-X_16和0的较大值的13日[1日权重]移动平均/收盘价-X_16的绝对值的13日[1日权重]移动平均*100
X_19赋值:上次X_18<20距今天数<=3 AND X_17上穿X_18
X_20赋值:(收盘价-收盘价的20日简单移动平均)/收盘价的20日简单移动平均*100<(-12.5)
X_21赋值:5日内最低价的最低值
X_22赋值:5日内最高价的最高值
X_23赋值:(收盘价-X_21)/(X_22-X_21)*100的4日指数移动平均
X_24赋值:0.667*1日前的X_23+0.333*X_23的2日指数移动平均
X_25赋值:X_19 AND X_20 AND X_23上穿X_24 AND X_23<=25
X_26赋值:以成交量(手)的5日累和/3/当前流通股本(手)为权重收盘价的14日指数移动平均的动态移动平均
X_27赋值:(收盘价-X_26)/X_26*100
X_28赋值:X_27<(-38)
X_29赋值:以成交量(手)的5日累和/3/当前流通股本(手)为权重收盘价的12日指数移动平均的动态移动平均
X_30赋值:(收盘价-X_29)/X_29*100
X_31赋值:1日前的X_30<(-37) AND X_30>1日前的X_30 AND 1日前的X_30<2日前的X_30 AND 2日前的X_30-1日前的X_30>1
X_32赋值:X_28 OR X_31 AND 成交量(手)/当前流通股本(手)*100<6
X_33赋值:X_32 AND 统计10日中满足X_32的天数=1
X_34赋值:(最高价-最低价)/最高价*100+(收盘价-1日前的收盘价)/1日前的收盘价*100
X_35赋值:X_34的50日简单移动平均的5日指数移动平均
X_36赋值:X_35>5日内X_35的最低值*1.01 AND 1日前的X_35<1日前的5日内X_35的最低值*1.01 AND 50日内X_35的最低值=5日内X_35的最低值
X_37赋值:5日内最低价的最低值=50日内最低价的最低值 AND 5日内最低价的最低值<70日内最低价的最高值*0.5
X_38赋值:X_36 AND X_37
X_39赋值:X_15 OR X_25 OR X_33 OR X_38 AND X_4
X_40赋值:收盘价/1日前的收盘价>1.05 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
X_41赋值:X_40的28日过滤*100
X_42赋值:如果收盘价/1日前的收盘价>1.05ANDHIGH/收盘价<1.01ANDCLOSE>1日前的收盘价,返回91,否则返回0
X_43赋值:X_42>90的45日过滤 AND X_42>90的35日过滤 AND X_41>0
输出X_44:X_43 AND 统计60日中满足X_43的天数=1

演示图片