首页 > 选股公式 > 多头35度上升选股公式

多头35度上升选股公式

日期:2021-12-17 18:51:02

选股公式源码

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
主力:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
角度:=ATAN((主力-REF(主力,1))/REF(主力,1)*100)*180/3.1416;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
XG2:主力>REF(主力,1) AND 角度>=35 AND VAR19;

选股公式翻译

MID赋值:(3*收盘价+最低价+开盘价+最高价)/6
主力赋值:(20*MID+19*1日前的MID+18*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210
角度赋值:(主力-1日前的主力)/1日前的主力*100的反正切*180/3.1416
JRH赋值:2日内收盘价的最高值
JRL赋值:2日内收盘价的最低值
MA3赋值:收盘价的3日简单移动平均
YTSL赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR1赋值:(收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价)
VAR2赋值:(1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR3赋值:(1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR4赋值:(1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR5赋值:(1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR6赋值:(1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR7赋值:(1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR8赋值:(1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR9赋值:(1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARA赋值:(1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARB赋值:(1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARC赋值:(1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARD赋值:(收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价)
VARE赋值:(1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARF赋值:(1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR10赋值:(1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR11赋值:(1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR12赋值:(1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR13赋值:(1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR14赋值:(1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR15赋值:(1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR16赋值:(1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR17赋值:(1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR18赋值:(1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR19赋值:((1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18) AND VAR1)
VAR1A赋值:((1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC) AND VARD)
输出XG2:主力>1日前的主力 AND 角度>=35 AND VAR19

演示图片