首页 > 选股公式 > 小疯牛选股公式

小疯牛选股公式

日期:2021-12-17 18:51:02

选股公式源码

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
低吸:=CROSS(RSI,11);
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
{DRAWTEXT(FILTER(VARB,6),L-0.05,'坚决买进'),COLORFF00FF;
DRAWTEXT(FILTER(VARB,6),L,'★'),COLORFF00FF;}
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
{DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L,'★'),COLORYELLOW;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L-0.05,'出击'),COLORYELLOW;}
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
R1:=(C+L+H)/3;
R2:=EMA(R1,6);
R3:=EMA(R2,5);
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
中期波段:=SMA(K4,3,1);
VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
VV2:=SMA(VV1,3,1);
VV3:=3*VV1-2*VV2;
趋势:=EMA(VV3,3);
VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
VA1:=(CLOSE*2+HIGH+LOW)/4*10;
VA2:=EMA(VA1,13);
VA3:=EMA(VA1,34);
VA14:=VA2-VA3;
VA15:=EMA(VA14,5);
VA16:=2*(VA14-VA15)*5.5;
AAA1:=VA16>=0 AND 趋势<13;
转折:=REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1);
短线波段:=(EXIST(转折,2) AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1));
WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
XYS0:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;
XYS1:=MA(XYS0,2);
XYS2:=MA(XYS0,1);
波段买入:FILTER(短线波段,3)&&CROSS(D1,K1)&&CROSS(XYS2,XYS1);

选股公式翻译

LC赋值:1日前的收盘价 RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100 低吸赋值:RSI上穿11 VAR7赋值:成交额(元)/成交量(手)/100的3日指数移动平均 VAR8赋值:VAR7的88日指数移动平均 VAR9赋值:VAR7的88日指数移动平均*0.85 VARA赋值:VAR9*0.87 VARB赋值:最低价1日前的收盘价*1.02 VARF赋值:(2*收盘价+最高价+最低价)/4 VA4赋值:34日内最低价的最低值 VA5赋值:34日内最高价的最高值 VA6赋值:(VARF-VA4)/(VA5-VA4)*100的6日指数移动平均 VA7赋值:0.667*1日前的VA6+0.333*VA6的4日指数移动平均 A赋值:(3*收盘价+最低价+开盘价+最高价)/6 D1赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/211 D2赋值:D1的2日指数移动平均 D3赋值:D2的2日指数移动平均 K1赋值:D3的2日指数移动平均 R1赋值:(收盘价+最低价+最高价)/3 R2赋值:R1的6日指数移动平均 R3赋值:R2的5日指数移动平均 RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100 RSV4赋值:(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)*100 短期B赋值:RSV1的3日[1日权重]移动平均 短期A赋值:短期B的3日[1日权重]移动平均 K4赋值:RSV4的8日[1日权重]移动平均 中期波段赋值:K4的3日[1日权重]移动平均 VV1赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均 VV2赋值:VV1的3日[1日权重]移动平均 VV3赋值:3*VV1-2*VV2 趋势赋值:VV3的3日指数移动平均 VV4赋值:(趋势-1日前的趋势)/1日前的趋势*100 VA1赋值:(收盘价*2+最高价+最低价)/4*10 VA2赋值:VA1的13日指数移动平均 VA3赋值:VA1的34日指数移动平均 VA14赋值:VA2-VA3 VA15赋值:VA14的5日指数移动平均 VA16赋值:2*(VA14-VA15)*5.5 AAA1赋值:VA16>=0 AND 趋势<13 转折赋值:1日前的中期波段<2日前的中期波段 AND 中期波段>1日前的中期波段 短线波段赋值:(最近2日存在转折 AND 短期B>=短期A) OR (1日前的短期B<1日前的短期A AND 短期B>=短期A AND 中期波段>1日前的中期波段) WY1001赋值:(2*收盘价+最高价+最低价)/4 WY1002赋值:WY1001的4日指数移动平均 WY1003赋值:WY1002的4日指数移动平均 WY1004赋值:WY1003的4日指数移动平均 XYS0赋值:(WY1004-1日前的WY1004)/1日前的WY1004*100 XYS1赋值:XYS0的2日简单移动平均 XYS2赋值:XYS0的1日简单移动平均 输出波段买入:短线波段的3日过滤并且D1上穿K1并且XYS2上穿XYS1

演示图片