首页 > 选股公式 > 资金动能选股公式

资金动能选股公式

日期:2021-12-17 18:51:02

选股公式源码

{CX1:=O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20);
CX11:=O<MA(C,5) AND O<MA(C,10) AND O<MA(C,30) AND C>MA(C,5) AND C>MA(C,10) AND C>MA(C,30);
CX2:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,10)>MA(C,30) AND MA(C,30)>MA(C,60);
CX3:=NOT(CROSS(MA(C,10),MA(C,5)) OR CROSS(MA(C,30),MA(C,20)));
CX4:=C>O AND C/REF(C,1)>1.02;
CXG:(CX1 OR CX11) AND CX2 AND CX3 AND CX4;}
LCX1:=O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20);
LCX11:=O<MA(C,5) AND O<MA(C,10) AND O<MA(C,30) AND C>MA(C,5) AND C>MA(C,10) AND C>MA(C,30);
LCX2:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,10)>MA(C,30) AND MA(C,30)>MA(C,60);
LCX3:=NOT(CROSS(MA(C,10),MA(C,5)) OR CROSS(MA(C,30),MA(C,20)) OR CROSS(MA(C,50),MA(C,10))
OR CROSS(MA(C,10),MA(C,20)) OR CROSS(MA(C,10),MA(C,30)));
LCX4:=C>O AND C/REF(C,1)>1.02;
LCXG:(LCX1 OR LCX11) AND LCX2 AND LCX3 AND LCX4;

选股公式翻译

LCX1赋值:开盘价<收盘价的5日简单移动平均 AND 开盘价<收盘价的10日简单移动平均 AND 开盘价<收盘价的20日简单移动平均 AND 收盘价>收盘价的5日简单移动平均 AND 收盘价>收盘价的10日简单移动平均 AND 收盘价>收盘价的20日简单移动平均 LCX11赋值:开盘价<收盘价的5日简单移动平均 AND 开盘价<收盘价的10日简单移动平均 AND 开盘价<收盘价的30日简单移动平均 AND 收盘价>收盘价的5日简单移动平均 AND 收盘价>收盘价的10日简单移动平均 AND 收盘价>收盘价的30日简单移动平均 LCX2赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的30日简单移动平均 AND 收盘价的30日简单移动平均>收盘价的60日简单移动平均 LCX3赋值:取反 LCX4赋值:收阳线AND 收盘价/1日前的收盘价>1.02 输出LCXG:(LCX1 OR LCX11) AND LCX2 AND LCX3 AND LCX4

演示图片