首页 > 选股公式 > 金牛开路喜丰收选股公式

金牛开路喜丰收选股公式

日期:2021-12-17 18:51:02

选股公式源码

VAR34:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,15,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,15,1),10,1);
VAR35:=100-VAR34;
VAR36:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR37:=SMA(VAR36,3,1);
VAR38:=SMA(VAR37,3,1);
VAR39:=(-1)*(EMA(VAR35,1)-50)+50;
金牛:=EMA(3*VAR37-2*VAR38,3);
开路:=MA(VAR39,18);
喜:=(-1)*(EMA(VAR35,1)-50)+50;
丰收:金牛>-1 AND 金牛<25 AND 开路<84 AND 喜>REF(喜,1);


选股公式翻译

VAR34赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的15日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的15日[1日权重]移动平均的10日[1日权重]移动平均
VAR35赋值:100-VAR34
VAR36赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR37赋值:VAR36的3日[1日权重]移动平均
VAR38赋值:VAR37的3日[1日权重]移动平均
VAR39赋值:(-1)*(VAR35的1日指数移动平均-50)+50
金牛赋值:3*VAR37-2*VAR38的3日指数移动平均
开路赋值:VAR39的18日简单移动平均
喜赋值:(-1)*(VAR35的1日指数移动平均-50)+50
输出丰收:金牛>-1 AND 金牛<25 AND 开路<84 AND 喜>1日前的喜

演示图片