首页 > 选股公式 > 老憨标签选股公式

老憨标签选股公式

日期:2021-12-17 18:51:02

选股公式源码

VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
VAR2:=SMA(VAR1,10,1);
RSV:= ((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100)-70;
RSV1:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
FATK:=SMA(RSV1,3,1);
形态:=SMA(FATK,3,1);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARB:=SMA(VARA,3,1);
VARC:=SMA(VARB,3,1);
加速:= EMA(3*VARB-2*VARC,3);
CC:=CROSS(加速,形态);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,29);
DEA:=EMA(DIF,6);
EE:=CROSS(DIF,DEA);
MA20:=MA(C,20);
MA60:=MA(C,60);
VAR11:=(CLOSE*2+HIGH+LOW)/4;
VAR12:=EMA(VAR11,8)-EMA(VAR11,25);
VAR13:=EMA(VAR12,8);
弃盘线:=(-2)*(VAR12-VAR13)*5.10;
控盘线:=2*(VAR12-VAR13)*5.10;
控盘:=REF(控盘线,1)<REF(控盘线,2) AND REF(控盘线,0)>REF(控盘线,1) OR CROSS(控盘线,弃盘线);
AA:=O>C AND C>REF(C,1) AND O/REF(C,1)>1.03;
去除星股:=IF(NAMELIKE('*'),0,1);
去除大盘股:=CAPITAL/1000000<15;
去除ST:=IF(NAMELIKE('ST'),0,1) AND IF(NAMELIKE('*ST'),0,1) AND IF(NAMELIKE('S'),0,1);
去停牌:=NOT(DYNAINFO(4)=0);
DD:=去除星股 AND 去除大盘股 AND 去除ST AND 去停牌;
涨幅:=(C-REF(C,1))/REF(C,1)*100<5 AND (C-REF(C,1))/REF(C,1)*100>-5;
五日涨幅:=COUNT(涨幅,5)=5;
XG:AA AND(CC OR EE) AND DD AND L>REF(H,1) AND 控盘 AND 五日涨幅 AND H>MA60 ;

选股公式翻译

VAR1赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*80
VAR2赋值:VAR1的10日[1日权重]移动平均
RSV赋值: ((9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100)-70
RSV1赋值: (收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
FATK赋值:RSV1的3日[1日权重]移动平均
形态赋值:FATK的3日[1日权重]移动平均
VARA赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VARB赋值:VARA的3日[1日权重]移动平均
VARC赋值:VARB的3日[1日权重]移动平均
加速赋值: 3*VARB-2*VARC的3日指数移动平均
CC赋值:加速上穿形态
DIF赋值:收盘价的12日指数移动平均-收盘价的29日指数移动平均
DEA赋值:DIF的6日指数移动平均
EE赋值:DIF上穿DEA
MA20赋值:收盘价的20日简单移动平均
MA60赋值:收盘价的60日简单移动平均
VAR11赋值:(收盘价*2+最高价+最低价)/4
VAR12赋值:VAR11的8日指数移动平均-VAR11的25日指数移动平均
VAR13赋值:VAR12的8日指数移动平均
弃盘线赋值:(-2)*(VAR12-VAR13)*5.10
控盘线赋值:2*(VAR12-VAR13)*5.10
控盘赋值:1日前的控盘线<2日前的控盘线 AND 0日前的控盘线>1日前的控盘线 OR 控盘线上穿弃盘线
AA赋值:收阴线AND 收盘价>1日前的收盘价 AND 开盘价/1日前的收盘价>1.03
去除星股赋值:如果模糊匹配品种名称,返回0,否则返回1
去除大盘股赋值:当前流通股本(手)/1000000<15
去除ST赋值:如果模糊匹配品种名称,返回0,否则返回1 AND 如果模糊匹配品种名称,返回0,否则返回1 AND 如果模糊匹配品种名称,返回0,否则返回1
去停牌赋值:取反
DD赋值:去除星股 AND 去除大盘股 AND 去除ST AND 去停牌
涨幅赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100<5 AND (收盘价-1日前的收盘价)/1日前的收盘价*100>-5
五日涨幅赋值:统计5日中满足涨幅的天数=5
输出XG:AA AND(CC OR EE) AND DD AND 最低价>1日前的最高价 AND 控盘 AND 五日涨幅 AND 最高价>MA60 

演示图片