首页 > 选股公式 > 缩量启动选股公式

缩量启动选股公式

日期:2021-12-17 18:51:02

选股公式源码

VAR1C:=(HIGH - MIN(OPEN,CLOSE));
VAR2C:=(CLOSE - OPEN);
VAR3C:=(MIN(OPEN,CLOSE) - LOW);
VAR4C:=(HIGH - LOW);
VAR5C:=((VOL * VAR1C) / VAR4C);
VAR6C:=((VOL * VAR2C) / VAR4C);
VAR7C:=((VOL * VAR3C) / VAR4C);
VAR8C:=((VAR5C - VAR6C) - VAR7C);
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 100),4) / SUM((VOL * 100),4));
VARB:=(INTPART((VARA * 100)) / 100);
VARC:=(SUM(((CLOSE * VOL) * 100),7) / SUM((VOL * 100),7));
VARD:=(INTPART((VARC * 100)) / 100);
VARE:=(SUM(((CLOSE * VOL) * 100),28) / SUM((VOL * 100),28));
VARF:=(INTPART((VARE * 100)) / 100);
短线趋势:=(EMA(CLOSE,5) - EMA(CLOSE,10));
中线趋势:=EMA(短线趋势,9);
VAR10:=((0 - ((100 * (HHV(CLOSE,5) - CLOSE)) / (HHV(CLOSE,5) - LLV(LOW,5)))) + 100);
VAR11:=((0 - ((100 * (HHV(CLOSE,10) - CLOSE)) / (HHV(CLOSE,10) - LLV(LOW,10)))) + 100);
VAR12:=((0 - ((100 * (HHV(CLOSE,20) - CLOSE)) / (HHV(CLOSE,20) - LLV(LOW,20)))) + 100);
VAR13:=((0 - ((100 * (HHV(CLOSE,30) - CLOSE)) / (HHV(CLOSE,30) - LLV(LOW,30)))) + 100);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 - VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
(((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)) AND DYNAINFO(4)>0
AND REF(C,1)<REF(O,1) AND REF(C,1)<REF(C,2);

选股公式翻译

VAR1C赋值:(最高价 - 开盘价和收盘价的较小值)
VAR2C赋值:(收盘价 - 开盘价)
VAR3C赋值:(开盘价和收盘价的较小值 - 最低价)
VAR4C赋值:(最高价 - 最低价)
VAR5C赋值:((成交量(手) * VAR1C) / VAR4C)
VAR6C赋值:((成交量(手) * VAR2C) / VAR4C)
VAR7C赋值:((成交量(手) * VAR3C) / VAR4C)
VAR8C赋值:((VAR5C - VAR6C) - VAR7C)
VAR4赋值:收盘价的5日简单移动平均
VAR5赋值:收盘价的10日简单移动平均
VAR6赋值:收盘价的30日简单移动平均
VAR7赋值:收盘价的60日简单移动平均
VAR8赋值:获利盘为85%的成本分布的7日指数移动平均
VAR9赋值:获利盘为15%的成本分布的7日指数移动平均
VARA赋值:(((收盘价*成交量(手))*100)的4日累和 / (成交量(手)*100)的4日累和)
VARB赋值:((VARA*100)的整数部分 / 100)
VARC赋值:(((收盘价*成交量(手))*100)的7日累和 / (成交量(手)*100)的7日累和)
VARD赋值:((VARC*100)的整数部分 / 100)
VARE赋值:(((收盘价*成交量(手))*100)的28日累和 / (成交量(手)*100)的28日累和)
VARF赋值:((VARE*100)的整数部分 / 100)
短线趋势赋值:(收盘价的5日指数移动平均 - 收盘价的10日指数移动平均)
中线趋势赋值:短线趋势的9日指数移动平均
VAR10赋值:((0 - ((100 * (5日内收盘价的最高值 - 收盘价)) / (5日内收盘价的最高值 - 5日内最低价的最低值))) + 100)
VAR11赋值:((0 - ((100 * (10日内收盘价的最高值 - 收盘价)) / (10日内收盘价的最高值 - 10日内最低价的最低值))) + 100)
VAR12赋值:((0 - ((100 * (20日内收盘价的最高值 - 收盘价)) / (20日内收盘价的最高值 - 20日内最低价的最低值))) + 100)
VAR13赋值:((0 - ((100 * (30日内收盘价的最高值 - 收盘价)) / (30日内收盘价的最高值 - 30日内最低价的最低值))) + 100)
VAR14赋值:1日前的中线趋势
VAR15赋值:中线趋势
VAR16赋值:(VAR15 - VAR14)
VAR17赋值:1日前的短线趋势
VAR18赋值:短线趋势
VAR19赋值:(VAR18 - VAR17)
VAR1A赋值:开盘价
VAR1B赋值:收盘价
(((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B>= VAR4)) AND (VAR1B>= VARF)) AND (VAR16> 0)) AND (VAR19> 0)) AND 开盘价>0AND 1日前的收盘价<1日前的开盘价 AND 1日前的收盘价<2日前的收盘价

演示图片