首页 > 选股公式 > 新高二选股公式

新高二选股公式

日期:2021-12-17 18:51:02

选股公式源码

JC:=(C+O+H+L)/4;
MA5:=EMA(JC,5);
MA10:=EMA(JC,10);
MA60:=EMA(JC,60);
MA20:=EMA(JC,20);
D:=REF(LLV(L,6),1);
P:=HHV(H,6);
DBX:=D<MA5&&D<MA10&&D<MA60&&D<MA20;
PB:=P>MA5&&P>MA10&&P>MA60&&P>MA20;
DIF:=EMA(VOL,20)-EMA(VOL,60);
DEA:=EMA(DIF,9);
JUH:=C>JC&&C>MA5&&C>MA10&&((C-REF(C,1))/REF(C,1)>0.035);
HSCOL:=100*VOL/(FINANCE(7)/100);
MAHSL5:=MA(HSCOL,5);
MAHSL10:=MA(HSCOL,10);
VC:=HSCOL>(MAHSL10*1.8);
VC1:=MAHSL10>3.5&&HSCOL>4.5;BJC:=JUH&&(VC OR VC1);
QWE:REF(EVERY(BJC=0,10),1)&&BJC>0;

选股公式翻译

JC赋值:(收盘价+开盘价+最高价+最低价)/4
MA5赋值:JC的5日指数移动平均
MA10赋值:JC的10日指数移动平均
MA60赋值:JC的60日指数移动平均
MA20赋值:JC的20日指数移动平均
D赋值:1日前的6日内最低价的最低值
P赋值:6日内最高价的最高值
DBX赋值:DMA5并且P>MA10并且P>MA60并且P>MA20
DIF赋值:成交量(手)的20日指数移动平均-成交量(手)的60日指数移动平均
DEA赋值:DIF的9日指数移动平均
JUH赋值:收盘价>JC并且收盘价>MA5并且收盘价>MA10并且((收盘价-1日前的收盘价)/1日前的收盘价>0.035)
HSCOL赋值:100*成交量(手)/(流通股本(股)/100)
MAHSL5赋值:HSCOL的5日简单移动平均
MAHSL10赋值:HSCOL的10日简单移动平均
VC赋值:HSCOL>(MAHSL10*1.8)
VC1赋值:MAHSL10>3.5并且HSCOL>4.5
BJC赋值:JUH并且(VC OR VC1)
输出QWE:1日前的最近10日一直存在BJC=0并且BJC>0

演示图片