首页 > 选股公式 > 凸凹合并选股公式

凸凹合并选股公式

日期:2021-12-17 18:51:02

选股公式源码

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TTR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TTR);
MDI:=((DMM * 100) / TTR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:=(MA(HHH,2)*3+HHH*13)/16;
SS:=(MA(CCC,2)*3+CCC*13)/16;
GG:=MA(HHH,5);
MM:=MA(CCC,5);
WW:=IF(QQ<GG ,SS,MM);
EE:=IF(SS<MM ,GG,QQ);
买:=EE-WW<5.6;
CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100);
YJDD:=(EMA(CSS,3)-50)*2;
强弱:=(YJDD+100)/2;
A2:=CROSS(20,强弱)*50;
阶段底部 AND 买 AND A2;

选股公式翻译

LC赋值:1日前的收盘价
RSI5赋值:(((收盘价-LC)和0的较大值的5日[1日权重]移动平均 / (收盘价-LC)的绝对值的5日[1日权重]移动平均) * 100)
TTR赋值:(最高价-最低价)和(最高价-1日前的收盘价)的绝对值的较大值和(最低价-1日前的收盘价)的绝对值的较大值的10日累和
HD赋值:(最高价 - 1日前的最高价)
LD赋值:(1日前的最低价 - 最低价)
DMP赋值:如果((HD>0)AND(HD>LD)),返回HD,否则返回0的10日累和
DMM赋值:如果((LD>0)AND(LD>HD)),返回LD,否则返回0的10日累和
PDI赋值:((DMP * 100) / TTR)
MDI赋值:((DMM * 100) / TTR)
ADX赋值:(((MDI-PDI)的绝对值/(MDI+PDI))*100)的5日简单移动平均
AV赋值:(RSI5 + ADX)
WR10赋值:((100 * (10日内最高价的最高值 - 收盘价)) / (10日内最高价的最高值 - 10日内最低价的最低值))
NEWVOL赋值:(RSI5 - WR10)
阶段底部赋值:(AV + NEWVOL)
AA赋值:1日前的收盘价
BBB赋值:收盘价-AA和0的较大值的21日[1日权重]移动平均/收盘价-AA的绝对值的21日[1日权重]移动平均*1000
HHH赋值:BBB-27日内BBB的最低值
CCC赋值:27日内BBB的最低值-BBB
QQ赋值:(HHH的2日简单移动平均*3+HHH*13)/16
SS赋值:(CCC的2日简单移动平均*3+CCC*13)/16
GG赋值:HHH的5日简单移动平均
MM赋值:CCC的5日简单移动平均
WW赋值:如果QQ

演示图片