首页 > 选股公式 > 下注提钱选股公式

下注提钱选股公式

日期:2021-12-17 18:51:02

选股公式源码

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
P:=7;
VAR1:=(C*2+H+L+O)/5;
CZ1:=SUM(MAX(0,HIGH-REF(VAR1,1)),P)/SUM(MAX(0,REF(VAR1,1)-LOW),P)*100;
CZ:=EMA(CZ1,4);
CA1:=SUM(MAX(0,HIGH-REF(VAR1,1)),63)/SUM(MAX(0,REF(VAR1,1)-LOW),63)*100;
CA:=EMA(CA1,4);
AA:= REF(MA(CZ,10),5);
BB:= REF(MA(CZ,20),9);
CC:= REF(MA(CZ,40),17);
AA1:="OBV";
XX:=IF(AA>BB,IF(AA>CC,AA,CC),IF(BB>CC,BB,CC));
QQ:=IF(AA<BB,IF(AA<CC,AA,CC),IF(BB<CC,BB,CC));
顶:=XX;
底:=QQ;
主力:=CZ COLORRED;
ZZ1:=(XX+QQ)/2;
VAR5:=CZ;
VAR3:=1;
MM:=EMA(SLOPE(VAR5,21)*20+VAR5,55)*VAR3;
趋势:=MM;
SS:=EMA(VAR5,5);
SS1:=EMA(SS,5)*VAR3;
预测:=SS;
下降:=IF(REF(主力,1)>主力,主力,DRAWNULL)LINETHICK5,COLOR00FF00;
上升:=IF(REF(主力,1)<主力,主力,DRAWNULL)LINETHICK5,COLOR0000FF;
VAR11:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR21:=2*ABS(VAR1);
VAR31:=100-3*SMA((CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100,20,1)+2*SMA
(SMA((CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100,20,1),15,1);
筹码:= VAR31,COLORFF0000;
能量:= IF(VAR11>0,VAR21,0),COLOR00FF00,LINETHICK2;
量下:=IF(能量<REF(能量,1),能量,DRAWNULL)LINETHICK4,COLOR00FF00;
量上:=IF(能量>REF(能量,1),能量,DRAWNULL)LINETHICK4,COLOR0000FF;
DRAWICON( REF(主力,1)<主力 AND REF(主力,1)<REF(主力,2) AND 主力>=10 AND 主力<250 ,L,1);

选股公式翻译

MA1赋值:收盘价的5日简单移动平均
MA2赋值:收盘价的10日简单移动平均
MA3赋值:收盘价的20日简单移动平均
MA4赋值:收盘价的60日简单移动平均
P赋值:7
VAR1赋值:(收盘价*2+最高价+最低价+开盘价)/5
CZ1赋值:0和最高价-1日前的VAR1的较大值的P日累和/0和1日前的VAR1-最低价的较大值的P日累和*100
CZ赋值:CZ1的4日指数移动平均
CA1赋值:0和最高价-1日前的VAR1的较大值的63日累和/0和1日前的VAR1-最低价的较大值的63日累和*100
CA赋值:CA1的4日指数移动平均
AA赋值: 5日前的CZ的10日简单移动平均
BB赋值: 9日前的CZ的20日简单移动平均
CC赋值: 17日前的CZ的40日简单移动平均
AA1赋值:"OBV"
XX赋值:如果AA>BB,返回如果AA>CC,返回AA,否则返回CC,否则返回如果BB>CC,返回BB,否则返回CC
QQ赋值:如果AA主力,返回主力,否则返回无效数线宽为5,COLOR00FF00
上升赋值:如果1日前的主力<主力,返回主力,否则返回无效数线宽为5,COLOR0000FF
VAR11赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
VAR21赋值:2*VAR1的绝对值
VAR31赋值:100-3*(收盘价-90日内最低价的最低值)/(90日内最高价的最高值-90日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-90日内最低价的最低值)/(90日内最高价的最高值-90日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
筹码赋值: VAR31,COLORFF0000
能量赋值: 如果VAR11>0,返回VAR21,否则返回0,COLOR00FF00,线宽为2
量下赋值:如果能量<1日前的能量,返回能量,否则返回无效数线宽为4,COLOR00FF00
量上赋值:如果能量>1日前的能量,返回能量,否则返回无效数线宽为4,COLOR0000FF
当满足条件1日前的主力<主力ANDREF(主力,1)<2日前的主力AND主力>=10AND主力<250时,在最低价位置画1号图标

演示图片