首页 > 选股公式 > 走强买入选股公式

走强买入选股公式

日期:2021-12-17 18:51:02

选股公式源码

VAR1:=LLV(LOW,13);
VAR2:=HHV(HIGH,13);
VAR3:=SMA((CLOSE-VAR1)/(VAR2-VAR1)*100,5,1);
VAR4:=SMA((VAR2-CLOSE)/(VAR2-VAR1)*100,5,1);
AA:=VAR3;
BB:=VAR4;
VAR5:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
CC:=EMA(VAR5,3);
XG: CROSS(CC,BB)AND CC>=REF(CC,1) AND BB<=REF(BB,3)AND CC>=49.5 AND MA(C,3)>=REF(MA(C,3),1)AND MA(C,7)>=REF(MA(C,7),1) AND MA(C,60)>REF(MA(C,60),3);

选股公式翻译

VAR1赋值:13日内最低价的最低值
VAR2赋值:13日内最高价的最高值
VAR3赋值:(收盘价-VAR1)/(VAR2-VAR1)*100的5日[1日权重]移动平均
VAR4赋值:(VAR2-收盘价)/(VAR2-VAR1)*100的5日[1日权重]移动平均
AA赋值:VAR3
BB赋值:VAR4
VAR5赋值:收盘价-1日前的收盘价和0的较大值的5日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的5日[1日权重]移动平均*100
CC赋值:VAR5的3日指数移动平均
输出XG: CC上穿BBAND CC>=1日前的CC AND BB<=3日前的BBAND CC>=49.5 AND 收盘价的3日简单移动平均>=1日前的收盘价的3日简单移动平均AND 收盘价的7日简单移动平均>=1日前的收盘价的7日简单移动平均 AND 收盘价的60日简单移动平均>3日前的收盘价的60日简单移动平均

演示图片