首页 > 选股公式 > 主升抓牛选股公式

主升抓牛选股公式

日期:2021-12-17 18:51:02

选股公式源码

A:=CROSS(SMA(CLOSE,2,1),SMA(LOW,5,1));
A1:=(SMA(HIGH,21,2)*1.05)*1.05;
A2:=IF(A,A1,SMA(LOW,5,1));
A3:=CROSS(SMA(CLOSE,2,1),(SMA(HIGH,21,2)*1.05));
A4:=IF(A3,(SMA(HIGH,21,2)*1.05)*1.10,(SMA(LOW,21,2)*0.95));
A5:=A2>SMA(LOW,5,1) AND CROSS(C,REF(MA(C,13),13/2+1)) AND VOL>0;
A6:=REF(H/O<1.02,1) AND REF(C<O,1);
在主升抓牛:A4>(SMA(LOW,21,2)*0.95) OR A5 AND A6;

选股公式翻译

A赋值:收盘价的2日[1日权重]移动平均上穿最低价的5日[1日权重]移动平均
A1赋值:(最高价的21日[2日权重]移动平均*1.05)*1.05
A2赋值:如果A,返回A1,否则返回最低价的5日[1日权重]移动平均
A3赋值:收盘价的2日[1日权重]移动平均上穿(最高价的21日[2日权重]移动平均*1.05)
A4赋值:如果A3,返回(最高价的21日[2日权重]移动平均*1.05)*1.10,否则返回(最低价的21日[2日权重]移动平均*0.95)
A5赋值:A2>最低价的5日[1日权重]移动平均 AND 收盘价上穿13/2+1日前的收盘价的13日简单移动平均 AND 成交量(手)>0
A6赋值:1日前的最高价/开盘价<1.02 AND 1日前的收阴线
输出在主升抓牛:A4>(最低价的21日[2日权重]移动平均*0.95) OR A5 AND A6

演示图片