首页 > 选股公式 > 强势股抄底选股公式

强势股抄底选股公式

日期:2021-12-17 18:51:02

选股公式源码

VAR1:=(EMA(C,12)-EMA(C,26))*100+50;
VAR2:=EMA(VAR1,9);
VAR3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
VAR6:=SMA(VAR3,21,8);
VAR7:=MA(C,80)-MA(C,10)/7;
VAR8:=EMA(C,5);
VAR9:=MA((LLV(C,9))*1.1,14);
VAR10:=2*VAR9-VAR8-C*0.1;
VAR11:=IF(((VAR8-VAR10)*5>0),(POW((VAR8-VAR10)*5,2))/10,(-1*(POW((VAR8-VAR10)*(5),2)))/(10));
VAR12:=IF((VAR11>0),VAR11-0,12);
VAR13:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
趋势:=CEILING(SMA(VAR5,13,8));
见底:趋势-VAR6<-65;

选股公式翻译

VAR1赋值:(收盘价的12日指数移动平均-收盘价的26日指数移动平均)*100+50
VAR2赋值:VAR1的9日指数移动平均
VAR3赋值:((21日内最高价的最高值-收盘价)/(21日内最高价的最高值-21日内最低价的最低值))*100-10
VAR4赋值:((收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值))*100
VAR5赋值:VAR4的13日[8日权重]移动平均
VAR6赋值:VAR3的21日[8日权重]移动平均
VAR7赋值:收盘价的80日简单移动平均-收盘价的10日简单移动平均/7
VAR8赋值:收盘价的5日指数移动平均
VAR9赋值:(9日内收盘价的最低值)*1.1的14日简单移动平均
VAR10赋值:2*VAR9-VAR8-收盘价*0.1
VAR11赋值:如果((VAR8-VAR10)*5>0),返回((VAR8-VAR10)*5的2乘幂)/10,否则返回(-1*((VAR8-VAR10)*(5)的2乘幂))/(10)
VAR12赋值:如果(VAR11>0),返回VAR11-0,否则返回12
VAR13赋值:收盘价-2日前的收盘价和0的较大值的7日[1日权重]移动平均/收盘价-2日前的收盘价的绝对值的7日[1日权重]移动平均*100
趋势赋值:VAR5的13日[8日权重]移动平均的向上舍入
输出见底:趋势-VAR6<-65

演示图片