首页 > 选股公式 > 提前精准选股公式

提前精准选股公式

日期:2021-12-17 18:51:02

选股公式源码

A:=(C*2+H+L)/4*10;
A1:=EMA(A,13)-EMA(A,34);
A2:=EMA(A1,5);
A3:=2*(A1-A2)*5.5;
A4:=IF(A3>=0,A3,0);
A5:=A4>REF(A4,1) AND REF(A3<0,1);
A6:=REF(A4,1)<=REF(A4,2)AND A4>REF(A4,1);
A7:= C/REF(C,1)>1.07;
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
XG:FILTER(VAR327>1,5) AND A5 OR A6 AND A7;

选股公式翻译

A赋值:(收盘价*2+最高价+最低价)/4*10
A1赋值:A的13日指数移动平均-A的34日指数移动平均
A2赋值:A1的5日指数移动平均
A3赋值:2*(A1-A2)*5.5
A4赋值:如果A3>=0,返回A3,否则返回0
A5赋值:A4>1日前的A4 AND 1日前的A3<0
A6赋值:1日前的A4<=2日前的A4AND A4>1日前的A4
A7赋值: 收盘价/1日前的收盘价>1.07
VAR326赋值:如果收盘价>1日前的收盘价,返回88,否则返回0
VAR327赋值:如果收盘价/1日前的收盘价>1.050ANDHIGH/收盘价<1.010ANDVAR326>0,返回91,否则返回0
输出XG:VAR327>1的5日过滤 AND A5 OR A6 AND A7

演示图片