首页 > 选股公式 > 至尊选股公式

至尊选股公式

日期:2021-12-17 18:51:02

选股公式源码

VAR1:=1;
VAR2:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR3:=(CLOSE-VAR2)/VAR2*100;
VAR4:=REF(VAR3,1)<-40 AND VAR3>REF(VAR3,1) AND REF(VAR3,1)<REF(VAR3,2) AND VAR3-REF(VAR3,1)>2.5;
VAR5:=(CLOSE-OPEN)/OPEN*100;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:=COUNT(VAR7<20,20)>=1;
VAR9:=VAR5>9 AND VAR8;
VARA:=100*WINNER(OPEN);
VARB:=100*WINNER(CLOSE);
VARC:=VARB-VARA;
VARD:=VARC>=30;
VARE:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VARF:=REF(CLOSE,1);
VAR10:=SMA(MAX(CLOSE-VARF,0),5,1)/SMA(ABS(CLOSE-VARF),5,1)*100;
VAR11:=COUNT(VAR10<20,20)>=1;
VAR12:=VARE AND VAR11;
VAR13:=MA(CLOSE,4);
VAR14:=MA(CLOSE,10);
VAR15:=MA(CLOSE,20);
VAR16:=MA(CLOSE,25);
VAR17:=COUNT(CROSS(VAR14,VAR15),2)=1;
VAR18:=COUNT(CROSS(VAR13,VAR16),2)=1;
VAR19:=VAR17 AND VAR18;
VAR1A:=VAR12 AND VARD AND VAR19;
VAR1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;
VAR1C:=CLOSE<VAR1B AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;
选股:VAR4 OR VAR9 OR VAR1A OR VAR1C*VAR1;

选股公式翻译

VAR1赋值:1
VAR2赋值:以成交量(手)的5日累和/3/当前流通股本(手)为权重收盘价的12日指数移动平均的动态移动平均
VAR3赋值:(收盘价-VAR2)/VAR2*100
VAR4赋值:1日前的VAR3<-40 AND VAR3>1日前的VAR3 AND 1日前的VAR3<2日前的VAR3 AND VAR3-1日前的VAR3>2.5
VAR5赋值:(收盘价-开盘价)/开盘价*100
VAR6赋值:1日前的收盘价
VAR7赋值:收盘价-VAR6和0的较大值的6日[1日权重]移动平均/收盘价-VAR6的绝对值的6日[1日权重]移动平均*100
VAR8赋值:统计20日中满足VAR7<20的天数>=1
VAR9赋值:VAR5>9 AND VAR8
VARA赋值:100*以开盘价计算的获利盘比例
VARB赋值:100*以收盘价计算的获利盘比例
VARC赋值:VARB-VARA
VARD赋值:VARC>=30
VARE赋值:收盘价/收盘价的3日简单移动平均>=1.07 AND 收盘价=3日内收盘价的最高值 AND 成交量(手)的2日简单移动平均/成交量(手)的40日简单移动平均>=3 AND 成交量(手)的2日简单移动平均=3日内成交量(手)的2日简单移动平均的最高值 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
VARF赋值:1日前的收盘价
VAR10赋值:收盘价-VARF和0的较大值的5日[1日权重]移动平均/收盘价-VARF的绝对值的5日[1日权重]移动平均*100
VAR11赋值:统计20日中满足VAR10<20的天数>=1
VAR12赋值:VARE AND VAR11
VAR13赋值:收盘价的4日简单移动平均
VAR14赋值:收盘价的10日简单移动平均
VAR15赋值:收盘价的20日简单移动平均
VAR16赋值:收盘价的25日简单移动平均
VAR17赋值:统计2日中满足VAR14上穿VAR15的天数=1
VAR18赋值:统计2日中满足VAR13上穿VAR16的天数=1
VAR19赋值:VAR17 AND VAR18
VAR1A赋值:VAR12 AND VARD AND VAR19
VAR1B赋值:收盘价的80日简单移动平均-收盘价的10日简单移动平均/3
VAR1C赋值:收盘价成交量(手)的5日简单移动平均/240 AND 收盘价>1日前的收盘价*1.08 AND 收盘价<收盘价的13日简单移动平均*1.3
输出选股:VAR4 OR VAR9 OR VAR1A OR VAR1C*VAR1

演示图片