首页 > 选股公式 > 牛股重生选股公式

牛股重生选股公式

日期:2021-12-17 18:51:02

选股公式源码

AA:=MA(CLOSE,1);
AA1:=(LOW+HIGH+CLOSE)/3;
AA2:= MA(AA1,5);
BB:= HHV(AA2,10);
BB1:= MA(AA1,5);
BB2:=LLV(BB1,10);
BB3:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
HD1:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );
HD2:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
HD3:=(((HD1 ) * 100) / BB3);
LD1:=((HD2 * 100) / BB3);
LD2:=(MA(((ABS((LD1 - HD3)) / (LD1 + HD3)) * 100),3));
LD3:=((LD2 + REF(LD2,3)) / 2);
DD:="MACD.macd">0.04;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A:=CROSS(K,D);
VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR4:=REF(VAR3,1);
VAR5:=( IF(((LD2 > 88) AND (HD3 < 5.8)),80,0));
牛股重生:IF(VAR5=0 AND C>O AND REF(VAR5,1)=80,80,0) AND DD AND A ;

选股公式翻译

AA赋值:收盘价的1日简单移动平均
AA1赋值:(最低价+最高价+收盘价)/3
AA2赋值: AA1的5日简单移动平均
BB赋值: 10日内AA2的最高值
BB1赋值: AA1的5日简单移动平均
BB2赋值:10日内BB1的最低值
BB3赋值:(最高价-最低价)和(最高价-1日前的收盘价)的绝对值的较大值和(最低价-1日前的收盘价)的绝对值的较大值的5日累和
HD赋值:(最高价 - 1日前的最高价)
LD赋值:(1日前的最低价 - 最低价)
HD1赋值:(如果((HD>0)AND(HD>LD)),返回HD,否则返回0的5日累和 )
HD2赋值:如果((LD>0)AND(LD>HD)),返回LD,否则返回0的5日累和
HD3赋值:(((HD1 ) * 100) / BB3)
LD1赋值:((HD2 * 100) / BB3)
LD2赋值:((((LD1-HD3)的绝对值/(LD1+HD3))*100)的3日简单移动平均)
LD3赋值:((LD2 + 3日前的LD2) / 2)
DD赋值:"平滑异同平均的MACD">0.04
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
A赋值:K上穿D
VAR1赋值:最低价的1日简单移动平均
VAR2赋值:最高价的2日简单移动平均
VAR3赋值:收盘价的2日简单移动平均
VAR4赋值:1日前的VAR3
VAR5赋值:( 如果((LD2>88)AND(HD3<5.8)),返回80,否则返回0)
输出牛股重生:如果VAR5=0ANDC>OANDREF(VAR5,1)=80,返回80,否则返回0 AND DD AND A 

演示图片