首页 > 选股公式 > 慢速KDJ选股公式

慢速KDJ选股公式

日期:2021-12-17 18:51:02

选股公式源码

RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))-0.5;
K0:=SMA(RSV,3,1);
K:=K0;
D:=SMA(K0,2,1);
J1:=(3*K0-2*D);
J2:=MA(J1,2);
MAV:=(2*C+H+L)/4;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
SK:=EMA((MAV-VAR1)/(VAR2-VAR1)-0.5,8);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,1);
SJ:=3*SK-2*SD;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
信号:CROSS(SK,DEA) AND MA(C,18)>=REF(MA(C,18),1) AND SK>=REF(SK,1);

选股公式翻译

RSV赋值:(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)-0.5
K0赋值:RSV的3日[1日权重]移动平均
K赋值:K0
D赋值:K0的2日[1日权重]移动平均
J1赋值:(3*K0-2*D)
J2赋值:J1的2日简单移动平均
MAV赋值:(2*收盘价+最高价+最低价)/4
VAR1赋值:21日内最低价的最低值
VAR2赋值:21日内最高价的最高值
SK赋值:(MAV-VAR1)/(VAR2-VAR1)-0.5的8日指数移动平均
SD赋值:0.667*1日前的SK+0.333*SK的1日指数移动平均
SJ赋值:3*SK-2*SD
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2
输出信号:SK上穿DEA AND 收盘价的18日简单移动平均>=1日前的收盘价的18日简单移动平均 AND SK>=1日前的SK

演示图片