首页 > 选股公式 > 亮剑选股公式

亮剑选股公式

日期:2022-09-12 09:06:16

选股公式源码

ZFA := ((C / REF(C,1)) - 1) * 100;

ZFB := ((C / O) - 1) * 100;

ZF := MAX(ZFA,ZFB);

MA1 := MA(CLOSE,5);

MA2 := MA(CLOSE,10);

MA3 := MA(CLOSE,20);

MA4 := MA(CLOSE,60);

上针 := ((H - MAX(O,C)) * 100) / MAX(O,C);

下针 := ((MIN(O,C) - L) * 100) / L;

DIF := EMA(CLOSE,12) - EMA(CLOSE,26);

DEA := EMA(DIF,9);

MACD := (DIF - DEA) * 2;

DD := BArslAstCOUNT(macd > 0);

XD8 := MA(REF(HHV(H,8),1),2);

XD13 := MA(REF(HHV(H,13),1),2);

XD21 := MA(REF(HHV(H,21),1),2);

XD34 := MA(REF(HHV(H,34),1),2);

XD55 := MA(REF(HHV(H,55),1),2);

XD89 := MA(REF(HHV(H,89),1),2);

QQ1 := (BARSLAST((((((((((((((COUNT(H > XD8,4)) = 1) AND (H > XD8)) OR CROSS(C,XD8)) OR (((COUNT(H > XD13,4)) = 1) AND (H > XD13))) OR CROSS(C,XD13)) OR (((COUNT(H > XD21,4)) = 1) AND (H > XD21))) OR CROSS(C,XD21)) OR (((COUNT(H > XD34,4)) = 1) AND (H > XD34))) OR CROSS(C,XD34)) OR (((COUNT(H > XD55,4)) = 1) AND (H > XD55))) OR CROSS(C,XD55)) OR (((COUNT(H > XD89,4)) = 1) AND (H > XD89))) OR CROSS(C,XD89))) <= 4;

QQ2 := (COUNT(REF(ZF,1) >= 5,3)) = 0;

QQ3 := ((((ZFB >= 1) AND (ZFA >= 2)) AND (上针 >= 3)) AND (下针 <= 1.5)) AND (上针 > ZF);

QQ4 := ((上针 >= 3) AND (上针 > MIN(ZFA,ZFB))) AND (((ZFB >= 1) AND (ZFA >= 2)) OR ((ZFB >= 2) AND (ZFA >= 1)));

QQ5 := (((ZF >= 5.5) AND (ZFA >= 5.5)) AND (上针 >= 3)) AND (下针 <= 1);

亮剑 : FILTER((((((((((((QQ3 OR QQ4) OR QQ5) AND QQ1) AND QQ2) AND (MA1 > REF(MA1,1))) AND (MA2 > REF(MA2,1))) AND (MA3 > REF(MA3,1))) AND ((COUNT(ZF >= 9,10)) = 0)) AND (C > MA4)) AND (MA2 > MA3)) AND (MA1 > MA2)) AND ((DD >= 6) OR ((BARSLAST(CROSS(DIF,DEA)) <= 4) AND (DIF > 0))),6);

选股公式翻译

赋值: ((收盘价 / 1日前的收盘价) - 1) * 100
赋值: ((收盘价 / 开盘价) - 1) * 100
赋值: ZFA和ZFB的较大值
赋值: 收盘价的5日简单移动平均
赋值: 收盘价的10日简单移动平均
赋值: 收盘价的20日简单移动平均
赋值: 收盘价的60日简单移动平均
赋值: ((最高价 - 开盘价和收盘价的较大值) * 100) / 开盘价和收盘价的较大值
赋值: ((开盘价和收盘价的较小值 - 最低价) * 100) / 最低价
赋值: 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均
赋值: DIF的9日指数移动平均
赋值: (DIF - DEA) * 2
赋值: 条件连续成立次数
赋值: 1日前的8日内最高价的最高值的2日简单移动平均
赋值: 1日前的13日内最高价的最高值的2日简单移动平均
赋值: 1日前的21日内最高价的最高值的2日简单移动平均
赋值: 1日前的34日内最高价的最高值的2日简单移动平均
赋值: 1日前的55日内最高价的最高值的2日简单移动平均
赋值: 1日前的89日内最高价的最高值的2日简单移动平均
赋值: (上次(((((((((((((统计4日中满足最高价>XD8的天数)=1)AND(最高价>XD8))ORCROSS(收盘价,XD8))OR(((统计4日中满足最高价>XD13的天数)=1)AND(最高价>XD13)))ORCROSS(收盘价,XD13))OR(((统计4日中满足最高价>XD21的天数)=1)AND(最高价>XD21)))ORCROSS(收盘价,XD距今天数) <= 4
赋值: (统计3日中满足1日前的ZF>=5的天数) = 0
赋值: ((((ZFB>= 1) AND (ZFA>= 2)) AND (上针>= 3)) AND (下针 <= 1.5)) AND (上针> ZF)
赋值: ((上针>= 3) AND (上针> ZFA和ZFB的较小值)) AND (((ZFB>= 1) AND (ZFA>= 2)) OR ((ZFB>= 2) AND (ZFA>= 1)))
赋值: (((ZF>= 5.5) AND (ZFA>= 5.5)) AND (上针>= 3)) AND (下针 <= 1)
输出亮剑 : (((((((((((QQ3ORQQ4)ORQQ5)ANDQQ1)ANDQQ2)AND(MA1>1日前的MA1))AND(均线>1日前的均线))AND(MA3>1日前的MA3))AND((统计10日中满足ZF>=9的天数)=0))AND(收盘价>MA4))AND(均线>MA3))AND(MA1>简单移动平均的))AND((DD>=6)OR((上次DIF上穿DEA距今天数<=4)AND(DIF>0)))日过滤

演示图片

亮剑选股公式