首页 > 选股公式 > 蓄势突破选股公式

蓄势突破选股公式

日期:2022-09-12 09:06:15

选股公式源码

BOLL := MA(CLOSE,20);

UPPER := BOLL + (2 * stD(CLOSE,20));

LOWER := BOLL - (2 * STD(CLOSE,20));

WIDTH := (UPPER - LOWER) / BOLL;

MAWIDTH := MA(WIDTH,6);

CV := CLOSE;

BBIBOLL := (((MA(CV,3) + MA(CV,6)) + MA(CV,12)) + MA(CV,24)) / 4;

UPR := BBIBOLL + (6 * STD(BBIBOLL,11));

DWN := BBIBOLL - (6 * STD(BBIBOLL,11));

WIDTH1 := (UPR - DWN) / BBIBOLL;

MAWIDTH1 := MA(WIDTH1,6);

UPPE := (1 + (6 / 100)) * MA(CLOSE,25);

LOWE := (1 - (6 / 100)) * MA(CLOSE,25);

ene := (UPPE + LOWE) / 2;

RSV := ((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100;

K := SMA(RSV,3,1);

D := SMA(K,3,1);

J := (3 * K) - (2 * D);

DIF := EMA(CLOSE,12) - EMA(CLOSE,26);

DEA := EMA(DIF,9);

MACD := (DIF - DEA) * 2;

MA05 := MA(CLOSE,5);

MA10 := MA(CLOSE,10);

MA30 := MA(CLOSE,30);

MA60 := MA(CLOSE,60);

VOLUME := VOL;

MAVOL5 := MA(VOLUME,5);

MAVOL10 := MA(VOLUME,10);

MAVOL30 := MA(VOLUME,30);

MAVOL60 := MA(VOLUME,60);

LB := DYNAINFO(17);

换手率 := (100 * V) / CAPITAL;

虚拟量 := IF((CURRBARSCOUNT = 1) AND (PERIOD = 5),(VOL * 240) / FROMOPEN,DRAWNULL);

交易时间 := FROMOPEN;

虚换手 := (换手率 * 240) / 交易时间;

虚换比 := 虚换手 / REF(换手率,1);

虚拟额 := (虚拟量 * C) * 100;

ZT := CLOSE >= (REF(CLOSE,1) * 1.09);

一字涨停 := ZT AND (OPEN = CLOSE);

冲ZT := H >= (REF(CLOSE,1) * 1.09);

ZT3 := COUNT(ZT,3);

ZT5 := COUNT(ZT,5);

ZT10 := COUNT(ZT,10);

ZT30 := COUNT(ZT,30);

ZT40 := COUNT(ZT,40);

ZT60 := COUNT(ZT,60);

MTR := EXPMEMA(MAX(MAX(HIGH - LOW,Abs(HIGH - REF(CLOSE,1))),ABS(REF(CLOSE,1) - LOW)),14);

HD := HIGH - REF(HIGH,1);

LD := REF(LOW,1) - LOW;

DMP := EXPMEMA(IF((HD > 0) AND (HD > LD),HD,0),14);

DMM := EXPMEMA(IF((LD > 0) AND (LD > HD),LD,0),14);

pdi := (DMP * 100) / MTR;

mdi := (DMM * 100) / MTR;

ADX := EXPMEMA(((ABS(MDI - PDI)) / (MDI + PDI)) * 100,6);

ADXR := EXPMEMA(ADX,6);

AA := MA((((2 * CLOSE) + HIGH) + LOW) / 4,5);

通道1 := (AA * 102) / 100;

通道2 := (AA * (200 - 102)) / 100;

CC := (ABS(((((2 * CLOSE) + HIGH) + LOW) / 4) - MA(CLOSE,20))) / MA(CLOSE,20);

DD := DMA(CLOSE,CC);

通道3 := (1 + (7 / 100)) * DD;

通道4 := (1 - (7 / 100)) * DD;

TYP := ((HIGH + LOW) + CLOSE) / 3;

CCI := (TYP - MA(TYP,14)) / (0.015 * AVEDEV(TYP,14));

剔除大盘 := ((((((((((((CAPITAL > 100000000) OR NAMELIKE(1)) OR NAMELIKE(2)) OR (FINANCE(34) < 1)) OR (FINANCE(33) < -0.8)) OR (C > 50)) OR ((C > 35) AND ((CLOSE / FINANCE(34)) > 10))) OR ((CAPITAL >= 40000000) AND ((CLOSE / FINANCE(34)) > 4))) OR ((CAPITAL >= 20000000) AND ((CLOSE / FINANCE(34)) > 5))) OR ((CAPITAL >= 10000000) AND ((CLOSE / FINANCE(34)) > 7))) OR (CODELIKE(3) AND (FINANCE(33) < -0.2))) OR (CODELIKE(3) AND (CAPITAL > 6000000))) OR (CODELIKE(4) AND (CAPITAL > 10000000));

我大盘 := NOT(剔除大盘);

蓄势突破 : ((((((((((((((((((DATE < 1991201) AND ((ZT60 >= 1) OR (COUNT(冲ZT,30) >= 1))) AND ((HHV(C,3) >= HHV(C,60)) OR (HHV(H,3) >= HHV(H,60)))) AND (C > REF(通道3,1))) AND (C > 通道1)) AND (通道1 > REF(通道1,1))) AND (MA30 >= REF(MA30,1))) AND (MA60 >= REF(MA60,1))) AND (MA10 >= REF(MA10,1))) AND (HHV(虚换手,3) >= 5)) AND 我大盘) AND (DYNAINFO(4) > 0)) AND (((ADX > REF(ADX,1)) AND (ADXR > REF(ADXR,1))) OR ((ADX > REF(ADX,1)) AND (PDI > REF(PDI,1))))) AND (MDI < REF(MDI,1))) AND (PDI > 20)) AND (ADX > 30)) AND (ADXR > 30)) AND (MDI < 20)) AND (CCI >= 100);

选股公式翻译

赋值: 收盘价的20日简单移动平均
赋值: BOLL + (2 * 收盘价的20日估算标准差)
赋值: BOLL - (2 * 收盘价的20日估算标准差)
赋值: (UPPER - LOWER) / BOLL
赋值: 布林极限宽的6日简单移动平均
赋值: 收盘价
赋值: (((CV的3日简单移动平均 + CV的6日简单移动平均) + CV的12日简单移动平均) + CV的24日简单移动平均) / 4
赋值: 多空布林线 + (6 * 多空布林线的11日估算标准差)
赋值: 多空布林线 - (6 * 多空布林线的11日估算标准差)
赋值: (UPR - DWN) / 多空布林线
赋值: WIDTH1的6日简单移动平均
赋值: (1 + (6 / 100)) * 收盘价的25日简单移动平均
赋值: (1 - (6 / 100)) * 收盘价的25日简单移动平均
赋值: (UPPE + LOWE) / 2
赋值: ((收盘价 - 9日内最低价的最低值) / (9日内最高价的最高值 - 9日内最低价的最低值)) * 100
赋值: RSV的3日[1日权重]移动平均
赋值: K的3日[1日权重]移动平均
赋值: (3 * K) - (2 * D)
赋值: 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均
赋值: DIF的9日指数移动平均
赋值: (DIF - DEA) * 2
赋值: 收盘价的5日简单移动平均
赋值: 收盘价的10日简单移动平均
赋值: 收盘价的30日简单移动平均
赋值: 收盘价的60日简单移动平均
赋值: 成交量(手)
赋值: VOLUME的5日简单移动平均
赋值: VOLUME的10日简单移动平均
赋值: VOLUME的30日简单移动平均
赋值: VOLUME的60日简单移动平均
赋值: 量比
赋值: (100 * 成交量(手)) / 当前流通股本(手)
赋值: 如果(到最后交易的周期=1)AND(周期类型=5),返回(成交量(手)*240)/当前离开盘分钟数,否则返回无效数
赋值: 当前离开盘分钟数
赋值: (换手率 * 240) / 交易时间
赋值: 虚换手 / 1日前的换手率
赋值: (虚拟量 * 收盘价) * 100
赋值: 收盘价>= (1日前的收盘价 * 1.09)
赋值: ZT AND (平盘)
赋值: 最高价>= (1日前的收盘价 * 1.09)
赋值: 统计3日中满足ZT的天数
赋值: 统计5日中满足ZT的天数
赋值: 统计10日中满足ZT的天数
赋值: 统计30日中满足ZT的天数
赋值: 统计40日中满足ZT的天数
赋值: 统计60日中满足ZT的天数
赋值: 最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值的14日指数平滑移动平均
赋值: 最高价 - 1日前的最高价
赋值: 1日前的最低价 - 最低价
赋值: 如果(HD>0)AND(HD>LD),返回HD,否则返回0的14日指数平滑移动平均
赋值: 如果(LD>0)AND(LD>HD),返回LD,否则返回0的14日指数平滑移动平均
赋值: (DMP * 100) / MTR
赋值: (DMM * 100) / MTR
赋值: ((MDI-PDI的绝对值)/(MDI+PDI))*100的6日指数平滑移动平均
赋值: ADX的6日指数平滑移动平均
赋值: (((2*收盘价)+最高价)+最低价)/4的5日简单移动平均
赋值: (AA * 102) / 100
赋值: (AA * (200 - 102)) / 100
赋值: (((((2*收盘价)+最高价)+最低价)/4)-收盘价的20日简单移动平均的绝对值) / 收盘价的20日简单移动平均
赋值: 以CC为权重收盘价的动态移动平均
赋值: (1 + (7 / 100)) * DD
赋值: (1 - (7 / 100)) * DD
赋值: ((最高价 + 最低价) + 收盘价) / 3
赋值: (TYP - TYP的14日简单移动平均) / (0.015 * TYP的14日平均绝对偏差)
赋值: ((((((((((((当前流通股本(手)> 100000000) OR 模糊匹配品种名称) OR 模糊匹配品种名称) OR (每股净资产 < 1)) OR (每股收益(全年折算) < -0.8)) OR (收盘价> 50)) OR ((收盘价> 35) AND ((收盘价 / 每股净资产)> 10))) OR ((当前流通股本(手)>= 40000000) AND ((收盘价 / 每股净资产)> 4))) OR ((当前流通股本(手)>= 20000000) AND ((收盘价 / 每股净资产)> 5))) OR ((当前流通股本(手)>= 10000000) AND ((收盘价 / 每股净资产)> 7))) OR (模糊匹配品种代码 AND (每股收益(全年折算) < -0.2))) OR (模糊匹配品种代码 AND (当前流通股本(手)> 6000000))) OR (模糊匹配品种代码 AND (当前流通股本(手)> 10000000))
赋值: 取反
输出蓄势突破 : ((((((((((((((((((日期 < 1991201) AND ((ZT60>= 1) OR (统计30日中满足冲ZT的天数>= 1))) AND ((3日内收盘价的最高值>= 60日内收盘价的最高值) OR (3日内最高价的最高值>= 60日内最高价的最高值))) AND (收盘价> 1日前的通道3)) AND (收盘价> 通道1)) AND (通道1> 1日前的通道1)) AND (MA30>= 1日前的MA30)) AND (MA60>= 1日前的MA60)) AND (MA10>= 1日前的MA10)) AND (3日内虚换手的最高值>= 5)) AND 我大盘) AND (开盘价> 0)) AND (((ADX> 1日前的ADX) AND (ADXR> 1日前的ADXR)) OR ((ADX> 1日前的ADX) AND (PDI> 1日前的PDI)))) AND (MDI < 1日前的MDI)) AND (PDI> 20)) AND (ADX> 30)) AND (ADXR> 30)) AND (MDI < 20)) AND (CCI>= 100)

演示图片

蓄势突破选股公式