首页 > 选股公式 > 强势狙击买进选股公式

强势狙击买进选股公式

日期:2022-09-12 09:06:13

选股公式源码

HJ_1:=IF(CLOSE>REF(CLOSE,1),88,0);

HJ_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND HJ_1>0,91,0);

HJ_3:=IF(DATETODAY(DATE)<99999999,1,1);

HJ_4:=FILTER(HJ_2>90,22.5)=1;

HJ_5:=FILTER(HJ_2>90,35)=1;

HJ_6:=FILTER(HJ_2>90,45)=1;

HJ_7:=FILTER(HJ_2>90,67.5)=1;

HJ_8:=FILTER(HJ_2>90,90)=1;

HJ_9:=FILTER(HJ_2>90,135)=1;

HJ_10:=FILTER(HJ_2>90,180)=1;

HJ_11:=FILTER(HJ_2>90,270)=1;

HJ_12:=HJ_4+HJ_5+HJ_6+HJ_7+HJ_8+HJ_9+HJ_10+HJ_11>=3*HJ_3;

HJ_13:=DATETODAY(DATE);

HJ_14:=VOL/REF(MA(VOL,5),1);

HJ_15:=HJ_14>135 AND HJ_14<137;

HJ_16:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);

HJ_17:=EMA(CLOSE,5);

HJ_18:=EMA(CLOSE,10);

HJ_19:=EMA(CLOSE,14);

HJ_20:=EMA(CLOSE,18);

HJ_21:=EMA(CLOSE,40);

HJ_22:=EMA(CLOSE,60);

HJ_23:=IF(DATE<2342.459961*500,1,1);

HJ_24:=MAX(HJ_21,HJ_22);

HJ_25:=CLOSE>HJ_24 AND HJ_16 AND (CLOSE>REF(HHV(HIGH,3),1)*HJ_3 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07);

HJ_26:=HJ_14>4.18 AND HJ_14<4.192;

HJ_27:=HJ_13>9550 AND HJ_13<99999999;

HJ_28:=HJ_26*HJ_27;

HJ_29:=HJ_14>2.67 AND HJ_14<2.69;

HJ_30:=HJ_13>9200 AND HJ_13<99999999;

HJ_31:=HJ_29*HJ_30;

HJ_32:=VOL;

HJ_33:=MA(HJ_32,5);

HJ_34:=HJ_33+HJ_33>HJ_32;

HJ_35:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15)*HJ_3)*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10)*HJ_23;

HJ_36:=CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07 AND HJ_35 AND HJ_34;

HJ_37:=DYNAINFO(4)*HJ_3>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)*HJ_23 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);

HJ_38:=HJ_14>2.91 AND HJ_14<2.93;

HJ_39:=HJ_13>9400 AND HJ_13<99999999;

HJ_40:=HJ_38*HJ_39;

HJ_41:=(CLOSE-REF(CLOSE,1)*HJ_3)/REF(CLOSE,1)*100>7;

HJ_42:=HJ_14>4.67 AND HJ_14<4.69;

HJ_43:=HJ_13>9300 AND HJ_13<99999999;

HJ_44:=HJ_42*HJ_43;

HJ_45:=HJ_14>2.07 AND HJ_14<2.08;

HJ_46:=HJ_13>9321 AND HJ_13<99999999;

HJ_47:=HJ_45*HJ_46;

HJ_48:=HJ_37 AND HJ_41;

HJ_49:=EMA(CLOSE,5);

HJ_50:=EMA(CLOSE,10);

HJ_51:=EMA(CLOSE,14);

HJ_52:=EMA(CLOSE,18);

HJ_53:=HJ_14>3.75 AND HJ_14<3.77;

HJ_54:=HJ_13>9400 AND HJ_13<99999999;

HJ_55:=HJ_53*HJ_54;

HJ_56:=EMA(CLOSE,40);

HJ_57:=EMA(CLOSE,60);

HJ_58:=MAX(MAX(MAX(MAX(MAX(HJ_49,HJ_18),HJ_51),HJ_52),HJ_56),HJ_57)*HJ_23;

HJ_59:=MIN(MIN(MIN(MIN(MIN(HJ_49,HJ_18),HJ_51),HJ_52),HJ_56),HJ_57)*HJ_23;

HJ_60:=CLOSE>HJ_58 AND LOW<HJ_59 AND (CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1)*HJ_3)/REF(CLOSE,1)>0.09);

HJ_61:=FILTER(HJ_60>0,0)=1;

HJ_62:=MA(REF(HHV(CLOSE,26),1),2);

HJ_63:=MA(CLOSE,26);

HJ_64:=POW(CLOSE-HJ_63,2);

HJ_65:=MA(HJ_64,13);

HJ_66:=SQRT(HJ_65);

HJ_67:=HJ_63+2*HJ_66;

HJ_68:=REF(HJ_67,1);

HJ_69:=CROSS(CLOSE,HJ_62) AND HIGH>REF(HJ_67,1) OR (CLOSE>HJ_62 AND CROSS(CLOSE,REF(HJ_67,1))*HJ_3) AND CLOSE/OPEN>0.998;

HJ_70:=MACD.macd;

HJ_71:=KD.K;

HJ_72:=KD.D;

HJ_73:=RSI.RSI1;

HJ_74:=RSI.RSI3;

HJ_75:=CLOSE-REF(CLOSE,1);

HJ_76:=IF(HJ_75>=0,HJ_75,0)*HJ_23;

HJ_77:=IF(HJ_75<0,-HJ_75,0)*HJ_23;

HJ_78:=MEMA(HJ_76,10);

HJ_79:=MEMA(HJ_77,10);

HJ_80:=MEMA(HJ_76,6);

HJ_81:=MEMA(HJ_77,6);

HJ_82:=MA(100*HJ_78/(HJ_78+HJ_79),10)*HJ_23;

HJ_83:=MA(100*HJ_80/(HJ_80+HJ_81),6)*HJ_23;

HJ_84:=MA(CLOSE,5)/MA(CLOSE,10)>0.999 AND MA(CLOSE,10)/MA(CLOSE,20)>0.9847 AND MA(CLOSE,20)>MA(CLOSE,60) AND REF(COUNT(MA(CLOSE,10)/MA(CLOSE,20)<1.017 OR MA(CLOSE,5)/MA(CLOSE,10)<1.017,8)>=1,1) AND MA(CLOSE,20)/MA(CLOSE,60)<1.121;

HJ_85:=(CLOSE-MA(CLOSE,60)*HJ_3)/MA(CLOSE,60)*100;

HJ_86:=COUNT(HJ_85<35,100)*HJ_3>=95;

HJ_87:=HJ_69 AND HJ_84>0 AND NOT(DYNAINFO(4)=0) AND HJ_86 AND REF(COUNT(MA(CLOSE,20)>MA(CLOSE,30),4)=4 AND COUNT(CLOSE>MA(CLOSE,5),3)>=2,1) AND VOL>REF(VOL,1) AND (REF(COUNT(CLOSE>OPEN,10)>=6 OR COUNT(CLOSE>OPEN,5)>=4,1) OR CLOSE=HIGH) AND (CROSS(HJ_83,HJ_82) OR CROSS(HJ_70,0) OR REF(COUNT(CROSS(HJ_70,0),3)=1 AND HJ_70<0.15 AND CLOSE/OPEN>0.989 AND CLOSE/REF(CLOSE,1)<1.03,1) OR CROSS(HJ_71,HJ_72) OR CROSS(HJ_73,HJ_74)) AND REF(CLOSE/OPEN>0.988 AND (CLOSE>OPEN OR (CLOSE<=OPEN AND HIGH/LOW<1.049)),1) AND HIGH/CLOSE<1.013 AND CLOSE/OPEN>1.05;

HJ_88:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60) AND MA(CLOSE,60)>MA(CLOSE,120) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1)*HJ_3;

HJ_89:=CLOSE>REF(CLOSE,1)*1.1-0.01;

HJ_90:=HHV(HIGH,20)=HHV(CLOSE,1) AND VOL>0 AND BARSCOUNT(CLOSE)>=20;

HJ_91:=HJ_14>3.28 AND HJ_14<3.3;

HJ_92:=HJ_13>9200 AND HJ_13<99999999;

HJ_93:=HJ_91*HJ_92;

HJ_94:=HJ_14>6.77 AND HJ_14<6.79;

HJ_95:=HJ_13>9500 AND HJ_13<99999999;

HJ_96:=HJ_94*HJ_95;

HJ_97:=HJ_15 OR HJ_28 OR HJ_31 OR HJ_44 OR HJ_40 OR HJ_47 OR HJ_55 OR HJ_93 OR HJ_96;

HJ_98:=VOL/REF(VOL,1)>1.9;

HJ_99:=HJ_88 AND HJ_89 AND HJ_90 AND HJ_98;

HJ_100:=KDJ.J-REF(KDJ.J,1)>30 AND CLOSE/REF(CLOSE,1)>1.043 AND MACD.MACD>0 AND MACD.DEA>0;

HJ_101:=MA(CLOSE,5);

HJ_102:=MA(CLOSE,10);

HJ_103:=MA(CLOSE,20);

HJ_104:=MA(CLOSE,30);

HJ_105:=MA(CLOSE,60);

HJ_106:=CLOSE>HJ_101 AND HJ_101>HJ_102 AND HJ_102>HJ_103 AND CLOSE>HJ_105;

HJ_107:=CLOSE/REF(CLOSE,1)>1.05 AND REF(CLOSE,1)/REF(CLOSE,2)<1.05 AND CLOSE/LLV(CLOSE,10)<1.4;

HJ_108:=VOL/REF(VOL,1)>2 OR VOL=HHV(VOL,15);

HJ_109:=CAPITAL<10000000;

HJ_110:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999>40;

HJ_111:=ATAN((MA(CLOSE,10)/REF(MA(CLOSE,10),1)-1)*100)*57.299999>30;

HJ_112:=ATAN((MA(CLOSE,20)/REF(MA(CLOSE,20),1)-1)*100)*57.299999>20;

HJ_113:=ATAN((MA(CLOSE,30)/REF(MA(CLOSE,30),1)-1)*100)*57.299999>10;

HJ_114:=HJ_110 AND HJ_111 AND HJ_112 AND HJ_113;

HJ_115:=KDJ.K>REF(KDJ.K,1)*HJ_23;

HJ_116:=KDJ.D>REF(KDJ.D,1) AND KDJ.D<70;

HJ_117:=KDJ.J>REF(KDJ.J,1)*HJ_23;

HJ_118:=HJ_115 AND HJ_116 AND HJ_117;

HJ_119:=HJ_21 AND HJ_107 AND HJ_108 AND HJ_109 AND HJ_114 AND HJ_118;

HJ_120:=FILTER(HJ_119,15)*HJ_3;

HJ_121:=HHV(REF(CLOSE,1),90);

HJ_122:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));

HJ_123:=IF(CLOSE>OPEN,HJ_122*(HIGH-LOW),IF(CLOSE<OPEN,HJ_122*(HIGH-OPEN+(CLOSE-LOW)),VOL/2))*HJ_23;

HJ_124:=IF(CLOSE>OPEN,0-HJ_122*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,0-HJ_122*(HIGH-LOW),0-VOL/2))*HJ_23;

HJ_125:=HJ_123/(-HJ_124);

HJ_126:=CLOSE/REF(CLOSE,1)*100-100;

HJ_127:=COUNT(HJ_126>7,10)*HJ_3>=1;

HJ_128:=REF(CLOSE,1)<MA(CLOSE,5) AND CLOSE>MA(CLOSE,5)*HJ_3;

HJ_129:=COUNT(CROSS(CLOSE,HJ_121),20)>=1;

HJ_130:=LOW>(REF(HIGH,1)+0.09)*HJ_23;

HJ_131:=(EMA(CLOSE,12)-EMA(CLOSE,25))*HJ_23;

HJ_132:=EMA(HJ_131,3);

HJ_133:=(HJ_131-HJ_132)*500000;

HJ_134:=MA(HJ_133-REF(HJ_133,1),3);

HJ_135:=HJ_134>REF(HJ_134,1)*HJ_3;

HJ_136:=HJ_129 AND HJ_128 AND HJ_125>3 AND HJ_127 AND HJ_135;

HJ_137:=(CLOSE-REF(CLOSE,2))/CLOSE>0.1;

HJ_138:=REF(HJ_137,(-2))*HJ_23;

HJ_139:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAst(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,5))*HJ_3;

HJ_140:=FILTER(HJ_139,28)*HJ_3;

HJ_141:=MA(CLOSE,5);

HJ_142:=MA(CLOSE,11);

HJ_143:=MA(CLOSE,21);

HJ_144:=MA(CLOSE,33);

HJ_145:=MA(CLOSE,89);

HJ_146:=MA(CLOSE,120)*HJ_23;

HJ_147:=HJ_141>HJ_142 AND HJ_142>HJ_143 AND HJ_143>HJ_144 AND HJ_144>HJ_145 AND HJ_145>HJ_146;

HJ_148:=MA(CLOSE,5)*HJ_3;

HJ_149:=ATAN((HJ_148/REF(HJ_148,1)-1)*100)*57.299999>60;

HJ_150:=CLOSE>MA(CLOSE,5)*HJ_3;

HJ_151:=HJ_149 AND HJ_150 AND HJ_147;

龙一:(HJ_12+HJ_25+HJ_36+HJ_48+HJ_87+HJ_99+HJ_120+HJ_136+HJ_140+HJ_151>=7 OR HJ_97) AND C>MA(C,20) AND MA(C,20)>REF(MA(C,20),1) ;

选股公式翻译

HJ_1赋值:如果收盘价>1日前的收盘价,返回88,否则返回0
HJ_2赋值:如果收盘价/1日前的收盘价>1.05ANDHIGH/收盘价<1.01ANDHJ_1>0,返回91,否则返回0
HJ_3赋值:如果日期对应的转换天数<99999999,返回1,否则返回1
HJ_4赋值:HJ_2>90的22.5日过滤=1
HJ_5赋值:HJ_2>90的35日过滤=1
HJ_6赋值:HJ_2>90的45日过滤=1
HJ_7赋值:HJ_2>90的67.5日过滤=1
HJ_8赋值:HJ_2>90的90日过滤=1
HJ_9赋值:HJ_2>90的135日过滤=1
HJ_10赋值:HJ_2>90的180日过滤=1
HJ_11赋值:HJ_2>90的270日过滤=1
HJ_12赋值:HJ_4+HJ_5+HJ_6+HJ_7+HJ_8+HJ_9+HJ_10+HJ_11>=3*HJ_3
HJ_13赋值:日期对应的转换天数
HJ_14赋值:成交量(手)/1日前的成交量(手)的5日简单移动平均
HJ_15赋值:HJ_14>135 AND HJ_14<137
HJ_16赋值:开盘价>0 AND 10日内最高价的最高值/10日内最低价的最低值<1.25 AND 1日前的收盘价<15日内最低价的最低值+(15日内最高价的最高值-15日内最低价的最低值)*0.85 AND 收阳线ANDSE 收盘价>=10日内最高价的最高值
HJ_17赋值:收盘价的5日指数移动平均
HJ_18赋值:收盘价的10日指数移动平均
HJ_19赋值:收盘价的14日指数移动平均
HJ_20赋值:收盘价的18日指数移动平均
HJ_21赋值:收盘价的40日指数移动平均
HJ_22赋值:收盘价的60日指数移动平均
HJ_23赋值:如果日期<2342.459961*500,返回1,否则返回1
HJ_24赋值:HJ_21和HJ_22的较大值
HJ_25赋值:收盘价>HJ_24 AND HJ_16 AND (收盘价>1日前的3日内最高价的最高值*HJ_3 AND (收盘价-1日前的收盘价)/1日前的收盘价>0.07)
HJ_26赋值:HJ_14>4.18 AND HJ_14<4.192
HJ_27赋值:HJ_13>9550 AND HJ_13<99999999
HJ_28赋值:HJ_26*HJ_27
HJ_29赋值:HJ_14>2.67 AND HJ_14<2.69
HJ_30赋值:HJ_13>9200 AND HJ_13<99999999
HJ_31赋值:HJ_29*HJ_30
HJ_32赋值:成交量(手)
HJ_33赋值:HJ_32的5日简单移动平均
HJ_34赋值:HJ_33+HJ_33>HJ_32
HJ_35赋值:开盘价>0 AND 10日内最高价的最高值/10日内最低价的最低值<1.25 AND 1日前的收盘价<15日内最低价的最低值+(15日内最高价的最高值-15日内最低价的最低值*HJ_3)*0.85 AND 收阳线ANDSE 收盘价>=10日内最高价的最高值*HJ_23
HJ_36赋值:收盘价>1日前的3日内最高价的最高值 AND (收盘价-1日前的收盘价)/1日前的收盘价>0.07 AND HJ_35 AND HJ_34
HJ_37赋值:开盘价*HJ_3>0 AND 10日内最高价的最高值/10日内最低价的最低值<1.25 AND 1日前的收盘价<(15日内最低价的最低值+(15日内最高价的最高值-15日内最低价的最低值)*0.85)*HJ_23 AND 收阳线ANDSE 收盘价>=10日内最高价的最高值
HJ_38赋值:HJ_14>2.91 AND HJ_14<2.93
HJ_39赋值:HJ_13>9400 AND HJ_13<99999999
HJ_40赋值:HJ_38*HJ_39
HJ_41赋值:(收盘价-1日前的收盘价*HJ_3)/1日前的收盘价*100>7
HJ_42赋值:HJ_14>4.67 AND HJ_14<4.69
HJ_43赋值:HJ_13>9300 AND HJ_13<99999999
HJ_44赋值:HJ_42*HJ_43
HJ_45赋值:HJ_14>2.07 AND HJ_14<2.08
HJ_46赋值:HJ_13>9321 AND HJ_13<99999999
HJ_47赋值:HJ_45*HJ_46
HJ_48赋值:HJ_37 AND HJ_41
HJ_49赋值:收盘价的5日指数移动平均
HJ_50赋值:收盘价的10日指数移动平均
HJ_51赋值:收盘价的14日指数移动平均
HJ_52赋值:收盘价的18日指数移动平均
HJ_53赋值:HJ_14>3.75 AND HJ_14<3.77
HJ_54赋值:HJ_13>9400 AND HJ_13<99999999
HJ_55赋值:HJ_53*HJ_54
HJ_56赋值:收盘价的40日指数移动平均
HJ_57赋值:收盘价的60日指数移动平均
HJ_58赋值:HJ_49和HJ_18的较大值和HJ_51的较大值和HJ_52的较大值和HJ_56的较大值和HJ_57的较大值*HJ_23
HJ_59赋值:HJ_49和HJ_18的较小值和HJ_51的较小值和HJ_52的较小值和HJ_56的较小值和HJ_57的较小值*HJ_23
HJ_60赋值:收盘价>HJ_58 AND 最低价1日前的3日内最高价的最高值 AND (收盘价-1日前的收盘价*HJ_3)/1日前的收盘价>0.09)
HJ_61赋值:HJ_60>0的历史过滤=1
HJ_62赋值:1日前的26日内收盘价的最高值的2日简单移动平均
HJ_63赋值:收盘价的26日简单移动平均
HJ_64赋值:收盘价-HJ_63的2乘幂
HJ_65赋值:HJ_64的13日简单移动平均
HJ_66赋值:HJ_65的开方
HJ_67赋值:HJ_63+2*HJ_66
HJ_68赋值:1日前的HJ_67
HJ_69赋值:收盘价上穿HJ_62 AND 最高价>1日前的HJ_67 OR (收盘价>HJ_62 AND 收盘价上穿1日前的HJ_67*HJ_3) AND 收盘价/开盘价>0.998
HJ_70赋值:平滑异同平均线的MACD
HJ_71赋值:随机指标KD的K
HJ_72赋值:随机指标KD的D
HJ_73赋值:RSI的RSI1
HJ_74赋值:RSI的RSI3
HJ_75赋值:收盘价-1日前的收盘价
HJ_76赋值:如果HJ_75>=0,返回HJ_75,否则返回0*HJ_23
HJ_77赋值:如果HJ_75<0,返回-HJ_75,否则返回0*HJ_23
HJ_78赋值:HJ_76的10日平滑移动平均
HJ_79赋值:HJ_77的10日平滑移动平均
HJ_80赋值:HJ_76的6日平滑移动平均
HJ_81赋值:HJ_77的6日平滑移动平均
HJ_82赋值:100*HJ_78/(HJ_78+HJ_79)的10日简单移动平均*HJ_23
HJ_83赋值:100*HJ_80/(HJ_80+HJ_81)的6日简单移动平均*HJ_23
HJ_84赋值:收盘价的5日简单移动平均/收盘价的10日简单移动平均>0.999 AND 收盘价的10日简单移动平均/收盘价的20日简单移动平均>0.9847 AND 收盘价的20日简单移动平均>收盘价的60日简单移动平均 AND 1日前的统计8日中满足收盘价的10日简单移动平均/收盘价的20日简单移动平均<1.017ORMA(收盘价,5)/收盘价的10日简单移动平均<1.017的天数>=1 AND 收盘价的20日简单移动平均/收盘价的60日简单移动平均<1.121
HJ_85赋值:(收盘价-收盘价的60日简单移动平均*HJ_3)/收盘价的60日简单移动平均*100
HJ_86赋值:统计100日中满足HJ_85<35的天数*HJ_3>=95
HJ_87赋值:HJ_69 AND HJ_84>0 AND 取反 AND HJ_86 AND 1日前的统计4日中满足收盘价的20日简单移动平均>收盘价的30日简单移动平均的天数=4ANDCOUNT(收盘价>收盘价的5日简单移动平均,3)>=2 AND 成交量(手)>1日前的成交量(手) AND (1日前的统计10日中满足收阳线的天数>=6ORCOUNT(收阳线,5)>=4 OR 收盘价=最高价) AND (HJ_83上穿HJ_82 OR HJ_70上穿0 OR 1日前的统计3日中满足HJ_70上穿0的天数=1ANDHJ_70<0.15ANDCLOSE/开盘价>0.989ANDCLOSE/1日前的收盘价<1.03 OR HJ_71上穿HJ_72 OR HJ_73上穿HJ_74) AND 1日前的收盘价/开盘价>0.988AND(收盘价>OPENOR(收盘价<=OPENANDHIGH/最低价<1.049)) AND 最高价/收盘价<1.013 AND 收盘价/开盘价>1.05
HJ_88赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>收盘价的60日简单移动平均 AND 收盘价的60日简单移动平均>收盘价的120日简单移动平均 AND 收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均*HJ_3
HJ_89赋值:收盘价>1日前的收盘价*1.1-0.01
HJ_90赋值:20日内最高价的最高值=1日内收盘价的最高值 AND 成交量(手)>0 AND 收盘价的有效数据周期数>=20
HJ_91赋值:HJ_14>3.28 AND HJ_14<3.3
HJ_92赋值:HJ_13>9200 AND HJ_13<99999999
HJ_93赋值:HJ_91*HJ_92
HJ_94赋值:HJ_14>6.77 AND HJ_14<6.79
HJ_95赋值:HJ_13>9500 AND HJ_13<99999999
HJ_96赋值:HJ_94*HJ_95
HJ_97赋值:HJ_15 OR HJ_28 OR HJ_31 OR HJ_44 OR HJ_40 OR HJ_47 OR HJ_55 OR HJ_93 OR HJ_96
HJ_98赋值:成交量(手)/1日前的成交量(手)>1.9
HJ_99赋值:HJ_88 AND HJ_89 AND HJ_90 AND HJ_98
HJ_100赋值:KDJ的J-1日前的KDJ的J>30 AND 收盘价/1日前的收盘价>1.043 AND 平滑异同平均线的MACD>0 AND 平滑异同平均线的DEA>0
HJ_101赋值:收盘价的5日简单移动平均
HJ_102赋值:收盘价的10日简单移动平均
HJ_103赋值:收盘价的20日简单移动平均
HJ_104赋值:收盘价的30日简单移动平均
HJ_105赋值:收盘价的60日简单移动平均
HJ_106赋值:收盘价>HJ_101 AND HJ_101>HJ_102 AND HJ_102>HJ_103 AND 收盘价>HJ_105
HJ_107赋值:收盘价/1日前的收盘价>1.05 AND 1日前的收盘价/2日前的收盘价<1.05 AND 收盘价/10日内收盘价的最低值<1.4
HJ_108赋值:成交量(手)/1日前的成交量(手)>2 OR 成交量(手)=15日内成交量(手)的最高值
HJ_109赋值:当前流通股本(手)<10000000
HJ_110赋值:(收盘价的5日简单移动平均/1日前的收盘价的5日简单移动平均-1)*100的反正切*57.299999>40
HJ_111赋值:(收盘价的10日简单移动平均/1日前的收盘价的10日简单移动平均-1)*100的反正切*57.299999>30
HJ_112赋值:(收盘价的20日简单移动平均/1日前的收盘价的20日简单移动平均-1)*100的反正切*57.299999>20
HJ_113赋值:(收盘价的30日简单移动平均/1日前的收盘价的30日简单移动平均-1)*100的反正切*57.299999>10
HJ_114赋值:HJ_110 AND HJ_111 AND HJ_112 AND HJ_113
HJ_115赋值:KDJ的K>1日前的KDJ的K*HJ_23
HJ_116赋值:KDJ的D>1日前的KDJ的D AND KDJ的D<70
HJ_117赋值:KDJ的J>1日前的KDJ的J*HJ_23
HJ_118赋值:HJ_115 AND HJ_116 AND HJ_117
HJ_119赋值:HJ_21 AND HJ_107 AND HJ_108 AND HJ_109 AND HJ_114 AND HJ_118
HJ_120赋值:HJ_119的15日过滤*HJ_3
HJ_121赋值:90日内1日前的收盘价的最高值
HJ_122赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
HJ_123赋值:如果收阳线,返回HJ_122*(最高价-最低价),否则返回如果收阴线,返回HJ_122*(最高价-开盘价+(收盘价-最低价)),否则返回成交量(手)/2*HJ_23
HJ_124赋值:如果收阳线,返回0-HJ_122*(最高价-收盘价+(开盘价-最低价)),否则返回如果收阴线,返回0-HJ_122*(最高价-最低价),否则返回0-成交量(手)/2*HJ_23
HJ_125赋值:HJ_123/(-HJ_124)
HJ_126赋值:收盘价/1日前的收盘价*100-100
HJ_127赋值:统计10日中满足HJ_126>7的天数*HJ_3>=1
HJ_128赋值:1日前的收盘价<收盘价的5日简单移动平均 AND 收盘价>收盘价的5日简单移动平均*HJ_3
HJ_129赋值:统计20日中满足收盘价上穿HJ_121的天数>=1
HJ_130赋值:最低价>(1日前的最高价+0.09)*HJ_23
HJ_131赋值:(收盘价的12日指数移动平均-收盘价的25日指数移动平均)*HJ_23
HJ_132赋值:HJ_131的3日指数移动平均
HJ_133赋值:(HJ_131-HJ_132)*500000
HJ_134赋值:HJ_133-1日前的HJ_133的3日简单移动平均
HJ_135赋值:HJ_134>1日前的HJ_134*HJ_3
HJ_136赋值:HJ_129 AND HJ_128 AND HJ_125>3 AND HJ_127 AND HJ_135
HJ_137赋值:(收盘价-2日前的收盘价)/收盘价>0.1
HJ_138赋值:(-2)日前的HJ_137*HJ_23
HJ_139赋值:收盘价/1日前的收盘价>1.048 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的5日线性回归预测值之间*HJ_3
HJ_140赋值:HJ_139的28日过滤*HJ_3
HJ_141赋值:收盘价的5日简单移动平均
HJ_142赋值:收盘价的11日简单移动平均
HJ_143赋值:收盘价的21日简单移动平均
HJ_144赋值:收盘价的33日简单移动平均
HJ_145赋值:收盘价的89日简单移动平均
HJ_146赋值:收盘价的120日简单移动平均*HJ_23
HJ_147赋值:HJ_141>HJ_142 AND HJ_142>HJ_143 AND HJ_143>HJ_144 AND HJ_144>HJ_145 AND HJ_145>HJ_146
HJ_148赋值:收盘价的5日简单移动平均*HJ_3
HJ_149赋值:(HJ_148/1日前的HJ_148-1)*100的反正切*57.299999>60
HJ_150赋值:收盘价>收盘价的5日简单移动平均*HJ_3
HJ_151赋值:HJ_149 AND HJ_150 AND HJ_147
输出龙一:(HJ_12+HJ_25+HJ_36+HJ_48+HJ_87+HJ_99+HJ_120+HJ_136+HJ_140+HJ_151>=7 OR HJ_97) AND 收盘价>收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>1日前的收盘价的20日简单移动平均 

演示图片

强势狙击买进选股公式