首页 > 选股公式 > 更上层楼选股公式

更上层楼选股公式

日期:2022-09-12 09:06:12

选股公式源码

N:=65;

N1:=10;

N2:=110;

AA := VOL / (((HIGH - LOW) * 2) - (Abs(CLOSE - OPEN)));

ZM := IF(CLOSE > OPEN,AA * (HIGH - LOW),IF(CLOSE < OPEN,AA * ((HIGH - OPEN) + (CLOSE - LOW)),VOL / 2));

AAA := VOL / (((HIGH - LOW) * 2) - (ABS(CLOSE - OPEN)));

ZMQD := (ZM / VOL) * 100;

XVOL := IF((CURRBARSCOUNT = 1) AND (PERIOD = 5),(VOL * 240) / FROMOPEN,VOL);

SHS := (VOL / CAPITAL) * 100;

XHS := IF((CURRBARSCOUNT = 1) AND (PERIOD = 5),(((VOL / CAPITAL) * 100) * 240) / FROMOPEN,(VOL / CAPITAL) * 100);

HS := (((XHS > 5) OR (SHS > 2)) AND ((SUM((VOL / CAPITAL) * 100,10)) > 15)) AND ((SUM((VOL / CAPITAL) * 100,10)) < 100);

GL := ((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100;

DIF := (EMA(CLOSE,12) - EMA(CLOSE,26)) * 20;

DEA := EMA(DIF,9);

MACD := (DIF - DEA) * 2;

(((((((((((((EXIst(CROSS(DEA,DIF),7) AND CROSS(DIF,DEA)) AND HS) AND (ZMQD > N)) AND (GL < N1)) AND (CCI.CCI >= N2))

AND (REF(VOL,1) > REF(VOL,2))) AND (macd >= 0)) AND (MACD > REF(MACD,1))) AND (REF(MACD,1) > REF(MACD,2)))

AND (VOL > (REF(VOL,1) * 0.125))) AND ((OPEN / REF(MA(C,5),1)) < 1.065)) AND (REF(EXIST((C / REF(C,1)) > 1.052,30),1))) AND ((DYNAINFO(17) > 2) OR ((XVOL > (REF(VOL,1) * 2)) OR (DYNAINFO(51) < 0.8)))) AND ((VOL < (REF(VOL,1) * 3.5)) OR (VOL < HHV(VOL,30)));

选股公式翻译

N赋值:65
N1赋值:10
N2赋值:110
赋值: 成交量(手) / (((最高价 - 最低价) * 2) - (收盘价-开盘价的绝对值))
赋值: 如果收阳线,返回AA*(最高价-最低价),否则返回如果收阴线,返回AA*((最高价-开盘价)+(收盘价-最低价)),否则返回成交量(手)/2
赋值: 成交量(手) / (((最高价 - 最低价) * 2) - (收盘价-开盘价的绝对值))
赋值: (ZM / 成交量(手)) * 100
赋值: 如果(到最后交易的周期=1)AND(周期类型=5),返回(成交量(手)*240)/当前离开盘分钟数,否则返回成交量(手)
赋值: (成交量(手) / 当前流通股本(手)) * 100
赋值: 如果(到最后交易的周期=1)AND(周期类型=5),返回(((成交量(手)/当前流通股本(手))*100)*240)/当前离开盘分钟数,否则返回(成交量(手)/当前流通股本(手))*100
赋值: (((XHS> 5) OR (SHS> 2)) AND (((成交量(手)/当前流通股本(手))*100的10日累和)> 15)) AND (((成交量(手)/当前流通股本(手))*100的10日累和) < 100)
赋值: ((收盘价 - 收盘价的12日简单移动平均) / 收盘价的12日简单移动平均) * 100
赋值: (收盘价的12日指数移动平均 - 收盘价的26日指数移动平均) * 20
赋值: DIF的9日指数移动平均
赋值: (DIF - DEA) * 2
(((((((((((((最近7日存在DEA上穿DIF AND DIF上穿DEA) AND HS) AND (ZMQD> N)) AND (GL < N1)) AND (CCI的CCI>= N2))AND (1日前的成交量(手)> 2日前的成交量(手))) AND (平滑异同平均线>= 0)) AND (平滑异同平均线> 1日前的平滑异同平均线)) AND (1日前的平滑异同平均线> 2日前的平滑异同平均线))AND (成交量(手)> (1日前的成交量(手) * 0.125))) AND ((开盘价 / 1日前的收盘价的5日简单移动平均) < 1.065)) AND (1日前的最近30日存在(收盘价/1日前的收盘价)>1.052)) AND ((量比> 2) OR ((XVOL> (1日前的成交量(手) * 2)) OR (内外比 < 0.8)))) AND ((成交量(手) < (1日前的成交量(手) * 3.5)) OR (成交量(手) < 30日内成交量(手)的最高值))

演示图片

更上层楼选股公式