首页 > 选股公式 > 牛红柿子选股公式

牛红柿子选股公式

日期:2022-07-24 09:08:16

选股公式源码

A5:=(MA(CLOSE,4)+MA(CLOSE,5))/2;

A9:=MA(CLOSE,9);

A36:=MA(CLOSE,36);

A153:=MA(CLOSE,153);

ZQ:=PERIOD;

MX:=IF(ZQ=10,A5,IF(ZQ=7,A9,IF(ZQ=6,A36,A153)));

FJTJ:=(ZQ>4)AND (ZQ!=8)AND (ZQ!=9)AND (ZQ!=11);

牛红柿子:CROSS(CLOSE,MX)*FJTJ;

选股公式翻译

A5赋值:(收盘价的4日简单移动平均+收盘价的5日简单移动平均)/2
A9赋值:收盘价的9日简单移动平均
A36赋值:收盘价的36日简单移动平均
A153赋值:收盘价的153日简单移动平均
ZQ赋值:周期类型
MX赋值:如果ZQ=10,返回A5,否则返回如果ZQ=7,返回A9,否则返回如果ZQ=6,返回A36,否则返回A153
FJTJ赋值:(ZQ>4)AND (ZQ不等于8)AND (ZQ不等于9)AND (ZQ不等于11)
输出牛红柿子:收盘价上穿MX*FJTJ

演示图片

牛红柿子选股公式