首页 > 选股公式 > 大笔进货选股公式

大笔进货选股公式

日期:2022-07-24 09:08:14

选股公式源码

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-Abs(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

XG:VAR1C AND COUNT(VAR1C,30)=1;

选股公式翻译

VARE赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
VARF赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR10赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR11赋值:VARF<1日前的VAR10 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
VAR12赋值:(最高价+最低价+收盘价)/3
VAR13赋值:(VAR12-VAR12的14日简单移动平均)/(0.015*VAR12的14日平均绝对偏差)
VAR14赋值:(VAR12-VAR12的70日简单移动平均)/(0.015*VAR12的70日平均绝对偏差)
VAR15赋值:如果VAR13>=150ANDVAR13<200ANDVAR14>=150ANDVAR14<200,返回10,否则返回0
VAR16赋值:如果VAR13<=-150ANDVAR13>-200ANDVAR14<=-150ANDVAR14>-200,返回-10,否则返回VAR15
VAR17赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100
VAR18赋值:100-VAR17的绝对值
VAR19赋值:如果VAR18<90,返回VAR18,否则返回100
VAR1A赋值:如果VARE>0,返回VARE,否则返回0
VAR1B赋值:如果VAR14>=200ANDVAR13>=150,返回15,否则返回如果VAR14<=-200ANDVAR13<=-150,返回-15,否则返回VAR16+60
VAR1C赋值:VAR1A>48 AND VAR1B>60 AND VAR19<100
输出XG:VAR1C AND 统计30日中满足VAR1C的天数=1

演示图片

大笔进货选股公式