首页 > 选股公式 > 主升浪加强版选股公式

主升浪加强版选股公式

日期:2022-07-24 09:08:13

选股公式源码

X_1:=DYNAINFO(4)>1 AND NOT(NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3)) AND BARSCOUNT(CLOSE)>61;

X_2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

X_3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

X_4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

X_5:=(X_2+2*X_3+3*X_4)/6;

X_6:=MA(X_5,3);

X_7:=LLV(LOW,36);

X_8:=HHV(HIGH,30);

X_9:=EMA((CLOSE-X_7)/(X_8-X_7)*4,4)*25;

X_10:=IF(X_9>90,1,110);

主升浪加强版:X_10=1 AND X_1;

选股公式翻译

X_1赋值:开盘价>1 AND 取反 AND 收盘价的有效数据周期数>61
X_2赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
X_3赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
X_4赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
X_5赋值:(X_2+2*X_3+3*X_4)/6
X_6赋值:X_5的3日简单移动平均
X_7赋值:36日内最低价的最低值
X_8赋值:30日内最高价的最高值
X_9赋值:(收盘价-X_7)/(X_8-X_7)*4的4日指数移动平均*25
X_10赋值:如果X_9>90,返回1,否则返回110
输出主升浪加强版:X_10=1 AND X_1

演示图片

主升浪加强版选股公式