首页 > 选股公式 > 阶段绝底选股公式

阶段绝底选股公式

日期:2022-07-24 09:08:12

选股公式源码

VARR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;

VARR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;

VARR3:=(2*CLOSE+HIGH+LOW)/4;

VARR4:=LLV(LOW,26);

VARR5:=HHV(HIGH,34);

VARR6:=EMA((VARR3-VARR4)/(VARR5-VARR4)*100,16);

VARR7:=SMA((SMA(VARR2,3,1)+3),3,1),LINETHICK3;

VARR8:=EMA(VARR6,7);

VARR9:=SMA(VARR1,3,1);

VARR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VARR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VARR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VARR13:=(VARR10+VARR11+VARR12)/3;

VARR14:=IF(VARR13<=-20,10,0);

VARR15:=HHV(VARR14,10);

VARR24:=LLV(LOW,36);

VARR25:=HHV(HIGH,30);

VARR26:=EMA((CLOSE-VARR24)/(VARR25-VARR24)*4,4)*25;

VARB27:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)/2+22)*1;

VARB28:=(((CLOSE -(((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) / (((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) * 100);

VAR2:=LLV(LOW,10);

VAR33:=HHV(HIGH,25);

动力线:= EMA((CLOSE-VAR2)/(VAR33-VAR2)*4,4);

底部:=0.2;

阶段底部:=CROSS(动力线,底部);

MAA5:=MA(C,5);

MAA10:=MA(C,10);

MAA30:=MA(C,30),;

KS:=IF(MAA10>MAA30,MAA10,MAA30);

A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

A4:=SMA(A3,3,1);

A5:=SMA(A4,3,1);

A6:=3*A4-2*A5;

A7:=C-REF(C,1);

A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(Abs(A7),6),6);

买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

替换:=FILTER(买=1,5);

绝底:((VARB28 < (0)) AND 替换) AND ((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)<VARB27-2 AND VARR26<10 AND 阶段底部,LINETHICK2;

选股公式翻译

VARR1赋值:(24日内最高价的最高值-收盘价)/(24日内最高价的最高值-24日内最低价的最低值)*100
VARR2赋值:(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100
VARR3赋值:(2*收盘价+最高价+最低价)/4
VARR4赋值:26日内最低价的最低值
VARR5赋值:34日内最高价的最高值
VARR6赋值:(VARR3-VARR4)/(VARR5-VARR4)*100的16日指数移动平均
VARR7赋值:(VARR2的3日[1日权重]移动平均+3)的3日[1日权重]移动平均,线宽为3
VARR8赋值:VARR6的7日指数移动平均
VARR9赋值:VARR1的3日[1日权重]移动平均
VARR10赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
VARR11赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
VARR12赋值:(收盘价-收盘价的32日简单移动平均)/收盘价的32日简单移动平均*100
VARR13赋值:(VARR10+VARR11+VARR12)/3
VARR14赋值:如果VARR13<=-20,返回10,否则返回0
VARR15赋值:10日内VARR14的最高值
VARR24赋值:36日内最低价的最低值
VARR25赋值:30日内最高价的最高值
VARR26赋值:(收盘价-VARR24)/(VARR25-VARR24)*4的4日指数移动平均*25
VARB27赋值:(((收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100)/2+22)*1
VARB28赋值:(((收盘价 -(((成交额(元)的13日指数移动平均 /成交量(手)的13日指数移动平均) / 100))) / (((成交额(元)的13日指数移动平均 /成交量(手)的13日指数移动平均) / 100))) * 100)
VAR2赋值:10日内最低价的最低值
VAR33赋值:25日内最高价的最高值
动力线赋值: (收盘价-VAR2)/(VAR33-VAR2)*4的4日指数移动平均
底部赋值:0.2
阶段底部赋值:动力线上穿底部
MAA5赋值:收盘价的5日简单移动平均
MAA10赋值:收盘价的10日简单移动平均
MAA30赋值:收盘价的30日简单移动平均,
KS赋值:如果MAA10>MAA30,返回MAA10,否则返回MAA30
A3赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
A4赋值:A3的3日[1日权重]移动平均
A5赋值:A4的3日[1日权重]移动平均
A6赋值:3*A4-2*A5
A7赋值:收盘价-1日前的收盘价
A8赋值:100*A7的6日指数移动平均的6日指数移动平均/A7的绝对值的6日指数移动平均的6日指数移动平均
买赋值:2日内A8的最低值=7日内A8的最低值 AND 统计2日中满足A8<0的天数 AND A8上穿A8的2日简单移动平均
替换赋值:买=1的5日过滤
输出绝底:((VARB28 < (0)) AND 替换) AND ((收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100)

演示图片

阶段绝底选股公式