首页 > 选股公式 > 金牛王选股公式

金牛王选股公式

日期:2022-07-20 09:25:30

选股公式源码

M11:=5;M22:=10;M33:=20;M44:=60;P:=VOL;VOLUME:=VOL;

LB:=VOL/REF(MA(VOL,5),1);LJC:=MA(P,M11)>MA(P,M44)*0.9;

M1:=4;M2:=6;M3:=9;M4:=13;M5:=18;M6:=24;MA5:=MA(C,60);

PB1:=(EXPMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;

PB2:=(EXPMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;

PB3:=(EXPMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;

PB4:=(EXPMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;

PB5:=(EXPMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3,LINETHICK2;

PB6:=(EXPMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;

AAA:=MIN(MIN(MIN(MIN(MIN(PB1,PB2),PB3),PB4),PB5),PB6);

BBB:=MAX(MAX(MAX(MAX(MAX(PB1,PB2),PB3),PB4),PB5),PB6);

XG:=(O<AAA OR REF(O<AAA,1)) AND C>BBB;

P6:=Abs(PB1-PB2)+ABS(PB1-PB3)+ABS(PB1-PB4)

+ABS(PB1-PB5)+ABS(PB1-PB6)+ABS(PB2-PB3)+ABS(PB2-PB4)

+ABS(PB2-PB5)+ABS(PB2-PB6)+ABS(PB3-PB4)

+ABS(PB3-PB5)+ABS(PB3-PB6)+ABS(PB4-PB5)+ABS(PB4-PB6)+ABS(PB5-PB6);

LXZH:=P6/C<20/100,COLORRED;

SS:=XG AND LB>2.2 AND C>MA5*1.02 AND C<MA5*1.15

AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>3/100 AND C>O*1.02,COLORRED;

JL:=C>MA5 AND LJC AND (LB>2.2 OR REF(LB>2.2,1))

AND (XG OR REF(XG,1)) AND C>MA5*1.02 AND C<MA5*1.15 AND C>O*1.02

AND (LXZH OR REF(LXZH,1))

AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>3/100,COLORRED;

PD:=(JL OR REF(JL,1)),COLORRED;

金牛王:FILTER(PD=1,PB1*0.88);

选股公式翻译

M11赋值:5
M22赋值:10
M33赋值:20
M44赋值:60
P赋值:成交量(手)
VOLUME赋值:成交量(手)
LB赋值:成交量(手)/1日前的成交量(手)的5日简单移动平均
LJC赋值:P的M11日简单移动平均>P的M44日简单移动平均*0.9
M1赋值:4
M2赋值:6
M3赋值:9
M4赋值:13
M5赋值:18
M6赋值:24
MA5赋值:收盘价的60日简单移动平均
PB1赋值:(收盘价的M1日指数移动平均+收盘价的M1*2日简单移动平均+收盘价的M1*4日简单移动平均)/3
PB2赋值:(收盘价的M2日指数移动平均+收盘价的M2*2日简单移动平均+收盘价的M2*4日简单移动平均)/3
PB3赋值:(收盘价的M3日指数移动平均+收盘价的M3*2日简单移动平均+收盘价的M3*4日简单移动平均)/3
PB4赋值:(收盘价的M4日指数移动平均+收盘价的M4*2日简单移动平均+收盘价的M4*4日简单移动平均)/3
PB5赋值:(收盘价的M5日指数移动平均+收盘价的M5*2日简单移动平均+收盘价的M5*4日简单移动平均)/3,线宽为2
PB6赋值:(收盘价的M6日指数移动平均+收盘价的M6*2日简单移动平均+收盘价的M6*4日简单移动平均)/3
AAA赋值:PB1和PB2的较小值和PB3的较小值和PB4的较小值和PB5的较小值和PB6的较小值
BBB赋值:PB1和PB2的较大值和PB3的较大值和PB4的较大值和PB5的较大值和PB6的较大值
XG赋值:(开盘价BBB
P6赋值:PB1-PB2的绝对值+PB1-PB3的绝对值+PB1-PB4的绝对值+PB1-PB5的绝对值+PB1-PB6的绝对值+PB2-PB3的绝对值+PB2-PB4的绝对值+PB2-PB5的绝对值+PB2-PB6的绝对值+PB3-PB4的绝对值+PB3-PB5的绝对值+PB3-PB6的绝对值+PB4-PB5的绝对值+PB4-PB6的绝对值+PB5-PB6的绝对值
LXZH赋值:P6/收盘价<20/100,画红色
SS赋值:XG AND LB>2.2 AND 收盘价>MA5*1.02 AND 收盘价3/100 AND 收盘价>开盘价*1.02,画红色
JL赋值:收盘价>MA5 AND LJC AND (LB>2.2 OR 1日前的LB>2.2)AND (XG OR 1日前的XG) AND 收盘价>MA5*1.02 AND 收盘价开盘价*1.02AND (LXZH OR 1日前的LXZH)AND (收盘价-1日前的收盘价)/1日前的收盘价>3/100,画红色
PD赋值:(JL OR 1日前的JL),画红色
输出金牛王:PD=1的PB1*0.88日过滤

演示图片

金牛王选股公式