首页 > 选股公式 > 金叉套利选股公式

金叉套利选股公式

日期:2022-06-20 09:43:28

选股公式源码

MA5:=EMA(C,5);

MA10:=EMA(C,10);

MV5:=EMA(V,5);

MV10:=EMA(V,10);

K:="KDJ.K"(9,9,9);

D:="KDJ.D"(9,9,9);

CG:=MA(CLOSE,19);

CD:=MA(CLOSE,2);

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD1:=DIF>REF(DIF,1) AND DEA>=REF(DEA,1) AND DIF>DEA;

V1:=MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND C>REF(C,1) AND C/O>1.01;

VV1:=MV5>REF(MV5,1) AND MV10>=REF(MV10,1) AND V>REF(V,1)*1.2 ;

KD1:=K>REF(K,1) AND D>=REF(D,1);

VA:=COUNT(CROSS(K,D),1)>=1 AND COUNT(CROSS(MA5,MA10),1)>=1 AND

COUNT(CROSS(MV5,MV10),1)>=1 AND COUNT(CROSS(DIF,DEA),1)>=1;

XG2:(IF(V1 AND VV1 AND KD1 AND macd1 AND VA,1,0)) AND (CROSS(CD,CG));

选股公式翻译

MA5赋值:收盘价的5日指数移动平均
MA10赋值:收盘价的10日指数移动平均
MV5赋值:成交量(手)的5日指数移动平均
MV10赋值:成交量(手)的10日指数移动平均
K赋值:"KDJ的K"(9,9,9)
D赋值:"KDJ的D"(9,9,9)
CG赋值:收盘价的19日简单移动平均
CD赋值:收盘价的2日简单移动平均
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD1赋值:DIF>1日前的DIF AND DEA>=1日前的DEA AND DIF>DEA
V1赋值:MA5>1日前的MA5 AND MA10>1日前的MA10 AND 收盘价>1日前的收盘价 AND 收盘价/开盘价>1.01
VV1赋值:MV5>1日前的MV5 AND MV10>=1日前的MV10 AND 成交量(手)>1日前的成交量(手)*1.2
KD1赋值:K>1日前的K AND D>=1日前的D
VA赋值:统计1日中满足K上穿D的天数>=1 AND 统计1日中满足MA5上穿MA10的天数>=1 ANDCOUNT(MV5上穿MV10,1)>=1 AND 统计1日中满足DIF上穿DEA的天数>=1
输出XG2:(如果V1ANDVV1ANDKD1ANDMACD1ANDVA,返回1,否则返回0) AND (CD上穿CG)

演示图片

金叉套利选股公式