首页 > 选股公式 > 五鬼擒妖选股公式

五鬼擒妖选股公式

日期:2022-05-03 10:05:12

选股公式源码

X_1:=MA(CLOSE,5);

X_2:=IF(X_1>REF(X_1,1),X_1,DRAWNULL);

X_3:=IF(CLOSE>REF(CLOSE,1),88,0);

X_4:=IF(CLOSE/REF(CLOSE,1)>1.095 AND HIGH/CLOSE<1.035 AND X_3>0,91,0);

X_5:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAst(VOL,5),0.3*FORCAST(VOL,12),2.1*FORCAST(VOL,12));

X_6:=FILTER(X_4>90,30)=1;

X_7:=FILTER(X_5,60);

X_8:=X_2 AND X_7 AND X_6;

X_9:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));

X_10:=X_9 AND COUNT(X_9,9)=1;

X_11:=(CLOSE-EMA(CLOSE,5))/EMA(CLOSE,5)*100;

X_12:=EMA(EMA(EMA(CLOSE,50),50),50)*1.1;

X_13:=EMA(EMA(EMA(CLOSE,10),10),10)*1.09;

X_14:=CROSS(X_11,5) AND CROSS(CLOSE,X_12) AND CROSS(CLOSE,X_13);

X_15:=IF(CLOSE>REF(CLOSE,1),88,0);

X_16:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_15>0,91,0);

X_17:=FILTER(X_16>90,45);

X_18:=FILTER(X_16>90,35);

X_19:=MA(CLOSE,10);

X_20:=MA(CLOSE,54);

X_21:=(CLOSE-X_20)/X_20<0.1;

X_22:=(CLOSE-X_19)/X_19<0.3;

X_23:=(X_21=1 AND X_22=1)*0.2;

X_24:=(X_23=0 AND REF(X_23,1)=0.2 AND REF(COUNT(X_23=0.2,10)=10,1)=1)*(-0.1);

X_25:=X_24=(-0.1);

XG:X_14 AND X_25 AND X_18 AND X_8 AND X_10;

选股公式翻译

X_1赋值:收盘价的5日简单移动平均
X_2赋值:如果X_1>1日前的X_1,返回X_1,否则返回无效数
X_3赋值:如果收盘价>1日前的收盘价,返回88,否则返回0
X_4赋值:如果收盘价/1日前的收盘价>1.095ANDHIGH/收盘价<1.035ANDX_3>0,返回91,否则返回0
X_5赋值:收盘价/1日前的收盘价>1.048 AND 收盘价=最高价 AND 成交量(手)的5日线性回归预测值位于0.3*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
X_6赋值:X_4>90的30日过滤=1
X_7赋值:X_5的60日过滤
X_8赋值:X_2 AND X_7 AND X_6
X_9赋值:收盘价/1日前的收盘价>1.048 AND 收盘价=最高价 AND 成交量(手)的4日线性回归预测值位于0.2*成交量(手)的12日线性回归预测值和2.1*成交量(手)的12日线性回归预测值之间
X_10赋值:X_9 AND 统计9日中满足X_9的天数=1
X_11赋值:(收盘价-收盘价的5日指数移动平均)/收盘价的5日指数移动平均*100
X_12赋值:收盘价的50日指数移动平均的50日指数移动平均的50日指数移动平均*1.1
X_13赋值:收盘价的10日指数移动平均的10日指数移动平均的10日指数移动平均*1.09
X_14赋值:X_11上穿5 AND 收盘价上穿X_12 AND 收盘价上穿X_13
X_15赋值:如果收盘价>1日前的收盘价,返回88,否则返回0
X_16赋值:如果收盘价/1日前的收盘价>1.05ANDHIGH/收盘价<1.01ANDX_15>0,返回91,否则返回0
X_17赋值:X_16>90的45日过滤
X_18赋值:X_16>90的35日过滤
X_19赋值:收盘价的10日简单移动平均
X_20赋值:收盘价的54日简单移动平均
X_21赋值:(收盘价-X_20)/X_20<0.1
X_22赋值:(收盘价-X_19)/X_19<0.3
X_23赋值:(X_21=1 AND X_22=1)*0.2
X_24赋值:(X_23=0 AND 1日前的X_23=0.2 AND 1日前的统计10日中满足X_23=0.2的天数=10=1)*(-0.1)
X_25赋值:X_24=(-0.1)
输出XG:X_14 AND X_25 AND X_18 AND X_8 AND X_10

演示图片

五鬼擒妖选股公式