首页 > 选股公式 > 战斗机选股公式

战斗机选股公式

日期:2022-05-03 10:05:11

选股公式源码

B:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.1416;

B1:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.1416;

B2:=ATAN((MA(C,20)/REF(MA(C,20),1)-1)*100)*180/3.1416;

AA:=IF(B>45 AND B1>55 AND B2>30 ,1,0);

B3:=100*(C-LLV(L,34))/(HHV(C,34)-LLV(L,34));

B4:=(AMOUNT/C)/(HHV(AMOUNT,34)/HHV(C,34));

B5:=IF(B4>1,1,B4)*100;

B6:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

B7:=EMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,25)-LLV(LOW,10))*4,4)*30;

B8:=B5>=90 AND B3>80 AND MA(B6,12)<90;

B9:=BArslAst(CROSS(B7,MA(B6,12)))<40;

B10:=C/REF(C,1)>1+0.01*2;

AA1:=B8 AND B9 AND (C>O OR C/REF(C,1)>1.05) AND B10;

BB1:=C/REF(C,1)>1+0.01*9;

BB2:=EXIST(C/REF(C,1)>1+0.01*9,10);

BB3:=C/REF(C,1)>1+0.01*9;

AA2:=IF(BB1+BB2+BB3=3,1,0);

BB4:=EMA(C,50)>EMA(C,240);

BB5:=BARSLAST(CROSS(EMA(C,240),EMA(C,50)));

BB6:=IF(BB4>0,BB5,50);

BB7:=C/LLV(C,BB6)*100-100;

AA3:=HHV(BB7,283);

AA4:=(AA>0 OR AA1>0 OR AA2>0) AND COUNT(AA>0,2)>=1 AND COUNT(AA1>0,3)>=1 AND COUNT(AA2>0,5)>=1 ;

选股:IF(AA4>0 AND COUNT(AA4>0,10)=1 AND AA3<100 >=1 AND (H-C)/C*100<1 AND REF(C<O,1) ,5,0);

选股公式翻译

B赋值:(收盘价的5日简单移动平均/1日前的收盘价的5日简单移动平均-1)*100的反正切*180/3.1416
B1赋值:(收盘价的10日简单移动平均/1日前的收盘价的10日简单移动平均-1)*100的反正切*180/3.1416
B2赋值:(收盘价的20日简单移动平均/1日前的收盘价的20日简单移动平均-1)*100的反正切*180/3.1416
AA赋值:如果B>45ANDB1>55ANDB2>30,返回1,否则返回0
B3赋值:100*(收盘价-34日内最低价的最低值)/(34日内收盘价的最高值-34日内最低价的最低值)
B4赋值:(成交额(元)/收盘价)/(34日内成交额(元)的最高值/34日内收盘价的最高值)
B5赋值:如果B4>1,返回1,否则返回B4*100
B6赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
B7赋值:(收盘价-10日内最低价的最低值)/(25日内最高价的最高值-10日内最低价的最低值)*4的4日指数移动平均*30
B8赋值:B5>=90 AND B3>80 AND B6的12日简单移动平均<90
B9赋值:上次B7上穿B6的12日简单移动平均距今天数<40
B10赋值:收盘价/1日前的收盘价>1+0.01*2
AA1赋值:B8 AND B9 AND (收阳线OR 收盘价/1日前的收盘价>1.05) AND B10
BB1赋值:收盘价/1日前的收盘价>1+0.01*9
BB2赋值:最近10日存在收盘价/1日前的收盘价>1+0.01*9
BB3赋值:收盘价/1日前的收盘价>1+0.01*9
AA2赋值:如果BB1+BB2+BB3=3,返回1,否则返回0
BB4赋值:收盘价的50日指数移动平均>收盘价的240日指数移动平均
BB5赋值:上次收盘价的240日指数移动平均上穿收盘价的50日指数移动平均距今天数
BB6赋值:如果BB4>0,返回BB5,否则返回50
BB7赋值:收盘价/BB6日内收盘价的最低值*100-100
AA3赋值:283日内BB7的最高值
AA4赋值:(AA>0 OR AA1>0 OR AA2>0) AND 统计2日中满足AA>0的天数>=1 AND 统计3日中满足AA1>0的天数>=1 AND 统计5日中满足AA2>0的天数>=1
输出选股:如果AA4>0ANDCOUNT(AA4>0,10)=1ANDAA3<100>=1AND(最高价-收盘价)/收盘价*100<1ANDREF(收阴线,1),返回5,否则返回0

演示图片

战斗机选股公式