首页 > 选股公式 > 底现选股公式

底现选股公式

日期:2022-05-03 10:05:03

选股公式源码

MA55:=MA(C,55);

EXPA:=EXPMA(C,6)COLORRED,LINETHICK2;

M5:=MA(CLOSE,5)COLORWHITE;

M5138线:=MA(C,5)-MA(C,13)+MA(C,8),COLORCYAN,LINETHICK1;

M52:=MA(M5138线,2),COLORYELLOW,LINETHICK1;

M53:=(M5138线*1.045),COLORYELLOW,LINETHICK1;

M54:=(M5138线*1.090),COLORYELLOW,LINETHICK1;

M55:=(M5138线*1.135),COLORYELLOW,LINETHICK1;

DIF0:=CROSS(C,M5138线),COLORYELLOW,LINETHICK1;

DI:=CROSS(M5138线,M52);

先行:=LLV(MA(HIGH,(3)),1),LINETHICK2,COLORRED;

先行2:=LLV(MA(HIGH,(3)),2),LINETHICK2,COLORWHITE;

M38线:=MA(C,5)-MA(C,13)+MA(C,8),COLORCYAN,LINETHICK1;

M522:=MA(M38线,2),COLORYELLOW,LINETHICK1;

M3852:=CROSS(M38线,M522);

C先行:=CROSS(C,先行);

DDTD:=DMA(C,Abs(C-MA(C,14))/MA(C,14));

上布:=EMA(DDTD,30)*1.2,COLORGREEN;

上布2:=MA(上布,3)COLORWHITE;

上布涨:=IF(上布>REF(上布,1),1,0),COLORWHITE;

中上轨:=EMA(2.055*EMA(EMA(H,34),34)-EMA(EMA(L,34),34),5),COLORCYAN,LINETHICK2;

下布:=EMA(DDTD,30)*0.91,COLORMAGENTA;

中下轨:=EMA(2*EMA(EMA(L,21),21)-EMA(EMA(H,21),21),5),COLORYELLOW,LINETHICK2;

C轨:=IF(C>中下轨,0,1)COLORWHITE;

角度上布:=ATAN((上布/REF(上布,1)-1)*100)*180/3.141592654,COLORWHITE;

角度MA5:=ATAN((M5/REF(M5,1)-1)*100)*180/3.141592654,COLORWHITE;

中下轨2:=IF(中下轨>REF(中下轨,1),1,0),COLORWHITE;

下下轨:=EMA((3*C+H+O+L)/6,30)*0.89,COLORMAGENTA;

TJ5:=REF("CCI.CCI",1)<-100 AND "CCI.CCI">REF("CCI.CCI",1);

TJ6:=REF("KDJ.J"(9,3,3),1)<20 AND "KDJ.J"(9,3,3)>REF( "KDJ.J"(9,3,3),1);

TJ7:=REF("RSI.RSI1",1)<20 AND "RSI.RSI1">REF("RSI.RSI1",1);

TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);

TJ9:=3075.2525*400;

大底:=CROSS(TJ8,0.5);

建仓:=1;

神密底:=IF(下布>M38线 AND 中下轨>下布 AND 建仓 AND 大底,30.2,0),COLORCYAN,LINETHICK6;

底现:CROSS(神密底,1);

选股公式翻译

MA55赋值:收盘价的55日简单移动平均
EXPA赋值:收盘价的6日指数移动平均画红色,线宽为2
M5赋值:收盘价的5日简单移动平均画白色
M5138线赋值:收盘价的5日简单移动平均-收盘价的13日简单移动平均+收盘价的8日简单移动平均,画青色,线宽为1
M52赋值:M5138线的2日简单移动平均,画黄色,线宽为1
M53赋值:(M5138线*1.045),画黄色,线宽为1
M54赋值:(M5138线*1.090),画黄色,线宽为1
M55赋值:(M5138线*1.135),画黄色,线宽为1
DIF0赋值:收盘价上穿M5138线,画黄色,线宽为1
DI赋值:M5138线上穿M52
先行赋值:1日内最高价的(3)日简单移动平均的最低值,线宽为2,画红色
先行2赋值:2日内最高价的(3)日简单移动平均的最低值,线宽为2,画白色
M38线赋值:收盘价的5日简单移动平均-收盘价的13日简单移动平均+收盘价的8日简单移动平均,画青色,线宽为1
M522赋值:M38线的2日简单移动平均,画黄色,线宽为1
M3852赋值:M38线上穿M522
C先行赋值:收盘价上穿先行
DDTD赋值:以收盘价-收盘价的14日简单移动平均的绝对值/收盘价的14日简单移动平均为权重收盘价的动态移动平均
上布赋值:DDTD的30日指数移动平均*1.2,画绿色
上布2赋值:上布的3日简单移动平均画白色
上布涨赋值:如果上布>1日前的上布,返回1,否则返回0,画白色
中上轨赋值:2.055*最高价的34日指数移动平均的34日指数移动平均-最低价的34日指数移动平均的34日指数移动平均的5日指数移动平均,画青色,线宽为2
下布赋值:DDTD的30日指数移动平均*0.91,画洋红色
中下轨赋值:2*最低价的21日指数移动平均的21日指数移动平均-最高价的21日指数移动平均的21日指数移动平均的5日指数移动平均,画黄色,线宽为2
C轨赋值:如果收盘价>中下轨,返回0,否则返回1画白色
角度上布赋值:(上布/1日前的上布-1)*100的反正切*180/3.141592654,画白色
角度MA5赋值:(M5/1日前的M5-1)*100的反正切*180/3.141592654,画白色
中下轨2赋值:如果中下轨>1日前的中下轨,返回1,否则返回0,画白色
下下轨赋值:(3*收盘价+最高价+开盘价+最低价)/6的30日指数移动平均*0.89,画洋红色
TJ5赋值:1日前的"CCI的CCI"<-100 AND "CCI的CCI">1日前的"CCI的CCI"
TJ6赋值:1日前的"KDJ的J"(9,3,3)<20 AND "KDJ的J"(9,3,3)>1日前的"KDJ的J"(9,3,3)
TJ7赋值:1日前的"RSI的RSI1"<20 AND "RSI的RSI1">1日前的"RSI的RSI1"
TJ8赋值:统计5日中满足TJ5的天数 AND 统计5日中满足TJ6的天数 AND 统计5日中满足TJ7的天数
TJ9赋值:3075.2525*400
大底赋值:TJ8上穿0.5
建仓赋值:1
神密底赋值:如果下布>M38线AND中下轨>下布AND建仓AND大底,返回30.2,否则返回0,画青色,线宽为6
输出底现:神密底上穿1

演示图片

底现选股公式