首页 > 选股公式 > 板后回调选股公式

板后回调选股公式

日期:2022-05-03 10:05:01

选股公式源码

AAD:=Abs((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);

GD:=DMA(CLOSE,AAD);

SS:=(1+9/100)*GD;

XX:=(1-9/100)*GD;

ZTD:=C/REF(C,1)>1.092 AND C/REF(C,1)<1.1035 AND C=H;

A1:=REF(COUNT(ZTD,6)=1,1);

A2:=REF(SUM((C-REF(C,1))/C*100,2)<-5,1) OR REF(SUM((C-REF(C,1))/C*100,5)<-10,1);

VD1:=AMOUNT/VOL/7;

VD2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

VD3:=SUM(AMOUNT,10)/VD1/7;

VD4:=DMA(VD2,VOL/VD3);

VD5:=(CLOSE-VD4)/VD4*100;

VD6:=CROSS(VD5,-5) OR CROSS(VD5,-10);

VD7:=C/REF(C,20)<1.3 OR REF(C,3)/REF(C,20)<1.3;

A3:=A1 AND A2 AND C>XX AND C<GD AND C/REF(C,1)>1.01 AND VD6 AND VD7;

板后回调:IF(A3,1,0),LINETHICK1,COLORYELLOW;

选股公式翻译

AAD赋值:(2*收盘价+最高价+最低价)/4-收盘价的30日简单移动平均的绝对值/收盘价的30日简单移动平均
GD赋值:以AAD为权重收盘价的动态移动平均
SS赋值:(1+9/100)*GD
XX赋值:(1-9/100)*GD
ZTD赋值:收盘价/1日前的收盘价>1.092 AND 收盘价/1日前的收盘价<1.1035 AND 收盘价=最高价
A1赋值:1日前的统计6日中满足ZTD的天数=1
A2赋值:1日前的(收盘价-1日前的收盘价)/收盘价*100的2日累和<-5 OR 1日前的(收盘价-1日前的收盘价)/收盘价*100的5日累和<-10
VD1赋值:成交额(元)/成交量(手)/7
VD2赋值:(3*最高价+最低价+开盘价+2*收盘价)/7
VD3赋值:成交额(元)的10日累和/VD1/7
VD4赋值:以成交量(手)/VD3为权重VD2的动态移动平均
VD5赋值:(收盘价-VD4)/VD4*100
VD6赋值:VD5上穿-5 OR VD5上穿-10
VD7赋值:收盘价/20日前的收盘价<1.3 OR 3日前的收盘价/20日前的收盘价<1.3
A3赋值:A1 AND A2 AND 收盘价>XX AND 收盘价1.01 AND VD6 AND VD7
输出板后回调:如果A3,返回1,否则返回0,线宽为1,画黄色

演示图片

板后回调选股公式