首页 > 选股公式 > 鼎牛涨停狙击选股公式

鼎牛涨停狙击选股公式

日期:2022-05-03 10:04:49

选股公式源码

RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);

短期底部:=LLV(OPEN,30);

AA10:=MA(CLOSE,10);

AA12:=MA(CLOSE,12);

BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);

BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);

MA13:=MA(CLOSE,13);

VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);

VAR6:=MA(VAR5,3);

VAR7:=DMA(EMA(CLOSE,12),((SUM(VOL,5) / 3) / CAPITAL));

VAR8:=(((CLOSE - VAR7) / VAR7) * 100);

VAR9:=((((REF(VAR8,1) < (0 - 40)) AND (VAR8 > REF(VAR8,1))) AND (REF(VAR8,1) < REF(VAR8,2))) AND ((VAR8 - REF(VAR8,1)) >2.5));

VARA:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VARB:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VARC:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VARD:=REF(CLOSE,1);

VARE:=((SMA(MAX((CLOSE - VARD),0),5,1) / SMA(Abs((CLOSE - VARD)),5,1)) * 100);

VARF:=(((HIGH + LOW) + CLOSE) / 3);

VAR10:=((VARF - MA(VARF,14)) / (0.015 * AVEDEV(VARF,14)));

VAR11:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100))< (0 - 0.273));

VAR12:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));

VAR13:=(VAR11 AND VAR12);

VAR14:=((((VARA >= (0 - 45)) AND (VARA <= (0 - 10))) AND (VARB <= (0 - 15))) AND (VARC <= (0 - 20)));

VAR15:=(COUNT(VAR14,1) >= 1);

VAR16:=(VAR13 AND VAR15);

VAR17:=1;

VAB0:=531;VAB1:=1510000;VAB2:=VAB0 + VAB1; VAB3:=IF(DATE > VAB2,0,1);

VARA12:=SMA(H,10,9)*VAB3; VARA13:=SMA(L,10,9)*VAB3; VAR18:=(CLOSE * VOL);

VAR19:=EMA((((((MA(VAR18,4) / MA(VOL,4)) + (MA(VAR18,6) / MA(VOL,6))) + (MA(VAR18,13) / MA(VOL,13))) + (MA(VAR18,24) / MA(VOL,24))) / 4),1);

VAR1A:=(1 * VAR19);

VAR1B:=(VAR19 * 0.92);

VAR1C:=EMA(CLOSE,34);

VAR1D:=MA((VAR1C * 1.12),5);

VAR1E:=MA((VAR1C * 0.82),5);

VAR1F:=(CLOSE < VAR1E);

VAR20:=((((((MA(AMOUNT,5) * VAR17) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < ((0 - 0.4) * VAR17));

VAR21:=HHV(HIGH,500);

VAR22:=LLV(LOW,500);

VAR23:=HHV(HIGH,250);

VAR24:=LLV(LOW,250);

VAR25:=HHV(HIGH,125);

VAR26:=LLV(LOW,125);

VAR27:=MA(((((((VAR21 * 0.45) + (VAR23 * 0.5)) + VAR22) + VAR24) + VAR26) / 5),35);

VAR28:=MA((((VAR23 * 0.62) + VAR26) / 2),35);

VAR29:=MA((((VAR23 * 0.75) + VAR26) / 2),18);

VAR2A:=MA((((((VAR23 * 0.93) + (VAR27 * 2)) + (VAR28 * 1.8)) + (VAR29 * 1.5)) / 4),18);

VAR2B:=MA(((((VAR21 * 0.95) + (VAR27 * 3)) + (VAR28 * 2)) / 3),35);

VAR2C:=VAR27;

VAR2D:=VAR28;

VAR2E:=VAR29;

VAR2F:=VAR2A;

VAR30:=VAR2B;

VAR31:=((CLOSE - REF(MA(CLOSE,20),11)) < (0 - 2));

VAR32:=(INDEXA / 100000000);

VAR33:=INDEXADV;

VAR34:=INDEXDEC;

VAR35:=((VAR18 / (VAR18 + VAR19)) * VAR17);

VAR36:=((VAR19 / (VAR18 + VAR19)) * VAR17);

VAR37:=EMA(VAR35,10);

VAR38:=EMA(VAR36,10);

VAR39:=EMA(VAR37,10);

VAR3A:=EMA(VAR38,20);

VAR3B:=EMA(VAR37,3);

VAR3C:=EMA(VAR39,6);

VAR3D:=EMA(VAR3A,2);

VAR3E:=(VAR3C - VAR3D);

VAR3F:=(((VAR3C - REF(VAR3C,1)) > 0) AND ((REF(VAR3C,1) - REF(VAR3C,2)) < 0));

VAR40:=IF((CROSS(VAR3B,VAR3C) AND (VAR3C <= 20)),30,0);

VAR41:=VAR40;

VAR42:=(SMA(((AMOUNT / VOL) / 100),13,1) * 1.15);

VAR43:=(SMA(((AMOUNT / VOL) / 100),13,1) * 0.85);

VAR44:=(CLOSE - REF(MA(CLOSE,20),11));

VAR45:=(((((((((((((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43)) OR (((CLOSE < VAR1E) AND VAR31) AND VAR20)) OR ((CLOSE <VAR1E) AND (CLOSE < VAR43))) OR (((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43))) OR (VAR20 AND (CLOSE < VAR2C))) OR ((VAR20AND VAR31) AND (VAR44 < (0 - 1.5)))) OR (VAR20 AND (CLOSE < VAR1E))) OR (VAR20 AND (VAR44 < (0 - 1.5)))) OR (VAR31 AND (CLOSE< VAR43))) OR ((CLOSE < VAR2C) AND (VAR44 < (0 - 1.5)))) OR ((CLOSE < VAR1E) AND VAR31));

VAR46:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VAR47:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VAR48:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VAR49:=REF(CLOSE,1);

VAR4A:=((SMA(MAX((CLOSE - VAR49),0),5,1) / SMA(ABS((CLOSE - VAR49)),5,1)) * 100);

VAR4B:=(((HIGH + LOW) + CLOSE) / 3);

VAR4C:=((VAR4B - MA(VAR4B,14)) / (0.015 * AVEDEV(VAR4B,14)));

VAR4D:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100))< (0 - 0.273));

VAR4E:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));

VAR4F:=(VAR11 AND VAR12);

VAR50:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)));

VAR51:=(COUNT(VAR50,1) >= 1);

VAR52:=(VAR4F AND VAR51);

VAR53:=(((((VAR20 AND (CLOSE < VAR1E)) AND VAR31) AND (CLOSE < VAR2C)) AND VAR45) AND VAR52);

VAR54:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VAR55:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VAR56:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VAR57:=REF(CLOSE,1);

VAR58:=((SMA(MAX((CLOSE - VAR57),0),5,1) / SMA(ABS((CLOSE - VAR57)),5,1)) * 100);

VAR59:=(((HIGH + LOW) + CLOSE) / 3);

VAR5A:=((VAR59 - MA(VAR59,14)) / (0.015 * AVEDEV(VAR59,14)));

VAR5B:=((((((VAR54 >= (0 - 15.8)) AND (VAR54 <= (0 - 12.2))) AND (VAR55 <= (0 - 20.8))) AND (VAR56 <= (0 - 27.5))) AND (VAR58<= 11.7)) AND (VAR5A <= (0 - 145)));

VAR5C:=9.999999884842+026;

VAR5D:=(COst(10) * 0)*VAB3;

VAR5E:=((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100));

VAR5F:=MA((((LLV(LOW,45) - CLOSE) / (HHV(HIGH,45) - LLV(LOW,45))) * 100),5);

VAR60:=((CROSS((0 - 5),VAR5F) AND (VAR5E < (0 - 0.4))) AND (((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.19)));

VAR61:=MA(CLOSE,3);

VAR62:=(REF(CLOSE,2) * 0.865);

VAR63:=(REF(CLOSE,13) * 0.772);

VAR64:=MIN(VAR62,VAR63);

VAR65:=((100 * VOL) / CAPITAL);

VAR66:=MA(CLOSE,13);

VAR67:=IF(((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) < 1.8)),1,0);

开始控盘:=STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),5,0)*VAB3,COLORBROWN;

出击:=IF(((((VAR9 OR VAR16) OR VAR53) OR VAR5B) OR ((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) <1.8))),120,0),LINETHICK2,COLOR0000FF;

VAR68:=0;

VARQ:=MA(CLOSE,152);

VARW:=MA(CLOSE,194.16);

VAREE:=(VARW + (2 * STD(CLOSE,170)));

VARR:=(VARQ + (2 * STD(CLOSE,170)));

VART:=IF((DATE > 1080822),0,1);

VAR611:=EMA(HHV(HIGH,500),21);

VAR71:=EMA(HHV(HIGH,250),21);

VAR81:=EMA(HHV(HIGH,90),21);

VAR91:=EMA(LLV(LOW,500),21);

VARA1:=EMA(LLV(LOW,250),21);

VARB1:=EMA(LLV(LOW,90),21);

VARC1:=EMA((((((((VAR91 * 0.96) + (VARA1 * 0.96)) + (VARB1 * 0.96)) + (VAR611 * 0.558)) + (VAR71 * 0.558)) + (VAR81 * 0.558))/ 6),21);

VARD1:=EMA((((((((VAR91 * 1.25) + (VARA1 * 1.23)) + (VARB1 * 1.2)) + (VAR611 * 0.55)) + (VAR71 * 0.55)) + (VAR81 * 0.65)) /6),21);

VARE1:=EMA((((((((VAR91 * 1.3) + (VARA1 * 1.3)) + (VARB1 * 1.3)) + (VAR611 * 0.68)) + (VAR71 * 0.68)) + (VAR81 * 0.68)) /6),21);

VARF1:=EMA((((((VARC1 * 3) + (VARD1 * 2)) + VARE1) / 6) * 1.738),21)*VAB3;

VAR101:=REF(LOW,1);

VAR111:=((SMA(ABS((LOW - VAR101)),3,1) / SMA(MAX((LOW - VAR101),0),3,1)) * 100);

VAR121:=EMA(IF(((CLOSE * 1.35) <= VARF1),(VAR111 * 10),(VAR111 / 10)),3)*VAB3;

VAR131:=LLV(LOW,30);

VAR141:=HHV(VAR121,30)*VAB3;

VAR151:=IF(MA(CLOSE,58),1,0);

VAR161:=((EMA(IF((LOW <= VAR131),((VAR121 + (VAR141 * 2)) / 2),0),3) / 618) * VAR151);

VAR171:=(((IF((VAR161 > 50),50,VAR161) / 20) * 15) * VART)*VAB3;

SG:=EMA(HHV(HIGH,1),8);

X1:=EMA(CLOSE,8);

X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));

X31:=IF(((SG < REF(SG,1)) OR X30),1,0);

LC:=REF(CLOSE,1);

{量化分析}

操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100,COLORRED,LINETHICK2;

趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,COLORGRAY;

震仓线:=45,COLORMAGENTA;

震仓线2:=50,COLORGRAY;

逃命线:=80,COLORRED;

抄底线:=20,COLORGREEN;

绝底线:=5,COLORBLUE;

PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;

PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;

PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线*VAB3;

鼎牛涨停狙击:(((((COUNT((X31 = 1),4) = 3) AND (X31 = 0))AND O<C AND (((C-REF(C,1))/REF(C,1))>0.085))*89) >=89)OR((C-REF(C,1))/REF(C,1)>0.085 AND (REF(PP3,1) OR REF(PP,1))) AND VAB3=1;

选股公式翻译

RSV赋值:(((收盘价 - 9日内最低价的最低值) / (9日内最高价的最高值 - 9日内最低价的最低值)) * 100)
短期底部赋值:30日内开盘价的最低值
AA10赋值:收盘价的10日简单移动平均
AA12赋值:收盘价的12日简单移动平均
BB10赋值:(((AA10-1日前的AA10)的反正切 * 3.1416) * 10)
BB12赋值:(((AA12-1日前的AA12)的反正切 * 3.1416) * 10)
MA13赋值:收盘价的13日简单移动平均
VAR2赋值:(((收盘价 - 收盘价的6日简单移动平均) / 收盘价的6日简单移动平均) * 100)
VAR3赋值:(((收盘价 - 收盘价的12日简单移动平均) / 收盘价的12日简单移动平均) * 100)
VAR4赋值:(((收盘价 - 收盘价的24日简单移动平均) / 收盘价的24日简单移动平均) * 100)
VAR5赋值:(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6)
VAR6赋值:VAR5的3日简单移动平均
VAR7赋值:以((成交量(手)的5日累和/3)/当前流通股本(手))为权重收盘价的12日指数移动平均的动态移动平均
VAR8赋值:(((收盘价 - VAR7) / VAR7) * 100)
VAR9赋值:((((1日前的VAR8 < (0 - 40)) AND (VAR8> 1日前的VAR8)) AND (1日前的VAR8 < 2日前的VAR8)) AND ((VAR8 - 1日前的VAR8)>2.5))
VARA赋值:(((收盘价 - 收盘价的6日简单移动平均) / 收盘价的6日简单移动平均) * 100)
VARB赋值:(((收盘价 - 收盘价的12日简单移动平均) / 收盘价的12日简单移动平均) * 100)
VARC赋值:(((收盘价 - 收盘价的24日简单移动平均) / 收盘价的24日简单移动平均) * 100)
VARD赋值:1日前的收盘价
VARE赋值:(((收盘价-VARD)和0的较大值的5日[1日权重]移动平均 / (收盘价-VARD)的绝对值的5日[1日权重]移动平均) * 100)
VARF赋值:(((最高价 + 最低价) + 收盘价) / 3)
VAR10赋值:((VARF - VARF的14日简单移动平均) / (0.015 * VARF的14日平均绝对偏差))
VAR11赋值:(((((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的110日简单移动平均 / 成交量(手)的110日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100))< (0 - 0.273))
VAR12赋值:(((收盘价 - 收盘价的30日简单移动平均) / 收盘价的30日简单移动平均) < (0 - 0.125))
VAR13赋值:(VAR11 AND VAR12)
VAR14赋值:((((VARA>= (0 - 45)) AND (VARA <= (0 - 10))) AND (VARB <= (0 - 15))) AND (VARC <= (0 - 20)))
VAR15赋值:(统计1日中满足VAR14的天数>= 1)
VAR16赋值:(VAR13 AND VAR15)
VAR17赋值:1
VAB0赋值:531
VAB1赋值:1510000
VAB2赋值:VAB0 + VAB1
VAB3赋值:如果日期>VAB2,返回0,否则返回1
VARA12赋值:最高价的10日[9日权重]移动平均*VAB3
VARA13赋值:最低价的10日[9日权重]移动平均*VAB3
VAR18赋值:(收盘价 * 成交量(手))
VAR19赋值:(((((VAR18的4日简单移动平均/成交量(手)的4日简单移动平均)+(VAR18的6日简单移动平均/成交量(手)的6日简单移动平均))+(VAR18的13日简单移动平均/成交量(手)的13日简单移动平均))+(VAR18的24日简单移动平均/成交量(手)的24日简单移动平均))/4)的1日指数移动平均
VAR1A赋值:(1 * VAR19)
VAR1B赋值:(VAR19 * 0.92)
VAR1C赋值:收盘价的34日指数移动平均
VAR1D赋值:(VAR1C*1.12)的5日简单移动平均
VAR1E赋值:(VAR1C*0.82)的5日简单移动平均
VAR1F赋值:(收盘价 < VAR1E)
VAR20赋值:((((((成交额(元)的5日简单移动平均 * VAR17) / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的125日简单移动平均 / 成交量(手)的125日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100)) < ((0 - 0.4) * VAR17))
VAR21赋值:500日内最高价的最高值
VAR22赋值:500日内最低价的最低值
VAR23赋值:250日内最高价的最高值
VAR24赋值:250日内最低价的最低值
VAR25赋值:125日内最高价的最高值
VAR26赋值:125日内最低价的最低值
VAR27赋值:((((((VAR21*0.45)+(VAR23*0.5))+VAR22)+VAR24)+VAR26)/5)的35日简单移动平均
VAR28赋值:(((VAR23*0.62)+VAR26)/2)的35日简单移动平均
VAR29赋值:(((VAR23*0.75)+VAR26)/2)的18日简单移动平均
VAR2A赋值:(((((VAR23*0.93)+(VAR27*2))+(VAR28*1.8))+(VAR29*1.5))/4)的18日简单移动平均
VAR2B赋值:((((VAR21*0.95)+(VAR27*3))+(VAR28*2))/3)的35日简单移动平均
VAR2C赋值:VAR27
VAR2D赋值:VAR28
VAR2E赋值:VAR29
VAR2F赋值:VAR2A
VAR30赋值:VAR2B
VAR31赋值:((收盘价 - 11日前的收盘价的20日简单移动平均) < (0 - 2))
VAR32赋值:(大盘的成交额 / 100000000)
VAR33赋值:大盘的上涨家数
VAR34赋值:大盘的下跌家数
VAR35赋值:((VAR18 / (VAR18 + VAR19)) * VAR17)
VAR36赋值:((VAR19 / (VAR18 + VAR19)) * VAR17)
VAR37赋值:VAR35的10日指数移动平均
VAR38赋值:VAR36的10日指数移动平均
VAR39赋值:VAR37的10日指数移动平均
VAR3A赋值:VAR38的20日指数移动平均
VAR3B赋值:VAR37的3日指数移动平均
VAR3C赋值:VAR39的6日指数移动平均
VAR3D赋值:VAR3A的2日指数移动平均
VAR3E赋值:(VAR3C - VAR3D)
VAR3F赋值:(((VAR3C - 1日前的VAR3C)> 0) AND ((1日前的VAR3C - 2日前的VAR3C) < 0))
VAR40赋值:如果(VAR3B上穿VAR3CAND(VAR3C<=20)),返回30,否则返回0
VAR41赋值:VAR40
VAR42赋值:(((成交额(元)/成交量(手))/100)的13日[1日权重]移动平均 * 1.15)
VAR43赋值:(((成交额(元)/成交量(手))/100)的13日[1日权重]移动平均 * 0.85)
VAR44赋值:(收盘价 - 11日前的收盘价的20日简单移动平均)
VAR45赋值:(((((((((((((收盘价 < VAR1E) AND VAR20) AND (收盘价 < VAR43)) OR (((收盘价 < VAR1E) AND VAR31) AND VAR20)) OR ((收盘价 = (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)))
VAR51赋值:(统计1日中满足VAR50的天数>= 1)
VAR52赋值:(VAR4F AND VAR51)
VAR53赋值:(((((VAR20 AND (收盘价 < VAR1E)) AND VAR31) AND (收盘价 < VAR2C)) AND VAR45) AND VAR52)
VAR54赋值:(((收盘价 - 收盘价的6日简单移动平均) / 收盘价的6日简单移动平均) * 100)
VAR55赋值:(((收盘价 - 收盘价的12日简单移动平均) / 收盘价的12日简单移动平均) * 100)
VAR56赋值:(((收盘价 - 收盘价的24日简单移动平均) / 收盘价的24日简单移动平均) * 100)
VAR57赋值:1日前的收盘价
VAR58赋值:(((收盘价-VAR57)和0的较大值的5日[1日权重]移动平均 / (收盘价-VAR57)的绝对值的5日[1日权重]移动平均) * 100)
VAR59赋值:(((最高价 + 最低价) + 收盘价) / 3)
VAR5A赋值:((VAR59 - VAR59的14日简单移动平均) / (0.015 * VAR59的14日平均绝对偏差))
VAR5B赋值:((((((VAR54>= (0 - 15.8)) AND (VAR54 <= (0 - 12.2))) AND (VAR55 <= (0 - 20.8))) AND (VAR56 <= (0 - 27.5))) AND (VAR58<= 11.7)) AND (VAR5A <= (0 - 145)))
VAR5C赋值:9.999999884842+026
VAR5D赋值:(获利盘为10%的成本分布 * 0)*VAB3
VAR5E赋值:((((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的125日简单移动平均 / 成交量(手)的125日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100))
VAR5F赋值:(((45日内最低价的最低值-收盘价)/(45日内最高价的最高值-45日内最低价的最低值))*100)的5日简单移动平均
VAR60赋值:(((0-5)上穿VAR5F AND (VAR5E < (0 - 0.4))) AND (((收盘价 - 收盘价的30日简单移动平均) / 收盘价的30日简单移动平均) < (0 - 0.19)))
VAR61赋值:收盘价的3日简单移动平均
VAR62赋值:(2日前的收盘价 * 0.865)
VAR63赋值:(13日前的收盘价 * 0.772)
VAR64赋值:VAR62和VAR63的较小值
VAR65赋值:((100 * 成交量(手)) / 当前流通股本(手))
VAR66赋值:收盘价的13日简单移动平均
VAR67赋值:如果((((收盘价-VAR64)/收盘价)<0.03)AND((VAR65的5日累和/5)<1.8)),返回1,否则返回0
开始控盘赋值:当满足条件(VAR6<=(0-10))时,在0和(0-20)位置之间画柱状线,宽度为5,0不为0则画空心柱.*VAB3,画棕色
出击赋值:如果((((VAR9ORVAR16)ORVAR53)ORVAR5B)OR((((收盘价-VAR64)/收盘价)<0.03)AND((VAR65的5日累和/5)<1.8))),返回120,否则返回0,线宽为2,COLOR0000FF
VAR68赋值:0
VARQ赋值:收盘价的152日简单移动平均
VARW赋值:收盘价的194.16日简单移动平均
VAREE赋值:(VARW + (2 * 收盘价的170日估算标准差))
VARR赋值:(VARQ + (2 * 收盘价的170日估算标准差))
VART赋值:如果(日期>1080822),返回0,否则返回1
VAR611赋值:500日内最高价的最高值的21日指数移动平均
VAR71赋值:250日内最高价的最高值的21日指数移动平均
VAR81赋值:90日内最高价的最高值的21日指数移动平均
VAR91赋值:500日内最低价的最低值的21日指数移动平均
VARA1赋值:250日内最低价的最低值的21日指数移动平均
VARB1赋值:90日内最低价的最低值的21日指数移动平均
VARC1赋值:(((((((VAR91*0.96)+(VARA1*0.96))+(VARB1*0.96))+(VAR611*0.558))+(VAR71*0.558))+(VAR81*0.558))/6)的21日指数移动平均
VARD1赋值:(((((((VAR91*1.25)+(VARA1*1.23))+(VARB1*1.2))+(VAR611*0.55))+(VAR71*0.55))+(VAR81*0.65))/6)的21日指数移动平均
VARE1赋值:(((((((VAR91*1.3)+(VARA1*1.3))+(VARB1*1.3))+(VAR611*0.68))+(VAR71*0.68))+(VAR81*0.68))/6)的21日指数移动平均
VARF1赋值:(((((VARC1*3)+(VARD1*2))+VARE1)/6)*1.738)的21日指数移动平均*VAB3
VAR101赋值:1日前的最低价
VAR111赋值:(((最低价-VAR101)的绝对值的3日[1日权重]移动平均 / (最低价-VAR101)和0的较大值的3日[1日权重]移动平均) * 100)
VAR121赋值:如果((收盘价*1.35)<=VARF1),返回(VAR111*10),否则返回(VAR111/10)的3日指数移动平均*VAB3
VAR131赋值:30日内最低价的最低值
VAR141赋值:30日内VAR121的最高值*VAB3
VAR151赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR161赋值:((如果(最低价<=VAR131),返回((VAR121+(VAR141*2))/2),否则返回0的3日指数移动平均 / 618) * VAR151)
VAR171赋值:(((如果(VAR161>50),返回50,否则返回VAR161 / 20) * 15) * VART)*VAB3
SG赋值:1日内最高价的最高值的8日指数移动平均
X1赋值:收盘价的8日指数移动平均
X30赋值:((X1 < 1日前的X1) AND (收盘价 < X1))
X31赋值:如果((SG<1日前的SG)ORX30),返回1,否则返回0
LC赋值:1日前的收盘价
操作线赋值:收盘价-LC和0的较大值的2日[1日权重]移动平均/收盘价-LC的绝对值的2日[1日权重]移动平均*100,画红色,线宽为2
趋势线赋值:收盘价-LC和0的较大值的14日[1日权重]移动平均/收盘价-LC的绝对值的14日[1日权重]移动平均*100,画深灰色
震仓线赋值:45,画洋红色
震仓线2赋值:50,画深灰色
逃命线赋值:80,画红色
抄底线赋值:20,画绿色
绝底线赋值:5,画蓝色
PP2赋值:操作线<震仓线2 AND 1日前的操作线>震仓线2
PP赋值:操作线<震仓线 AND 1日前的操作线>震仓线
PP3赋值:操作线<抄底线 AND 1日前的操作线>抄底线*VAB3
输出鼎牛涨停狙击:(((((统计4日中满足(X31=1)的天数 = 3) AND (X31 = 0))AND 收阳线AND (((收盘价-1日前的收盘价)/1日前的收盘价)>0.085))*89)>=89)OR((收盘价-1日前的收盘价)/1日前的收盘价>0.085 AND (1日前的PP3 OR 1日前的PP)) AND VAB3=1

演示图片

鼎牛涨停狙击选股公式