首页 > 选股公式 > 妖中妖选股公式

妖中妖选股公式

日期:2022-05-03 10:04:48

选股公式源码

MA10:=MA(CLOSE,10);

MA54:=MA(CLOSE,54);

HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;

HJ_9:=FILTER(HJ_8,10);

HJ_10:=BArslAst(HJ_9);

HJ_11:=REF(HIGH,HJ_10+2);

HJ_12:=REF(HIGH,HJ_10+1);

HJ_13:=REF(HIGH,HJ_10);

HJ_14:=MAX(HJ_11,HJ_12);

HJ_15:=MAX(HJ_14,HJ_13);

HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;

HJ_17:=HJ_10<150;

HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;

HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;

HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;

HJ_21:=VOL/MA(VOL,5)<3.5;

HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;

HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;

暴利:=FILTER(HJ_25,15);

PL1:=(((CLOSE-MA54)/MA54)<0.1);

PL2:=(((CLOSE-MA10)/MA10)<0.3);

偏离率:=(((PL1=1) AND (PL2=1))*0.2);

平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);

妖股突破:=平台突破=-0.1;

XDF:=(暴利 OR 妖股突破);

VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

VARAA:=C/(REF(CLOSE,1))>1.05 AND (C/O>1.05);

FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);

强妖:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA;

XA_1:=VOL/REF(MA(VOL,5),1);

XA_2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

XA_3:=HIGH;

XA_4:=REF(HIGH,1);

XA_5:=CLOSE;

XA_6:=LOW;

XA_7:=REF(CLOSE,1);

XA_8:=MA(CLOSE,5);

XA_9:=MA(CLOSE,10);

XA_10:=MA(CLOSE,20);

XA_11:=MA(CLOSE,30);

XA_12:=MA(CLOSE,60);

XA_13:=MA(XA_5,120);

XA_14:=XA_5>XA_8;

XA_15:=XA_5>XA_9;

XA_16:=XA_5>XA_10;

XA_17:=XA_5>XA_11;

XA_18:=XA_5>XA_12;

XA_19:=XA_5>MA(XA_5,88);

太妖:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>=9.93;

妖中妖: 太妖 AND 强妖;

选股公式翻译

MA10赋值:收盘价的10日简单移动平均
MA54赋值:收盘价的54日简单移动平均
HJ_8赋值:(3日前的收盘价-收盘价)/3日前的收盘价*100>5
HJ_9赋值:HJ_8的10日过滤
HJ_10赋值:上次HJ_9距今天数
HJ_11赋值:HJ_10+2日前的最高价
HJ_12赋值:HJ_10+1日前的最高价
HJ_13赋值:HJ_10日前的最高价
HJ_14赋值:HJ_11和HJ_12的较大值
HJ_15赋值:HJ_14和HJ_13的较大值
HJ_16赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>5
HJ_17赋值:HJ_10<150
HJ_18赋值:(开盘价-HJ_15)/HJ_15*100<30
HJ_19赋值:(收盘价-HJ_10日内最低价的最低值)/HJ_10日内最低价的最低值*100<50
HJ_20赋值:(收盘价-5日前的开盘价)/5日前的开盘价*100<30
HJ_21赋值:成交量(手)/成交量(手)的5日简单移动平均<3.5
HJ_22赋值:(收盘价-89日前的收盘价)/89日前的收盘价*100<80
HJ_25赋值:HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22
暴利赋值:HJ_25的15日过滤
PL1赋值:(((收盘价-MA54)/MA54)<0.1)
PL2赋值:(((收盘价-MA10)/MA10)<0.3)
偏离率赋值:(((PL1=1) AND (PL2=1))*0.2)
平台突破赋值:((((偏离率=0) AND (1日前的偏离率=0.2)) AND (1日前的(统计10日中满足(偏离率=0.2)的天数=10)=1))*-0.1)
妖股突破赋值:平台突破=-0.1
XDF赋值:(暴利 OR 妖股突破)
VARA赋值:以成交量(手)/当前流通股本(手)为权重成交额(元)/成交量(手)/100的动态移动平均
VARAA赋值:收盘价/(1日前的收盘价)>1.05 AND (收盘价/开盘价>1.05)
FLIGA赋值:(成交量(手)/1日前的成交量(手)>1.2 AND 统计1日中满足收阳线的天数) OR (最低价>1日前的最高价 AND 统计1日中满足收阴线的天数 AND 成交量(手)/1日前的成交量(手)>1.2)
强妖赋值:XDF AND 收盘价/1日前的收盘价>1.095 AND FLIGA AND VARAA
XA_1赋值:成交量(手)/1日前的成交量(手)的5日简单移动平均
XA_2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
XA_3赋值:最高价
XA_4赋值:1日前的最高价
XA_5赋值:收盘价
XA_6赋值:最低价
XA_7赋值:1日前的收盘价
XA_8赋值:收盘价的5日简单移动平均
XA_9赋值:收盘价的10日简单移动平均
XA_10赋值:收盘价的20日简单移动平均
XA_11赋值:收盘价的30日简单移动平均
XA_12赋值:收盘价的60日简单移动平均
XA_13赋值:XA_5的120日简单移动平均
XA_14赋值:XA_5>XA_8
XA_15赋值:XA_5>XA_9
XA_16赋值:XA_5>XA_10
XA_17赋值:XA_5>XA_11
XA_18赋值:XA_5>XA_12
XA_19赋值:XA_5>XA_5的88日简单移动平均
太妖赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>=9.93
输出妖中妖: 太妖 AND 强妖

演示图片

妖中妖选股公式